reboot: noisy if /proc/ide doesn't exist

Bug #92685 reported by Colin Watson on 2007-03-15
40
This bug affects 3 people
Affects Status Importance Assigned to Milestone
upstart
Wishlist
Scott James Remnant (Canonical)
upstart (Ubuntu)
Wishlist
Unassigned
Nominated for Jaunty by Martin Plaček

Bug Description

Binary package hint: upstart

On a system with no IDE controller and thus no /proc/ide, I get this on shutdown:

  halt: Unable to iterate IDE devices: No such file or directory

/etc/init.d/halt always uses 'halt -h' unless you're using RAID. Maybe it should avoid that if /proc/ide is missing? Or maybe this code should just be removed from upstart:

22:52 <cjwatson> ps3 doesn't seem to have an IDE controller; is upstart's warning message about that too loud maybe?
23:04 <Keybuk> err?
23:04 <Keybuk> upstart shouldn't have a warning about that
23:04 <Keybuk> what warning are you seeing?
23:04 <Keybuk> (why would upstart need an IDE controller?)
23:05 <cjwatson> "halt: Unable to iterate IDE devices: No such file or directory"
23:06 <Keybuk> oh
23:06 <Keybuk> heh
23:06 <Keybuk> interesting question of style that one
23:07 <Keybuk> since you did call halt with -h ("put disks into standby"), it seems potentially wrong to not warn that it didn't work
23:07 <Keybuk> (as apposed to default behaviour)
23:07 <Keybuk> doesn't sysvinit do the same?
23:07 <cjwatson> I have no idea, never run sysvinit on this machine
23:08 <Keybuk> I'm determined that that option is entirely pointless
23:08 <Keybuk> but too scared to find out :p
23:08 <Keybuk> both downing drives and interfaces should be things the kernel does these days
23:09 <Keybuk> file a bug plz :p
23:09 <cjwatson> maybe /etc/init.d/halt should check whether /proc/ide exists before using -h
23:10 <cjwatson> sysvinit's halt man page says that the kernel doesn't flush the write cache itself before poweroff
23:10 <cjwatson> and that that's the side-effectual purpose of putting the drive in standby
23:12 <Keybuk> kernel source disagrees
23:12 <Keybuk> ide_device_shutdown calls ide_cacheflush_p()
23:12 <cjwatson> yeah, could be a more recent change
23:13 <Keybuk> the sysvinit halt manpage is what, 5 years old?
23:13 <cjwatson> dated Nov 6, 2001
23:17 <Keybuk> I'll get Ben to tell me for sure whether that's needed anymore, I'm not 100% sure, or fix the warning on missing /proc/ide

Changed in upstart:
importance: Undecided → Wishlist
status: Unconfirmed → Confirmed
Changed in upstart:
importance: Undecided → Wishlist
status: Unconfirmed → Confirmed

Rejecting Ubuntu task since this is an upstream problem.

Interestingly we've read through the kernel source, and are now convinced that the IDE subsystem does flush the caches and power down the disks on halt.

And we've had a long conversation with the libata maintainers, who have made the same changes to libata so it too flushes caches and powers down the disks.

So reboot needs to do none of this.

Changed in upstart:
status: Confirmed → Rejected
Changed in upstart:
status: Confirmed → Triaged
Changed in upstart:
milestone: 0.5 → none
Changed in upstart:
status: Invalid → Triaged
Changed in upstart:
milestone: none → 0.5-later
Martin Plaček (placek-martin) wrote :

I have this problem too and it helped mi to edit the file called "halt".

Renato Candido (renatocan) wrote :

I also have this problem. Everytime I shut down Ubuntu I have to press a key in order to turn off the computer.

Ralf Jung (ralfjung-e) wrote :

I've got the same issue in Kubuntu Jaunty, too. The PC shuts down normally, but that message indicates that something is wrong and I have no clue if that is the case or not.

Bo Lundberg (bo-lundberg) wrote :

Same problem in Kubuntu 9.04. Same message show up before shutdown. Same problem in Ubuntu 9.04 but there is now message.
In both cases everything seems to shut down ok. except the mouse and KVM switch.
So with the computer turned off the mouse and KVM switch is still active. The only way around this seems to be use of the psu switch.

Changed in upstart:
milestone: 0.5-later → none
summary: - noisy halt if /proc/ide doesn't exist
+ reboot: noisy if /proc/ide doesn't exist
Changed in upstart:
status: Triaged → Fix Committed

Preparing packages of Upstart 0.6.0 for karmic

Changed in upstart (Ubuntu):
status: Triaged → In Progress
Changed in upstart:
milestone: none → 0.6.0
Download full text (6.7 KiB)

This has been fixed in Upstart 0.6.0.

0.6.0 2009-07-09 "How appropriate, you fight like a cow"

 * The licence for Upstart has been changed back to version 2 of the
   GNU GPL.

 * D-Bus 1.2.15 is now required, this is the current GIT HEAD
   pending a 1.2.16 release.

 * Configuration paths have changed. Global configuration now
   resides in "/etc/init.conf" while jobs are now configured in
   "/etc/init"

 * Job configuration filenames must now end in ".conf"

 * Default configuration files are now supplied in the "conf"
   sub-directory of the source, and installed into "/etc/init".

   These match the Debian/Ubuntu sysvinit configuration so may
   require some tweaking for other distributions, but provide an
   excellent base.

   The old example-jobs tarballs are deprecated.

 * The D-Bus interface remains unstable, to reflect this the current
   interface name has changed to "com.ubuntu.Upstart0_6" and the
   name of the job and instance interfaces have changed to match.

 * The "EmitEvent" D-Bus method gains a wait argument, when given
   as TRUE (the recommended setting) the method call will be blocked
   until all effects of the event have finished. When FALSE the
   method call will return once the event has been queued.

 * The "Start", "Stop" and "Restart" D-Bus methods of jobs and
   instances gain a similar wait argument.

 * The Upstart D-Bus object now has "version" and "log_priority"
   properties. The former is to obtain the version of the init daemon,
   the latter allows you to obtain and change the logging priority.

 * Job D-Bus objects now have "name", "description", "author" and
   "version" properties to obtain the job name and the contents of
   the equivalent job file fields for the others.

 * Instance D-Bus objects now have "name", "goal", "state" and
   "processes" properties to obtain the instance name, goal, state
   and list of running processes and their pids respectively.

 * The default D-Bus security policy now permits use of the "Get"
   methods by all users, including obtaining values of properties.

 * initctl has been rewritten with functionality more along the
   lines of Upstart 0.3.x than before; since many distributions are
   still shipping 0.3.x the summary of changes for the tool reflects
   both changes from 0.3.x and 0.5.x

 * The global "-p"/"--pid" argument has been dropped, since
   communication is over D-Bus. New "--system" and "--dest" arguments
   have been added to force communication over the system bus, and
   specify the destination, instead of using the private socket (this
   is the default when run as non-root to permit "list" and "status"
   to work for ordinary users).

 * The "-i"/"--id" and "--show-ids" options to commands have been
   dropped since jobs no longer have ids.

 * Since instances may now have names, these will be displayed in
   brackets after the job name when one is present. The output of
   the goal and state are now expressed as "start/running" instead
   of "(start) running" to disambiguate.

 * initctl "start" and "stop" now only output the final state of
   the job, not inte...

Read more...

Changed in upstart:
assignee: nobody → Scott James Remnant (scott)
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package upstart - 0.6.0-1

---------------
upstart (0.6.0-1) karmic; urgency=low

  * New upstream release ("How appropriate, you fight like a cow")
    - my customary changes list since pointless, it's basically a
      complete rewrite.
    - Handles /bin/sh symlink disappearing. LP: #65024.
    - Boot parameters may be passed to init scripts. LP: #74664.
    - reboot implies --force during shutdown. LP: #388738.
    - reboot no longer iterates /proc/ide. LP: #92685.
    - much improved documentation. LP: #60429, #72058, #388715.

  * Merge the various upstart packages into a single package, it makes
    little sense to have it all spread out.

 -- Scott James Remnant <email address hidden> Wed, 08 Jul 2009 23:12:03 +0100

Changed in upstart (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers