No 2 Minute pause at login for Server Boot in Ubuntu Desktop

Bug #886414 reported by Masi on 2011-11-05
44
This bug affects 7 people
Affects Status Importance Assigned to Milestone
upstart
Undecided
Unassigned
upstart (Ubuntu)
Undecided
Unassigned

Bug Description

SpamapS and Scott Moser made the system to wait a few minutes at the login at the expense of Desktop users, for the benefit of Server users. I propose that we separate Ubuntu Server from Ubuntu Desktop completely. I have received a lot negative feedback about the change in 11.10. A related discussion about the problem here http://askubuntu.com/questions/63456/waiting-for-network-configuration-adding-3-to-5-minutes-to-boot-time

/etc/networks/interface

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: xorg 1:7.6+7ubuntu7
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic i686
ApportVersion: 1.23-0ubuntu3
Architecture: i386
Date: Sat Nov 5 02:54:23 2011
InstallationMedia: Ubuntu 10.04.1 LTS "Lucid Lynx" - Release i386 (20100816.1)
ProcEnviron:
 LANGUAGE=en
 PATH=(custom, User Name)
 LANG=en_GB.UTF-8
 LC_MESSAGES=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: xorg
Symptom: display
Title: Xorg freeze
UpgradeStatus: Upgraded to oneiric on 2011-10-18 (17 days ago)

Masi (soopo) wrote :
Changed in xorg (Ubuntu):
status: New → Invalid
Masi (soopo) wrote :

The bug is a desing bug: separate Ubuntu Server completely from Ubuntu Desktop. It is not in Xorg.

Yongzhi Pan (fossilet) wrote :

This is annoying when I want to configure network interfaces via interfaces(5). Network Manager can do just a little simple configuration. Why should this even be call by the developer a feature?

affects: xorg (Ubuntu) → ubuntu
Changed in ubuntu:
status: Invalid → Opinion
status: Opinion → Incomplete
affects: ubuntu → upstart (Ubuntu)
Yongzhi Pan (fossilet) on 2011-11-17
Changed in upstart:
status: New → Incomplete
Henrik Ingo (hingo) wrote :

This bug was marked as a duplicate of #856810 but it is not. This bug is about a laptop/desktop user having to wait at boot time. The other is about system failing to start at all.

Leo Unglaub (leo-unglaub) wrote :

Henrik is right. It's not only the server version of ubuntu. It affects also normal Laptop users and it's realy anoying to wait every boot for 90 secounds.

Changed in upstart (Ubuntu):
status: Incomplete → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in upstart (Ubuntu):
status: New → Confirmed
Steve Langasek (vorlon) wrote :

Just because a system is a desktop system doesn't mean that it's ok to have an unreliable boot sequence. You will only see delays in boot if you have misconfigured /etc/network/interfaces. So if you want a faster boot, fix your network config...

Changed in upstart:
status: Incomplete → Invalid
Changed in upstart (Ubuntu):
status: Confirmed → Won't Fix
tenuki (tenuki) wrote :

Ok, and there's a way to configure how many retries are done?

Perhaps, in my network i've found that reliability is greatly improved by setting up retries to be done for 3 minutes.

Steve Langasek (vorlon) wrote :

What "retries" are you talking about? The system doesn't retry anything related to networking, generally, except for dhcp. Most of this time is just spent waiting for the devices to be configured - in the case of a broken configuration in /etc/network/interfaces, this is waiting for devices that will never *be* configured, which is why there's a timeout.

tenuki (tenuki) wrote :

Steve: I'm sorry i was thinking with the contextual information from the link in the bug-report which refers to the dhcp retries.

Indeed, in my case is due to dhcp, perhaps i'm missing something, but that happened when not using network-manager and having configured dhcp for some of the networks i use.

Before this release, I had no problems related to network configuration with my notebook. But since update, it started to show that the network isn't available and explicitly waiting some minutes.

I don't care if it is related to retries or a timeout. But if it's decided that in some environment it would be useful for reliability sake to have such timeout, it would be great to improve this feature with some option, like:
- a place where to configure it, enabling the feature be useful in other scenarios, or
- allow the user to skip the timeout, like when fsck fails for some drive.

just my point of view.
tenuki

Henrik Ingo (hingo) wrote :

Steve, what do you mean invalid? What do you mean with unreliable boot sequence?

I have a laptop. I take it onto a business trip. I want to work on the airplane. There is no internet connection within miles. That (K)Ubuntu wants to wait for several minutes until it accepts the fact that there is no internet is a bug.

I could understand if I have plugged in a cable and have an ethernet link (green blinkenlight), but not yet a dhcp configured ip address. Then it makes sense to wait for a while. But if there is no cable plugged and no wifi configured+found, what are you waiting for? A miracle?

Masi (soopo) wrote :

Steve says that the delay occurs "[only] if you have misconfigured /etc/network/interfaces. So if you want a faster boot, fix your network config - -."

Your clause is wrong if you we assume that /etc/network/interfaces are configured correctly in the fresh installation. The delay occurs also with a fresh Ubuntu 11.04 installation in every laptop which I have tried: Thinkpad Lenovo X60, Thinkpad Lenovo X60s and Thinkpad T30, for instance. No cable plugged and no wifi configured similarly as with Henrik.

So the /etc/network/interfaces is configured by default wrongly in the fresh installation for laptop users. The delay should not be default for laptop users like Henrik says.

So I propose that the Status will be changed from "won't fix" to "Confirmed".

Steve Langasek (vorlon) wrote :

Please attach the /etc/network/interfaces from the affected system. If there are delays with the stock file as shipped in any of our releases, that's definitely something that we need to clean up; but that's not something that anyone ran into during development, and not what the original bug report describes.

Masi (soopo) wrote :

@Steve I will du it in the middle of February as I am back in the university then from holiday. Yes, the delays are with the stock file.

Henrik Ingo (hingo) wrote :

FWIW, here's my

$ cat /etc/network/interfaces
auto lo
iface lo inet loopback

Note that:

 - this is not from fresh install but the system was upgraded a few times from previous Kubuntu versions, I don't know how much the file has lived on since then.

 - I'm actually not sure my system suffers from this bug. (I can check tomorrow, building something right now...) The wait may have disappeared after I checked the "System connection" box in Kubuntu > System Settings > Network Settings > Network Connections > Wireless > [my wlan] > Edit...

After upgrade until I checked "System connection" the text appeared at every boot.

On Fri, Jan 06, 2012 at 09:00:03PM -0000, Henrik Ingo wrote:
> Steve, what do you mean invalid?

An interfaces file that lists an interface as 'auto' which will not be
available at boot time.

> What do you mean with unreliable boot sequence?

Not waiting for the configured network interfaces to come up means that any
services installed on the system that require a network will fail at boot
time. This makes for an unreliable boot.

> I have a laptop. I take it onto a business trip. I want to work on the
> airplane. There is no internet connection within miles. That (K)Ubuntu
> wants to wait for several minutes until it accepts the fact that there
> is no internet is a bug.

That's true, but not because of a wrong design conflating servers and
desktops. Your boot should NOT wait several minutes before accepting that
there's no Internet connection; the failsafe job is there to make sure the
system continues to boot when something ELSE has already gone wrong. That
something could be a bug in Ubuntu, or it could be a broken
/etc/network/interfaces file, or some other kind of local breakage.

On Fri, Jan 06, 2012 at 10:29:42PM -0000, Henrik Ingo wrote:
> FWIW, here's my

> $ cat /etc/network/interfaces
> auto lo
> iface lo inet loopback

Please show the output of this command:

$ ls -ld /var/run

> - I'm actually not sure my system suffers from this bug.

Well, it would be good to confirm whether this is the case currently or not.

--
Steve Langasek Give me a lever long enough and a Free OS
Debian Developer to set it on, and I can move the world.
Ubuntu Developer http://www.debian.org/
<email address hidden> <email address hidden>

Henrik Ingo (hingo) wrote :

> Well, it would be good to confirm whether this is the case currently or not.

Hi

Finally had time to test this again.

I deleted my Wifi configuration from my laptop. The "Waiting for network connection..." text doesn't come back anymore.

I also had one more laptop that wasn't yet updated to 11.10. This was a good reason to update it. In this case the "Waiting for network connection..." text didn't appear at any point (also some other upgrade errors unrelated to this bug that I've seen didn't happen, guess it was my lucky day).

I have previously updated 2 laptops to Kubuntu 11.10 and in those cases the erroneous behavior went away after configuring a system wifi connection, as I described above - just wanted to repeat that as a useful fix for people that may read this.

I'm no longer able to reproduce the bug, so I suppose for my part I have nothing more to contribute. But it did happen 2 out of 3 upgrades.

goto (gotolaunchpad) wrote :

This bug is ridiculous. Won't Fix? And no kidding?!?

"I don't care if it is related to retries or a timeout. But if it's decided that in some environment it would be useful for reliability sake to have such timeout, it would be great to improve this feature with some option, like:
- a place where to configure it, enabling the feature be useful in other scenarios, or
- allow the user to skip the timeout, like when fsck fails for some drive."

100% agree.

At least allow to skip the waiting using STRG + C !!!

Keep on posting and commenting this bug. The current behavior is intolerable.

Steve Langasek (vorlon) wrote :

On Thu, Feb 23, 2012 at 09:20:47PM -0000, goto wrote:
> This bug is ridiculous. Won't Fix? And no kidding?!?

Yes, we are not going to "fix" the system in a way that causes the user's
configured and installed services to arbitrarily fail to start correctly on
boot because of a network startup delay.

> "I don't care if it is related to retries or a timeout. But if it's
> - decided that in some environment it would be useful for reliability sake
> - to have such timeout, it would be great to improve this feature with
> - some option, like: a place where to configure it, enabling the feature
> - be useful in other scenarios, or allow the user to skip the timeout,
> - like when fsck fails for some drive."

> 100% agree.

If someone were to submit a patch that implemented this, I would be amenable
to applying it. I will not, however, be working on this patch myself,
because seeing this message is a *symptom* of a system misconfiguration.

> At least allow to skip the waiting using STRG + C !!!

> Keep on posting and commenting this bug. The current behavior is
> intolerable.

Making a nuisance of yourself to the developers is not going to get you
anywhere. I suggest you instead try reading the bug log, *understanding*
why this is a configuration error on your system rather than a bug in
Ubuntu and how you can fix it, and letting us know afterwards if you still
think there's something here that Ubuntu should be fixing (and can
reasonably fix).

--
Steve Langasek Give me a lever long enough and a Free OS
Debian Developer to set it on, and I can move the world.
Ubuntu Developer http://www.debian.org/
<email address hidden> <email address hidden>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers