Disabling network-interface break rc-sysinit compatibility script

Bug #886205 reported by Marco Gaiarin on 2011-11-04
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
upstart (Ubuntu)
Undecided
Unassigned

Bug Description

I've upgraded an ubuntu server installation from hardy to lucid, moving indeed from sysV-init to upstart.
I use in this server a custom set of iptables script that i run from /etc/network/if-up.d/*, and after rebooting the server nothing seems to work.

After some panic, i've found the culprit: simply my script suppose that interfaces are brought up in the exact order they are written in /etc/network/interfaces (this is a server, clearly they have static ip addresses...), but upstart (better: the network-interface script) instead brought up the interface in mixed/casual order.

So, i've commented out the 'start on' and 'stop on' rows on network-interface.conf, but now the machine boot with correct interface order (and so, correct iptables rules) but with little or no service available.

Again, some panic, some work and i've found that the ''sysv compatibility scripts'' depends only on dynamic interfaces, not static ones.

Patch attached that solve the problem. Thanks.

PS: i've tried to read the upstart documentation to understand if there's a better way to ''serialize'' network interface brought up. So probably my patch solve my problem in a wrong way. Please, say me if it is the case...

Marco Gaiarin (marcogaio) wrote :

The attachment "rc-sysinit.conf.diff" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-sponsors please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Evan Broder (broder) wrote :

Hi Marco -

Thanks for your patch. We've actually already modified the rc-sysinit job in Oneiric to delay running legacy init.d jobs until after networking was up via the new /etc/init/failsafe.conf job. I'm going to mark this bug as a duplicate of that one.

Marco Gaiarin (marcogaio) wrote :

Ok, many thanks. Note thate i've posted the WRONG patch, it is not 'starting networking' but 'started networking', as stated in #580319; i've simply make the patch against the wrong file (a previous test), sorry. So, i post comment here.

I've seen #580319, but still i have some trouble caused by openvpn, and some other services that depends on openvpn interfaces bought up.
But i don't define the openvpn interfaces on /etc/network/interfaces file, so probably will suffices to add stanzas to that file.

I will do some tries and report there. Tnx.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers