Comment 54 for bug 881079

Mark - Syminet (mark-syminet) wrote :

I'm getting exactly these symptoms after a test upgrade from vanilla Lucid -> Precise.

Upon reboot, the iface is indeed reachable and I can ssh into it within about 10 seconds but
on the monitor it says "Waiting up to 60 more seconds for network configuration..." error,
and hangs there for a full minute. The /etc/network/interfaces contains all necessary info,
worked perfectly fine in Lucid, and the interface is indeed reachable the whole time:

root@19r8s12:/etc# ifconfig eth0
eth0 Link encap:Ethernet HWaddr 54:52:00:08:ea:ee
          inet addr:192.168.1.181 Bcast:192.168.1.255 Mask:255.255.255.0
          inet6 addr: fe80::5652:ff:fe08:eaee/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
          RX packets:377 errors:0 dropped:0 overruns:0 frame:0
          TX packets:122 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:27347 (27.3 KB) TX bytes:16381 (16.3 KB)
          Interrupt:10 Base address:0x6000

root@19r8s12:/etc# cat /etc/network/interfaces

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth0
iface eth0 inet static
address 192.168.1.181
netmask 255.255.255.0
network 192.168.1.0
broadcast 192.168.1.255
gateway 192.168.1.1

root@19r8s12:/etc#