Add emits stanza for unmounted-remote-filesystems

Bug #791866 reported by James Hunt
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
upstart
Undecided
Unassigned
upstart (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: upstart

The initctl(8) check-config command reads the "emits" stanzas (see init(5)). However, we have a minor problem in that portmap starts on an event that is not advertised using "emits":

$ initctl check-config
portmap
  stop on: unknown event unmounted-remote-filesystems
$

This event is actually emitted by the SysV script /etc/init.d/umountnfs.sh which poses a problem in that we cannot update the appropriate Upstart .conf file, since there isn't one.

I propose the best solution is to add an appropriate emits line to /etc/init/rc-sysinit.conf in the Ubuntu Upstart package for the unmounted-remote-filesystems event:

  emits runlevel
+ emits unmounted-remote-filesystems

This will pacify "initctl check-config" without having to resort to the --ignore-events option.

Related branches

James Hunt (jamesodhunt)
tags: added: bitesize
James Hunt (jamesodhunt)
description: updated
affects: upstart (Ubuntu) → portmap (Ubuntu)
affects: portmap (Ubuntu) → upstart (Ubuntu)
Steve Langasek (vorlon)
Changed in upstart (Ubuntu):
status: New → Triaged
importance: Undecided → Low
Revision history for this message
Steve Langasek (vorlon) wrote :

since this job is present upstream, maybe we want to include the change there.

Changed in upstart (Ubuntu):
status: Triaged → Fix Committed
Revision history for this message
Steve Langasek (vorlon) wrote :

This is already documented in rc.conf instead of rc-sysinit.conf; closing the report.

We may still want this change upstream however.

Changed in upstart (Ubuntu):
status: Fix Committed → Fix Released
Changed in upstart:
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers