0.3: Boot parameters not passed to init scripts

Bug #74664 reported by Rob Hasselbaum on 2006-12-06
8
Affects Status Importance Assigned to Milestone
upstart
Low
Unassigned
upstart (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: upstart

Prior to Upstart, boot parameters could be passed to init scripts as environment variables. This made it possible, for example, to select an "xorg.conf" at boot-time by specifying the XORGCONF variable.

In Edgy, this no longer works.

These boot parameters are set by the kernel in the environment of init.

While upstart does have a goal to make the environment of its jobs consistent, it should be possible for a job to say which environment variables it wants to receive.

So just like we pass PATH and TERM from the kernel, we should also pass an optional list of other variables that could be set from sources like the initramfs or kernel.

Changed in upstart:
assignee: nobody → keybuk
importance: Undecided → Wishlist
status: Unconfirmed → Confirmed
Jonathan Watts (jrwatts) wrote :

I can confirm this bug. It's causing problems with my dual boot setup (native Kubuntu or Kubuntu under coLinux on WinXP), as I was relying on passing a COLINUX variable to my colinux script so I can use the correct set of config files (fstab, network/interfaces, etc.).

Changed in upstart:
status: Unconfirmed → Confirmed

Not wishlist: this functionality existed in sysvinit

Changed in upstart:
importance: Undecided → Wishlist
importance: Wishlist → Low
importance: Wishlist → Low
Changed in upstart:
assignee: keybuk → nobody

Rejecting the Ubuntu portion of this bug, since it's an upstream problem

Changed in upstart:
status: Confirmed → Rejected

The intent is that the job should be able to specify "env PATH TERM" etc. (ie. without values) and have those passed through.

Changed in upstart:
status: Confirmed → Triaged

This was committed in trunk a while back with the new environment code.

Changed in upstart:
status: Triaged → Fix Committed
Changed in upstart:
status: Fix Committed → Fix Released

Still affects Ubuntu

Changed in upstart:
status: Invalid → Triaged
summary: - Boot parameters not passed to init scripts
+ 0.3: Boot parameters not passed to init scripts

Preparing packages of Upstart 0.6.0 for karmic

Changed in upstart (Ubuntu):
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package upstart - 0.6.0-1

---------------
upstart (0.6.0-1) karmic; urgency=low

  * New upstream release ("How appropriate, you fight like a cow")
    - my customary changes list since pointless, it's basically a
      complete rewrite.
    - Handles /bin/sh symlink disappearing. LP: #65024.
    - Boot parameters may be passed to init scripts. LP: #74664.
    - reboot implies --force during shutdown. LP: #388738.
    - reboot no longer iterates /proc/ide. LP: #92685.
    - much improved documentation. LP: #60429, #72058, #388715.

  * Merge the various upstart packages into a single package, it makes
    little sense to have it all spread out.

 -- Scott James Remnant <email address hidden> Wed, 08 Jul 2009 23:12:03 +0100

Changed in upstart (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers