package cups 1.4.5-1ubuntu6 failed to start with a kernel with missing apparmor

Bug #710649 reported by Serkan Hosca on 2011-01-31
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
upstart (Ubuntu)
Medium
Kees Cook

Bug Description

Binary package hint: cups

Cups daemon won't start.

$ sudo start cups
start: Job failed to start

but i can start the daemon with sudo cupsd -f

ProblemType: Package
DistroRelease: Ubuntu 11.04
Package: cups 1.4.5-1ubuntu6
Uname: Linux 2.6.38-rc2+ x86_64
AptOrdering:
 cups: Configure
 cups-driver-gutenprint: Configure
Architecture: amd64
Date: Mon Jan 31 08:16:30 2011
ErrorMessage: subprocess installed post-installation script returned error exit status 1
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20101202)
Lpstat: Error: command ['lpstat', '-v'] failed with exit code 1: lpstat: Connection refused
MachineType: Hewlett-Packard HP ENVY 15 Notebook PC
Papersize: letter
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-rc2+ root=/dev/sda3 ro elevator=noop quiet
SourcePackage: cups
Title: package cups 1.4.5-1ubuntu6 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1
dmi.bios.date: 10/12/2010
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: F.2B
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 1522
dmi.board.vendor: Hewlett-Packard
dmi.board.version: 36.35
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnHewlett-Packard:bvrF.2B:bd10/12/2010:svnHewlett-Packard:pnHPENVY15NotebookPC:pvr0494110000241900001320000:rvnHewlett-Packard:rn1522:rvr36.35:cvnHewlett-Packard:ct10:cvrN/A:
dmi.product.name: HP ENVY 15 Notebook PC
dmi.product.version: 0494110000241900001320000
dmi.sys.vendor: Hewlett-Packard

Related branches

Serkan Hosca (serkan-hosca) wrote :
Serkan Hosca (serkan-hosca) wrote :

I can start the daemon if i comment out this:

# /lib/init/apparmor-profile-load usr.sbin.cupsd

in pre-start in /etc/init/cups.conf

Till Kamppeter (till-kamppeter) wrote :

This is a problem with Upstart and AppArmor, can you have a look into this?

Changed in cups (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
importance: Undecided → Medium
Serkan Hosca (serkan-hosca) wrote :

I forgot to add i am using git kernel. It works fine with ubuntu kernel.

Serkan Hosca (serkan-hosca) wrote :

I am missing /sys/kernel/security/apparmor/profiles directory. I've commented out the directory check in apparmor-profile-load and i can start cups. I guess the git kernel is missing somethings.

Martin Pitt (pitti) wrote :

Kees, I think this should be checked centrally in /lib/init/apparmor-profile-load, and not fail if the kernel doesn't support apparmor?

summary: - package cups 1.4.5-1ubuntu6 failed to install/upgrade: subprocess
- installed post-installation script returned error exit status 1
+ package cups 1.4.5-1ubuntu6 failed to start with a kernel with missing
+ apparmor
affects: cups (Ubuntu) → upstart (Ubuntu)
Changed in upstart (Ubuntu):
assignee: Martin Pitt (pitti) → Kees Cook (kees)
Kees Cook (kees) wrote :

Martin, that was the idea -- the problem is the distinction between full apparmor and upstream apparmor. Easy fix.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package upstart - 0.6.7-6

---------------
upstart (0.6.7-6) natty; urgency=low

  * debian/apparmor-profile-load: check for correct AppArmor profile loading
    interface file (LP: #710649).
 -- Kees Cook <email address hidden> Thu, 03 Feb 2011 13:45:32 -0800

Changed in upstart (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers