kill 1 in postinst does not work inside a vserver

Bug #64499 reported by Max Lindner on 2006-10-07
2
Affects Status Importance Assigned to Milestone
upstart (Ubuntu)
Medium
Scott James Remnant (Canonical)

Bug Description

Binary package hint: upstart

I am running edgy in one of my vservers (http://www.linux-vserver.org) and it is not possible to do a killl 1 inside a vserver:

root@frankenstein:~# kill 1
bash: kill: (1) - No such process

So the postinst of upstart fails and due to this the dependencies are not configured either.
I discovered that a pkill init does not return a error, although it calls kill and there is this in the strace:

kill(1, SIGTERM) = -1 ESRCH (No such process)

So it would be nice to change the kill 1 to pkill init or changing the postinst not to fail if kill 1 fails.

Otherwise it is only hardly possible for vserver-users to update their upstart (deleting the kill 1 line in /var/lib/dpkg/...).

TIA,
Max

Changed in upstart:
assignee: nobody → keybuk
importance: Undecided → Medium
status: Unconfirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers