upstart-job returns SysV-incompatible value for 'start' when job is already running

Bug #603934 reported by Mark Garland on 2010-07-10
48
This bug affects 8 people
Affects Status Importance Assigned to Milestone
upstart (Ubuntu)
Critical
Steve Langasek
Natty
Critical
Steve Langasek

Bug Description

na

ProblemType: Package
Architecture: amd64
Date: Sat Jul 10 11:30:38 2010
DistroRelease: Ubuntu 9.10
ErrorMessage: subprocess installed post-installation script returned error exit status 1
Package: nfs-common 1:1.2.0-2ubuntu8
ProcVersionSignature: Ubuntu 2.6.31-20.58-generic
SourcePackage: nfs-utils
Title: package nfs-common 1:1.2.0-2ubuntu8 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1
Uname: Linux 2.6.31-20-generic x86_64

Related branches

Steve Langasek (vorlon) wrote :

Thank you for taking the time to report this issue and help to improve Ubuntu.

The error in your log shows:

Setting up nfs-common (1:1.2.0-2ubuntu8) ...
statd start/running, process 22556
gssd stop/pre-start, process 22634
start: Job is already running: idmapd
invoke-rc.d: initscript idmapd, action "restart" failed.
dpkg: error processing nfs-common (--configure):
 subprocess installed post-installation script returned error exit status 1

Why is idmapd running here? Please show the output of these commands:

 status idmapd
 ps aux | grep idmapd

Changed in nfs-utils (Ubuntu):
status: New → Incomplete
mkilivan (mkilivan) wrote :

  murat@murat:~$ status idmapd
  idmapd start/running, process 991

  murat@murat:~$ ps aux | grep idmapd
  root 991 0.0 0.0 2304 572 ? Ss 19:45 0:00 rpc.idmapd
  murat 3741 0.0 0.0 3048 812 pts/3 S+ 19:54 0:00 grep idmapd

I uninstall nfs-kernel-server and nfs-common packages and after reinstall again the packages successfully installed. But the /etc/init.d/nfs-common file does not exist.

On Tue, Dec 07, 2010 at 06:04:45PM -0000, Murat KILIVAN wrote:
> murat@murat:~$ status idmapd
> idmapd start/running, process 991

> murat@murat:~$ ps aux | grep idmapd
> root 991 0.0 0.0 2304 572 ? Ss 19:45 0:00 rpc.idmapd
> murat 3741 0.0 0.0 3048 812 pts/3 S+ 19:54 0:00 grep idmapd

Hmm, that really doesn't explain why this failed then, unfortunately.

> I uninstall nfs-kernel-server and nfs-common packages and after
> reinstall again the packages successfully installed.

Ah, then this bug report will have to remain 'incomplete', because further
debugging is now impossible.

> But the /etc/init.d/nfs-common file does not exist.

Yes, it's not expected to; it has been replaced by upstart jobs for each of
the individual servers.

--
Steve Langasek Give me a lever long enough and a Free OS
Debian Developer to set it on, and I can move the world.
Ubuntu Developer http://www.debian.org/
<email address hidden> <email address hidden>

Steve Langasek (vorlon) on 2010-12-23
summary: - package nfs-common 1:1.2.0-2ubuntu8 failed to install/upgrade:
- subprocess installed post-installation script returned error exit status
- 1
+ package nfs-common 1:1.2.0-2ubuntu8 failed to install/upgrade: start:
+ Job is already running: idmapd

I've sorted through what's going on here. Partly this is caused by bug #643289, which causes a race condition for idmapd at boot time and leaves the idmapd job in an inconsistent "start/running" state with no associated process (bug #545673). And partly, this is a bug in /lib/init/upstart-job: when the service *is* "start/running" with no PID, the 'restart' command is mapped to 'start', which fails because the job is already "running". I think upstart needs to restart in this case whether there's a pid or not.

affects: nfs-utils (Ubuntu) → upstart (Ubuntu)
Changed in upstart (Ubuntu):
importance: Undecided → Low
status: Incomplete → Triaged

Steve,
I know this isn't the same bug, but I'm running an Acer aspire one
D255, and was wondering if the sd media reader will ever work with
Ubuntu? How do I submit this to the proper group? I see it mentioned
in several articles, but never with a working answer.
Thanks,
Rick

On Tue, Jan 18, 2011 at 1:48 AM, Steve Langasek
<email address hidden> wrote:
> I've sorted through what's going on here.  Partly this is caused by bug
> #643289, which causes a race condition for idmapd at boot time and
> leaves the idmapd job in an inconsistent "start/running" state with no
> associated process (bug #545673).  And partly, this is a bug in
> /lib/init/upstart-job: when the service *is* "start/running" with no
> PID, the 'restart' command is mapped to 'start', which fails because the
> job is already "running".  I think upstart needs to restart in this case
> whether there's a pid or not.
>
> ** Package changed: nfs-utils (Ubuntu) => upstart (Ubuntu)
>
> ** Changed in: upstart (Ubuntu)
>   Importance: Undecided => Low
>
> ** Changed in: upstart (Ubuntu)
>       Status: Incomplete => Triaged
>
> --
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (691117).
> https://bugs.launchpad.net/bugs/603934
>
> Title:
>  package nfs-common 1:1.2.0-2ubuntu8 failed to install/upgrade: start:
>  Job is already running: idmapd
>
> Status in “upstart” package in Ubuntu:
>  Triaged
>
> Bug description:
>  na
>
>  ProblemType: Package
>  Architecture: amd64
>  Date: Sat Jul 10 11:30:38 2010
>  DistroRelease: Ubuntu 9.10
>  ErrorMessage: subprocess installed post-installation script returned error exit status 1
>  Package: nfs-common 1:1.2.0-2ubuntu8
>  ProcVersionSignature: Ubuntu 2.6.31-20.58-generic
>  SourcePackage: nfs-utils
>  Title: package nfs-common 1:1.2.0-2ubuntu8 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1
>  Uname: Linux 2.6.31-20-generic x86_64
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/upstart/+bug/603934/+subscribe
>

--
Rick Giorgio

Steve Langasek (vorlon) on 2011-01-26
summary: - package nfs-common 1:1.2.0-2ubuntu8 failed to install/upgrade: start:
- Job is already running: idmapd
+ upstart-job returns SysV-incompatible value for 'start' when job is
+ already running
Steve Langasek (vorlon) on 2011-01-26
Changed in upstart (Ubuntu):
importance: Low → Critical
Changed in upstart (Ubuntu Natty):
assignee: nobody → Steve Langasek (vorlon)
milestone: none → natty-alpha-2
Steve Langasek (vorlon) wrote :

This bug has become much more urgent due to fixes to the debhelper-provided maintainer script snippets; now any job which has no associated pid when in a 'started' state (and there are a few that legitimately work this way) will fail to upgrade. So we'll be fixing this for natty alpha-2.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package upstart - 0.6.7-5

---------------
upstart (0.6.7-5) natty; urgency=low

  * debian/upstart-job: properly handle jobs that are in state 'start/running'
    with no PID, by checking only if the goal is 'start'. LP: #603934,
    #707971.
 -- Steve Langasek <email address hidden> Wed, 26 Jan 2011 14:05:43 -0800

Changed in upstart (Ubuntu Natty):
status: Triaged → Fix Released
Michael Rivera (rivera) wrote :

Will this be fixed for lucid too?

Brian Murray (brian-murray) wrote :

As far as I can tell Lucid is not affected by this bug see the following comment that indicates this was a result of a change in debhelper. https://bugs.launchpad.net/ubuntu/+source/upstart/+bug/707971/comments/5

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers