upstart fails to build from source in maverick

Bug #602130 reported by Matthias Klose on 2010-07-06
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
upstart (Ubuntu)
High
Scott James Remnant (Canonical)
Maverick
High
Scott James Remnant (Canonical)

Bug Description

Binary package hint: upstart

seen in maverick, and in a test rebuild:
https://launchpad.net/ubuntu/+source/upstart/0.6.6-1/+build/1734147
on all architectures.

however building the package in a chroot doesn't show the failing tests.

test_job_class: tests/test_job_class.c:168: test_consider: Assertion `(execlp ("dbus-daemon", "test_dbus-daemon", "--session", "--print-address", ((void *)0))) == 0' failed.
test_job_class: tests/test_job_class.c:169: test_consider: Assertion `(conn = dbus_bus_get_private (DBUS_BUS_SYSTEM, ((void *)0))) != ((void *)0)' failed.
Testing job_class_new()
Testing job_class_consider()
/bin/bash: line 5: 17716 Aborted ${dir}$tst
FAIL: test_job_class

test_job: tests/test_job.c:190: test_new: Assertion `(execlp ("dbus-daemon", "test_dbus-daemon", "--session", "--print-address", ((void *)0))) == 0' failed.
test_job: tests/test_job.c:191: test_new: Assertion `(conn = dbus_bus_get_private (DBUS_BUS_SYSTEM, ((void *)0))) != ((void *)0)' failed.
Testing job_new()
...with no name
...with name given
...with D-Bus connection
/bin/bash: line 5: 18106 Aborted ${dir}$tst
FAIL: test_job

test_control: tests/test_control.c:802: test_bus_close: Assertion `(execlp ("dbus-daemon", "test_dbus-daemon", "--session", "--print-address", ((void *)0))) == 0' failed.
test_control: tests/test_control.c:806: test_bus_close: Assertion `(control_bus_open ()) == 0' failed.
...with no system bus
Testing control_bus_close()
/bin/bash: line 5: 18459 Aborted ${dir}$tst
FAIL: test_control
===============================================
3 of 13 tests failed

Matthias Klose (doko) on 2010-07-06
Changed in upstart (Ubuntu Maverick):
importance: Undecided → High
milestone: none → maverick-alpha-3
Colin Watson (cjwatson) on 2010-07-09
Changed in upstart (Ubuntu Maverick):
assignee: nobody → Scott James Remnant (scott)

Reviewing my results, I get the result rebuilding upstart for Maverick:

test_job_class: tests/test_job_class.c:168: test_consider: Assertion `(execlp ("dbus-daemon", "test_dbus-daemon", "--session", "--print-address", ((void *)0))) == 0' failed.
test_job_class: tests/test_job_class.c:168: test_consider: Assertion `read (_test_fds[0], _test_address, sizeof (_test_address)) > 0' failed.
/bin/bash: line 5: 25643 Aborted ${dir}$tst
FAIL: test_job_class

...with D-Bus connection
test_job: tests/test_job.c:190: test_new: Assertion `(execlp ("dbus-daemon", "test_dbus-daemon", "--session", "--print-address", ((void *)0))) == 0' failed.
test_job: tests/test_job.c:190: test_new: Assertion `read (_test_fds[0], _test_address, sizeof (_test_address)) > 0' failed.
/bin/bash: line 5: 26033 Aborted ${dir}$tst
FAIL: test_job

Testing control_bus_close()
test_control: tests/test_control.c:802: test_bus_close: Assertion `(execlp ("dbus-daemon", "test_dbus-daemon", "--session", "--print-address", ((void *)0))) == 0' failed.
test_control: tests/test_control.c:802: test_bus_close: Assertion `read (_test_fds[0], _test_address, sizeof (_test_address)) > 0' failed.
/bin/bash: line 5: 26420 Aborted ${dir}$tst
FAIL: test_control
===============================================
3 of 13 tests failed
Please report to <email address hidden>
===============================================
make[4]: *** [check-TESTS] Error 1
make[4]: Leaving directory `/tmp/buildd/upstart-0.6.6/init'
make[3]: *** [check-am] Error 2
make[3]: Leaving directory `/tmp/buildd/upstart-0.6.6/init'
make[2]: *** [check] Error 2
make[2]: Leaving directory `/tmp/buildd/upstart-0.6.6/init'
make[1]: *** [check-recursive] Error 1
make[1]: Leaving directory `/tmp/buildd/upstart-0.6.6'
dh_auto_test: make -j1 check returned exit code 2
make: *** [build] Error 29

I would be happy to upload my full build log if it would help.

Changed in upstart (Ubuntu Maverick):
status: New → Confirmed
Martin Pitt (pitti) on 2010-08-04
Changed in upstart (Ubuntu Maverick):
milestone: maverick-alpha-3 → ubuntu-10.10-beta

This seems to be failing to spawn dbus-daemon for one of the tests; interestingly, exactly which spawn fails seems to vary.

Has anyone replicated this outside of the buildd environment, e.g. in pbuilder?

Have replicated in pbuilder

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package upstart - 0.6.6-3

---------------
upstart (0.6.6-3) maverick; urgency=low

  * Ubuntu seems to have stopped installing Recommends of Build-Depends,
    add a Build-Depend on dbus. LP: #602130.
 -- Scott James Remnant <email address hidden> Thu, 12 Aug 2010 16:38:05 -0400

Changed in upstart (Ubuntu Maverick):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers