upstart-udev-bridge emits net-device-remove instead of net-device-removed

Bug #516698 reported by Steve Langasek on 2010-02-03
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
upstart (Ubuntu)
Medium
Johan Kiviniemi

Bug Description

Binary package hint: upstart

upstart-udev-bridge is emitting 'net-device-remove' instead of 'net-device-removed', which prevents the stop condition of /etc/init/network-interface.conf from ever being met. This should be fixed to be 'net-device-removed', consistent with 'net-device-added'.

ProblemType: Bug
Architecture: amd64
Date: Wed Feb 3 11:18:36 2010
DistroRelease: Ubuntu 10.04
Package: upstart 0.6.3-11build1
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-11.15-generic
SourcePackage: upstart
Uname: Linux 2.6.32-11-generic x86_64

Steve Langasek (vorlon) wrote :
Changed in upstart (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
Steve Langasek (vorlon) on 2010-02-03
Changed in upstart:
status: New → Confirmed

(closed the upstream task since this code doesn't exist there)

affects: upstart → null
Changed in null:
status: Confirmed → Invalid
Changed in upstart (Ubuntu):
status: Triaged → In Progress
assignee: nobody → Scott James Remnant (scott)
Changed in upstart (Ubuntu):
assignee: Scott James Remnant (scott) → Johan Kiviniemi (ion)
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package upstart - 0.6.5-1

---------------
upstart (0.6.5-1) lucid; urgency=low

  * New upstream release:
    - libnih has been separated out into its own project.
    - "start on" and "stop on" now support != matches. LP: #513035.
    - Fixed crash in child when unable to spawn job. LP: #451917.
    - No longer holds /dev/console open so SAK won't kill init. LP: #486005.
    - Added missing OPTIONS section to init(8). LP: #449883.

  [ Scott James Remnant ]
  * Build-depend on libnih-dev, libnih-dbus-dev and nih-dbus-tool to use
    the separated out libnih.
    - This has the fix for LP: #436758.
    - Remove changelog.nih from the doc directory.
  * Bump udev build-dependency to 147 to match upstream.
  * udev/Makefile.am: Update to use external libnih

  [ Johan Kiviniemi ]
  * udev/upstart-udev-bridge.c: Change -device-remove to -device-removed to
    match -device-added and -device-changed. LP: #516698.
 -- Scott James Remnant <email address hidden> Thu, 04 Feb 2010 16:30:10 -0800

Changed in upstart (Ubuntu):
status: Fix Committed → Fix Released
Curtis Hovey (sinzui) on 2011-11-11
no longer affects: null
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers