Ubuntu

Some essential services are not started

Reported by Rüdiger Kupper on 2009-12-26
206
This bug affects 41 people
Affects Status Importance Assigned to Milestone
upstart
Undecided
Unassigned
upstart (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: upstart

Since a few weeks ago, some essential services are no longer started at bootup. I noticed that the following (and probably many more) services are not running after a reboot:
- cupsd
- sshd
- atd
- ...?

They can be manually started using "service" or "start/stop", but they are not started automatically at boot time. This means, I cannot connect to my box after a reboot, because sshd is not running, and my scheduled jobs don't run, because atd isn't there, etc.

Those services have worked reliably in the past, and I don't know what actually happened. I suspect that it's related to upstart, but I'm not sure. It looks a rather general problem to me, as it seems to affect a lot of services.

ProblemType: Bug
Architecture: i386
Date: Sat Dec 26 12:33:01 2009
DistroRelease: Ubuntu 9.10
NonfreeKernelModules: nvidia
Package: upstart 0.6.3-11
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-16.53-generic
SourcePackage: upstart
Uname: Linux 2.6.31-16-generic i686

Heineken (lars-heineken) wrote :

It looks like an issue with upstart indeed:
http://ubuntuforums.org/showthread.php?p=8548144
The guys on the forum fixed it by downgrading Upstart 0.6.3-11 to 0.6.3-10.

Thank you Heineken. Downgrading to upstart 0.6.3-10 solved the issue for me, too.
It looks as if the changes made in 0.6.3-11 (wait until the loopback device is up?) keep upstart from working properly on some systems.
There are several reports of this issue on the forum.

nicobrainless (nicoseb) wrote :

I actually created that thread on the forums, and followed a couples of other bugs too..
Anyway, for me it has been fixed over the holidays!
Almost all services are started at boot.

uname -a
Linux brainless 2.6.32-9-generic #13-Ubuntu SMP Thu Dec 17 17:01:59 UTC 2009 x86_64 GNU/Linux

upstart 0.6.3-11
mountall 2.3

The only remaining problem at boot is that gdm init script is dying. I have to start through recovery mode, hit "continue normal boot" and everything is ok... weird!

Heineken (lars-heineken) wrote :

@nicobrainless:
Could you specify what has been fixed for you? I'm still observing the same issue and ss far as I can recall there has been no official fix yet.

Selmi (selmi) wrote :

i can confirm

after upgrade to upstart 0.6.3-11 no printing, no bluetooth, extremely slow pc when copying big files (probably something not set?), grub 1.97 never started automatically after 10 seconds but i always had to choose item to boot manually

after downgrade to previous upstart version everything went back to normal

Jon White (killermonkey01) wrote :

After extensive testing (ALL DAY TODAY!) I found that almost all of the upstart services in /etc/init are NOT invoked.

Most notably, the system is never put in a proper runlevel even though sulogin pops up and the system *appears* to be running normally.

Some services that I confirmed did not run (by adding echo "SERVICE ran" >> /home/rc.txt to certain places in the script .conf):

mountall
rc-sysinit
rc
rcS

rc-sysinit is responsible for getting you into your runlevel (telinit) and that runs all your services from rc2.d

Changed in upstart (Ubuntu):
status: New → Confirmed
tomasz kubacki (tomasz-kubacki) wrote :

For some reason i didn't have loopback interface defined in:
/etc/network/interfaces
So i've done:
sudo vim /etc/network/interfaces

and added:

auto lo
iface lo inet loopback

I think Ubuntu should have some self testing tool for basic settings. If it is known that some apps do require loopback interface for working (e.g. upstart) then there should be some automatic test tool checking whether the interface exists !! Ther should be some general solution for this kind. Maybe some kind of 'Unit test' tool

IcyJ (jeremy-michelle) wrote :

I have the same problem, particularly with CUPS. Please, when I try to open System -> Preferences - Default Printer, I get the message "The CUPS scheduler is not running". I can manually start CUP from the CLI.

Lars Ola Liavåg (l-liavag) wrote :

I've got the same problem. At least CUPS and vboxdrv fail to start upon boot. The loopback contents in /etc/network/interfaces weren't the issue. I'm considering to downgrade upstart but I'm worried about possible dependency problems. Any known issues with going from 0.6.3-11 to 0.6.3-10?

garab (garab) wrote :

The problem for me was the same as for "tomasz kubacki".
I added

auto lo
iface lo inet loopback

in /etc/network/interfaces and cups is running at startup.

Can anyboby explain what is the loopback interface and why cups
need this?
(thanks a lot tomasz kubacki)

Lars Ola Liavåg (l-liavag) wrote :

I also tried downgrading to 0.6.3-10 but it doesn't work either. Is something happening with this upstart issue? And where's the bug report that this one's supposed to be a duplicate to?

Steve Langasek (vorlon) wrote :

If downgrading doesn't solve your problem, you're experiencing an unrelated issue. Please file a separate bug report.

_sRg_ (sor-sergey) wrote :

I have the same problem in Ubuntu 10.10 on Toshiba A300 laptop. But I have /etc/network/interfaces containing required lines:

auto lo
iface lo inet loopback

But Upstart doesn't launch services anyway.

DiagonalArg (diagonalarg) wrote :

I'm having the same problem: Ubuntu 10.10 on a Dell Dimension 8250. Ditto with _sRg_ on the /etc/network/interfaces file.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions