compat: support for booting in emergency (-b) mode

Bug #193810 reported by andrew bezella on 2008-02-20
4
Affects Status Importance Assigned to Milestone
upstart
Wishlist
Unassigned
upstart (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: upstart

the sysvinit implementation of init supported booting in emergency
(-b) mode where it would "Boot directly into a single user shell
without running any other startup scripts." i have found this useful
in the past and was wondering if the functionality would (or could)
be included in upstart?

thanks!

        andy

Changed in upstart:
importance: Undecided → Wishlist
status: New → Confirmed
Changed in upstart:
importance: Undecided → Wishlist
status: New → Confirmed
Andrew Pollock (apollock) wrote :

IMO, this is not a wishlist bug, as sysvinit supported this.

Upstart makes no attempt to fully emulate sysvinit, it only makes attempt to emulate sysv-rc - many people think that sysv-rc (/etc/init.d, /etc/X.d, etc.) _is_ sysvinit, so it's easy to see where this confusion comes from.

(If Upstart emulated sysvinit, it would have an /etc/inittab, etc.)

Therefore wishlist is appropriate, you're asking for a feature that Upstart doesn't currently support and isn't documented to support.

Personally I tend to use the Importance field to indicate Severity, rather than Priority.

Note that the typical way people get the emergency shell is just to use init=/bin/bash, rather than -b - they are pretty much equivalent <g>

Andrew Pollock (apollock) wrote :

The only justification I was using for my comment was your own words on #74664...

Yes, init=/bin/bash or whatever certainly works as well, but there's plenty of documentation out there about booting with "emergency" as the argument in lieu of say "single". It's certainly a behaviour change going from say Dapper with sysvinit to Hardy with upstart.

But now that I know how you're using the Importance field, it's probably all moot...

See also bug #85014

Changed in upstart:
status: Confirmed → Triaged
Changed in upstart (Ubuntu):
status: Confirmed → Triaged
summary: - support for booting in emergency (-b) mode
+ compat: support for booting in emergency (-b) mode

This file is only shipped with Ubuntu, see bug #389113 about doing things in an upstream manner

Changed in upstart:
status: Triaged → Invalid

Patch to add support (to rcS) in progress

Changed in upstart (Ubuntu):
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package upstart - 0.3.10-2

---------------
upstart (0.3.10-2) karmic; urgency=low

  * debian/upstart.postinst: Use telinit u to re-exec, rather than
    kill just in case it's not Upstart that's running. LP: #92177.
  * debian/event.d/system-services/tty*: Run getty in 8-bit clean
    mode. LP: #273189.
  * debian/event.d/upstart-compat-sysv/rc-default:
    - Don't use grep -w, instead split on $IFS and iterate. LP: #385911.
    - Check for any valid runlevel, not just S. LP: #85014.
    - Make console owner, since it may spawn sulogin.
  * debian/event.d/upstart-compat-sysv/rcS:
    - Spawn sulogin if given -b or "emergency". LP: #193810.
  * debian/event.d/upstart-compat-sysv/rcS:
    - Make console owner. LP: #211402.
  * debian/event.d/upstart-compat-sysv/rcS-sulogin:
    - Place the telinit code in post-stop, checking $UPSTART_EVENT first so
      we don't change the runlevel if we were stopped due to a runlevel
      change. LP: #66002.

 -- Scott James Remnant <email address hidden> Thu, 18 Jun 2009 16:19:34 +0100

Changed in upstart (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers