passwd depends on init-system-helpers (>= 1.18~); however: Version of init-system-helpers on system is 1.14

Bug #1541914 reported by Will Cooke on 2016-02-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
upstart (Ubuntu)
Undecided
Martin Pitt

Bug Description

Upgrading a 14.04 machine to 16.04 in the QA Jenkins we see this message.

Hopefully useful log extracts:

Setting up libpam-modules:amd64 (1.1.8-3.1ubuntu3) ...
dpkg: dependency problems prevent configuration of passwd:
 passwd depends on init-system-helpers (>= 1.18~); however:
  Version of init-system-helpers on system is 1.14.

dpkg: error processing package passwd (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
dpkg: dependency problems prevent configuration of libuuid1:amd64:
 libuuid1:amd64 depends on passwd; however:
  Package passwd is not configured yet.

dpkg: error processing package libuuid1:amd64 (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
dpkg: dependency problems prevent configuration of libblkid1:amd64:
 libblkid1:amd64 depends on libuuid1 (>= 2.16); however:
  Package libuuid1:amd64 is not configured yet.

tags: added: rls-x-incoming
Martin Pitt (pitti) wrote :

I did a couple of trusty→ xenial upgrades but could not reproduce this.

The first error in that log was this:

dpkg: considering deconfiguration of init-system-helpers, which would be broken by installation of upstart ...
dpkg: yes, will deconfigure init-system-helpers (broken by upstart)
Preparing to unpack .../upstart_1.13.2-0ubuntu18_amd64.deb ...
De-configuring init-system-helpers (1.14) ...
Unpacking upstart (1.13.2-0ubuntu18) over (1.12.1-0ubuntu4.2) ...

which got introduced by http://launchpadlibrarian.net/222852012/upstart_1.13.2-0ubuntu16_1.13.2-0ubuntu17.diff.gz

This apparently leads to a dependency loop. The Replaces: must be kept, but we could drop the Breaks: to make apt's job of breaking such loops simpler.

affects: init-system-helpers (Ubuntu) → upstart (Ubuntu)
Changed in upstart (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
status: New → In Progress
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package upstart - 1.13.2-0ubuntu21

---------------
upstart (1.13.2-0ubuntu21) xenial; urgency=medium

  * init/tests/test_job_process.c: Relax assertion about output format of
    "dd", as it changed recently. Fixes test failure and FTBFS.
  * init/tests/test_job_process.c: Disable "exited with signal" check in "with
    single-line script that is killed" test, as this is racy: it is possible
    that a short lived process exits faster than we manage to kill it. This
    will enable us to un-ignore autopkgtests again.

 -- Martin Pitt <email address hidden> Mon, 29 Feb 2016 16:06:05 +0100

Changed in upstart (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers