Upstart cannot connect so no desktop is shown

Bug #1537610 reported by jdfalk on 2016-01-25
22
This bug affects 5 people
Affects Status Importance Assigned to Milestone
upstart (Ubuntu)
Critical
Unassigned

Bug Description

Attempt to login to ubuntu system and it fails, it shows the background but nothing else. Troubleshooting led me to look at .xsession-errors which pointed at upstart. Attempt to use upstart-udev-bridge on it's on and it says:
upstart-udev-bridge: Could not connect to Upstart: Failed to connect to socket /com/ubuntu/upstart: Connection refused

Systemd is the default and works like it is supposed to. I removed upstart and I can login again. However, that removes unity, ubuntu-desktop and a whole host of other useful things. It would be nice if I could have a solution to the login issues but I would settle for a general purge of upstart from every package.

tail .xsession-errors
openConnection: connect: No such file or directory
cannot connect to brltty at :0
upstart: Failed to spawn upstart-udev-bridge main process: unable to execute: No such file or directory
upstart: unity-gtk-module pre-start process (2523) terminated with status 127
upstart: dbus pre-start process (2534) terminated with status 127

ProblemType: Bug
DistroRelease: Ubuntu 15.10
Package: upstart 1.13.2-0ubuntu16
ProcVersionSignature: Ubuntu 4.2.0-25.30-generic 4.2.6
Uname: Linux 4.2.0-25-generic x86_64
ApportVersion: 2.19.1-0ubuntu5
Architecture: amd64
Date: Sun Jan 24 20:06:25 2016
InstallationDate: Installed on 2015-05-10 (260 days ago)
InstallationMedia: Ubuntu-Server 15.04 "Vivid Vervet" - Release amd64 (20150422)
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: upstart
UpgradeStatus: Upgraded to wily on 2015-10-26 (90 days ago)
UpstartBugCategory: Session
UpstartRunningSessionCount: 2
UpstartRunningSystemVersion: Error: command ['initctl', '--system', 'version'] failed with exit code 1: initctl: Name "com.ubuntu.Upstart" does not exist
upstart.upstart-dbus-session-bridge.log: upstart-dbus-bridge: Unable to write pid file: No such file or directory

jdfalk (johnathan-falk) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in upstart (Ubuntu):
status: New → Confirmed

Bug #1537616 can be related.

Changed in upstart (Ubuntu):
importance: Undecided → Critical
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers