postinst script causes network installer to fail

Bug #148734 reported by Matthew L. Dailey on 2007-10-03
12
Affects Status Importance Assigned to Milestone
upstart (Ubuntu)
Undecided
Unassigned
Edgy
High
Scott James Remnant (Canonical)

Bug Description

Binary package hint: upstart

When performing a network install of edgy, the "edgy-updates" release is automatically selected and put into sources.list by apt-mirror-setup. So, once base-installer runs, it attempts to install upstart 0.2.7-7.1. The install succeeds, but when the postinst script is run, the command 'kill 1 || true' is run, which causes the busybox init of the installer to die and reboot before completing the installation. I'm not sure what the most elegant solution is, but it would seem like there's some way to tell that busybox is init and not upstart.

To reproduce, simply run an installation from a minimal CD or PXE installer and point at any of the standard mirrors - the install never completes.

Let me know if there's any other information I can provide to help with this.

This bug is caused by fix for the previous SRU Bug #141034 being installed from -updates; that fix itself is fine, but the netboot image upgrading Upstart within the installer is what causes this problem.

The attached debdiff is the proposed fix, it simply comments out the kill. In practice, this causes more problems than it solves and is only necessary if the upgrade could change the initctl protocol (which this update doesn't, and we'd never do within a stable release)

Martin Pitt (pitti) wrote :

In gutsy the kill is necessary, and it needs a vastly different fix. This is tracked in bug 92177.

Changed in upstart:
status: New → Invalid
assignee: nobody → keybuk
importance: Undecided → High
status: New → In Progress
Martin Pitt (pitti) wrote :

Accepted into edgy-proposed. Verifying the fix with netboot is quite tricky admittedly. However, the most important point about verifying this is to check that existing installations do not break with this upgrade.

Changed in upstart:
status: In Progress → Fix Committed
Thom May (thombot) wrote :

I applied this patch to our internal repository after talking to Scott on IRC and can confirm that it works in the netboot case.

Just to chime in... I downloaded the upstart source, applied the diff, compiled, and installed updated 0.2.7-7.2 debs on a running edgy system here. Everything worked perfectly, both before and after a reboot. I can't think of any obvious way to test the network install here locally, but I'd assume if it works on your internal repository, it should work once released to the mirrors.

Thanks for your quick and effective response on this - 18 hours from report to diff and acceptance - wow!!

Cheers!

Confirmed that it's been tested on an edgy box by simple installation; and tested on netboot too

Martin Pitt (pitti) wrote :

Considering as verified as per Scott's comment. Copied to -updates.

Changed in upstart:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers