split out upstart-sysv

Bug #1422681 reported by Michael Bienia on 2015-02-17
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
autopkgtest (Ubuntu)
Undecided
Unassigned
init-system-helpers (Ubuntu)
Undecided
Unassigned
systemd (Ubuntu)
Undecided
Unassigned
ubuntu-touch-meta (Ubuntu)
Undecided
Unassigned
upstart (Ubuntu)
Undecided
Unassigned

Bug Description

After switching to systemd permanently (apt get install systemd-sysv) and purging the now not needed "upstart" package, I tried to boot with the upstart fallback option in grub, just to find out it doesn't work.
It looks like important init files are still in the "upstart" package instead of "upstart-bin" and should probably be moved there to keep the upstart fallback option working.

Martin Pitt (pitti) wrote :

Dimitri and I discussed that this morning. It's really hairy to move a lot of conffiles from one package to another. We resolved to this:

 * Split out upstart-sysv with just /sbin/init, reboot, etc. (similar to systemd-sysv)
 * Keep the config files in upstart
 * change init to depend on systemd-sysv | upstart-sysv
 * change systemd to conflict to upstart-sysv instead
 * make upstart depends: init, to ensure that we never lose an init system during upgrade

summary: - /etc/init files should get moved from "upstart" to "upstart-bin"
+ split out upstart-sysv
Changed in upstart (Ubuntu):
milestone: none → ubuntu-15.04
status: New → Triaged
Scott Moser (smoser) wrote :

just copying description from my duplicate bug as i think its probably / possibly useful

As seen in the failed systemd adt test at [1], installing 'upstart-bin' and then booting a system with 'init=/sbin/upstart' does not result in a fully functional system. The problem is that there are many upstart jobs provided by 'upstart' package that are essential to Ubuntu system boot.

To recreate the problem, just launch a cloud-instance, or fresh install with systemd, then:
  sudo apt-get install upstart-bin
  set /etc/default/grub up appropriately and run 'update-grub' (adding 'init=/sbin/upstart to GRUB_CMDLINE_LINUX_DEFAULT). Alternatively, you can just edit /bo
ot/grub/grub.cfg directly.
  reboot

System will not completely come up.

Installation of 'upstart' package *does* provide working boot, but conflicts and forces uninstallation of systemd-sysv, which is not desireable.

For reference, there is discussion in ubuntu-release between infinity, didrocks, smoser and cjwatson on 2015-03-18 [2] and 2015-03-19 [3].

--
[1] https://jenkins.qa.ubuntu.com/job/vivid-adt-systemd/ARCH=amd64,label=adt/121/consoleFull
[2] http://irclogs.ubuntu.com/2015/03/18/%23ubuntu-release.html
[3] http://irclogs.ubuntu.com/2015/03/19/%23ubuntu-release.html

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package upstart - 1.13.2-0ubuntu10

---------------
upstart (1.13.2-0ubuntu10) vivid; urgency=medium

  * Add upstart-sysv to mirror systemd-sysv behavior if upstart is chosen
    as the default init daemon: (LP: #1422681)
    - this fixes upstart not starting only with upstart-bin binary due to
      missing jobs.
    - upstart now contains upstart-bin binaries.
    - upstart-bin is a transitional package. Can be deleted in vivid+1.
    - removed some deprecated transition path for both debian and ubuntu.
    - ensure grub is updated when upstart-sysv is installed.
    - always get alternatives init and right default grub entries.
 -- Didier Roche <email address hidden> Mon, 23 Mar 2015 09:51:12 +0100

Changed in upstart (Ubuntu):
status: Triaged → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package systemd - 219-4ubuntu9

---------------
systemd (219-4ubuntu9) vivid; urgency=medium

  * debian/control:
    - systemd-sysv now conflicts with upstart-sysv, not upstart itself
      which contains upstart binaries. (LP: #1422681)
  * debian/test/*:
    - re-enable upstart boot test and switch to upstart instead of
      upstart-bin
  * debian/systemd-sysv.postinst:
    - fix syntax for better portability
 -- Didier Roche <email address hidden> Mon, 23 Mar 2015 10:21:34 +0100

Changed in systemd (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package init-system-helpers - 1.22ubuntu5

---------------
init-system-helpers (1.22ubuntu5) vivid; urgency=medium

  * Depend on upstart-sysv instead of upstart (LP: #1422681)
 -- Didier Roche <email address hidden> Mon, 23 Mar 2015 10:44:07 +0100

Changed in init-system-helpers (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package autopkgtest - 3.12ubuntu1

---------------
autopkgtest (3.12ubuntu1) vivid; urgency=medium

  * use the upstart path to start an upstart ubuntu touch session
    (LP: #1422681)
 -- Didier Roche <email address hidden> Mon, 23 Mar 2015 18:42:25 +0100

Changed in autopkgtest (Ubuntu):
status: New → Fix Released
Martin Pitt (pitti) wrote :
Changed in ubuntu-touch-meta (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers