Empty desktop in Xubuntu 14.04 on reboot after upgrading upstart package

Bug #1343905 reported by Ilya Almametov on 2014-07-18
36
This bug affects 7 people
Affects Status Importance Assigned to Milestone
upstart (Ubuntu)
Undecided
Unassigned
Trusty
High
Dimitri John Ledkov
Utopic
Undecided
Unassigned

Bug Description

Recently I've setup fresh Xubuntu 14.04 and upgraded system to current state. After reboot and logon to system I've got empty desktop and mouse pointer with no panels and icons. Alt+F2 and similar key combinations didn't work. Switching to console by Ctrl+Alt+F1 worked. After short investigation I've downgraded upstart to version 1.12.1-0ubuntu4 and rebooted. Now everything works as expected.

The .xsession-errors log form empty desktop session attached

Related branches

Ilya Almametov (ilya-almametov) wrote :
Dimitri John Ledkov (xnox) wrote :

Please report distribution bugs, against the distribution and the right package combo, otherwise release & stable release updates team may miss them, as they do not monitor upstream bugs.

Distribution/package adjusted.

affects: upstart → upstart (Ubuntu)
tags: added: regression-proposed
summary: - Empy desktop in Xubuntu 14.04 on reboot after upgrading upstart package
+ Empty desktop in Xubuntu 14.04 on reboot after upgrading upstart package
Changed in upstart (Ubuntu Utopic):
status: New → Fix Released
Changed in upstart (Ubuntu Trusty):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Dimitri John Ledkov (xnox)

Hello Ilya, or anyone else affected,

Accepted upstart into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/upstart/1.12.1-0ubuntu4.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in upstart (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed
Ilya Almametov (ilya-almametov) wrote :

Just tried version 1.12.1-0ubuntu4.2. It works as expected. Thank you!

tags: added: verification-done
removed: verification-needed

I was also affected by this bug. Installing the proposed packages fixed this issue on my system.

Thank you!

Regard...

Same here, I was affected, the fix worked.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package upstart - 1.12.1-0ubuntu4.2

---------------
upstart (1.12.1-0ubuntu4.2) trusty; urgency=medium

  * Safe guard against SESSIONTYPE-less sessions. (LP: #1343905)

upstart (1.12.1-0ubuntu4.1) trusty; urgency=medium

  [ James Hunt ] LP: #1317727
  * debian/manpages/upstart-events.7: Correction for 'rotate-logs'.
  * debian/upstart.cron.daily: Specify full path to initctl.
  * init/man/init.8: Add missing information on '--chroot-sessions'.
  * debian/upstart.apport: Sort system and session jobs.

  [ Iain Lane ]
  * xsession-init: Set $GNOME_DESKTOP_SESSION_ID if we are launching a
    gnome-session session. Some applications (Qt4) require this to be set to
    any value to detect the environment in use. It was historically set by
    gnome-session but now this is no longer the root of the session so not all
    user processes are guaranteed to have it. (LP: #1305294)

  [ Dimitri John Ledkov ]
  * Cherrypick reboot command fix to not process REBOOTCOMMAND argument
    when in runlevels 2-5 and without using force flag. (LP: #1174272)
 -- Dimitri John Ledkov <email address hidden> Fri, 18 Jul 2014 10:27:27 +0100

Changed in upstart (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for upstart has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers