grep: /etc/init/plymouth-shutdown.override: No such file or directory

Bug #1298938 reported by Sworddragon on 2014-03-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
upstart (Ubuntu)
Medium
Dimitri John Ledkov
Trusty
Medium
Dimitri John Ledkov

Bug Description

[Impact]

 * Unnecessary bogus harmless messages printed to the user in the default configuration.

[Test Case]

 * Execute wait-for-state against any job that does not have an override
 * Make sure no log / grep error messages from not finding .override file are printed for the wait-for-state job

[Regression Potential]

 * minimal output from $ grep, was already suppressed with '-q', now the stderr is redirected as well, exit / result from grep is checked.

[Other Info]

 * Original bug report:

I'm using Ubuntu 14.04 dev with plymouth 0.8.8-0ubuntu15 and on every boot I'm seeing another line of the warning "grep: /etc/init/plymouth-shutdown.override: No such file or directory" in the file /var/log/upstart/wait-for-state-rcplymouth-shutdown.log

Related branches

Steve Langasek (vorlon) wrote :

There are no upstart scripts in the official plymouth package that grep /etc/init/plymouth-shutdown.override. This looks like a local bug. Where does this grep happen?

Changed in plymouth (Ubuntu):
status: New → Incomplete
Sworddragon (sworddragon) wrote :

These are all greps in /etc/init:

sworddragon@ubuntu:/etc/init$ ack-grep --ignore-ack-defaults -C 1 grep
wait-for-state.conf
28- N|n|0)
29: if grep -q "^\s*manual\s*$" /etc/init/$WAIT_FOR.conf /etc/init/$WAIT_FOR.override ; then
30- exit 0
--
39- # Already running/stopped?
40: status $WAIT_FOR | grep -q "$TARGET_GOAL/$WAIT_STATE" && exit 0
41-

container-detect.conf
27- if [ -z "$container" ]; then
28: VXID="$(cat /proc/self/status | grep ^VxID | cut -f2)" || true
29- [ "${VXID:-0}" -gt 1 ] && container=vserver

plymouth-ready.conf
18- if [ "$UPSTART_EVENTS" = started ] || \
19: status plymouth-splash | grep -q "start/started" || \
20- plymouth --ping

Steve Langasek (vorlon) wrote :

> Maybe the grep comes from wait-for-state.conf which belongs to upstart.

Hmm, apparently so. I guess I haven't seen this here because it's a race condition. I would've thought this would be seen before now. It's a minor issue, but let's get this fixed for trusty.

affects: plymouth (Ubuntu) → upstart (Ubuntu)
Changed in upstart (Ubuntu):
status: Incomplete → Triaged
description: updated
Changed in upstart (Ubuntu):
importance: Undecided → Medium
assignee: nobody → Dimitri John Ledkov (xnox)
Changed in upstart (Ubuntu Trusty):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package upstart - 1.12.1-0ubuntu4

---------------
upstart (1.12.1-0ubuntu4) trusty; urgency=medium

  [ Adam Conrad ]
  * Disable chroot sessions by default, add an option to enable chroot
    sessions. (LP: #1277594)
 -- Dimitri John Ledkov <email address hidden> Fri, 11 Apr 2014 22:31:21 +0100

Changed in upstart (Ubuntu Trusty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers