Setting up upstart (1.8-0ubuntu1.1) ... dpkg: error: unknown option --compare-version

Bug #1195955 reported by Nick Semenkovich on 2013-06-29
32
This bug affects 7 people
Affects Status Importance Assigned to Milestone
upstart (Ubuntu)
High
Dimitri John Ledkov
Raring
High
Dimitri John Ledkov
Saucy
High
Dimitri John Ledkov

Bug Description

[Impact]
The upstart package has a wrong version check in the postinst. This won't cause upgrade failures, but it will cause wrong handling for one of the upgrade cases, resulting in upstart not being restarted on upgrade when it can be.

[Test case]
1. upgrade package from raring to the new one in raring-proposed
2. verify that there are no warning messages about wrong dpkg syntax in the upgrade log.

[Regression potential]
Minimal, correcting a syntax bug in the postinst specific to the SRU that has otherwise been approved.

== Original Report ==

Updating Ubuntu 13.04:

Building dependency tree
Reading state information... Done
The following packages will be upgraded:
   apport (2.9.2-0ubuntu8.1 => 2.9.2-0ubuntu8.2)
   python-boto (2.3.0-1 => 2.3.0-1ubuntu0.13.04.1)
   python3-apport (2.9.2-0ubuntu8.1 => 2.9.2-0ubuntu8.2)
   python3-problem-report (2.9.2-0ubuntu8.1 => 2.9.2-0ubuntu8.2)
   upstart (1.8-0ubuntu1 => 1.8-0ubuntu1.1)
5 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 1,190 kB of archives.
After this operation, 178 kB of additional disk space will be used.
Do you want to continue [Y/n]?
Get:1 http://mirrors.mit.edu/ubuntu/ raring-proposed/main upstart amd64 1.8-0ubuntu1.1 [515 kB]
Get:2 http://mirrors.mit.edu/ubuntu/ raring-proposed/main python3-problem-report all 2.9.2-0ubuntu8.2 [9,412 B]
Get:3 http://mirrors.mit.edu/ubuntu/ raring-proposed/main python3-apport all 2.9.2-0ubuntu8.2 [90.0 kB]
Get:4 http://mirrors.mit.edu/ubuntu/ raring-proposed/main apport all 2.9.2-0ubuntu8.2 [177 kB]
Get:5 http://mirrors.mit.edu/ubuntu/ raring-proposed/main python-boto all 2.3.0-1ubuntu0.13.04.1 [398 kB]
Fetched 1,190 kB in 1s (973 kB/s)
(Reading database ... 303022 files and directories currently installed.)
Preparing to replace upstart 1.8-0ubuntu1 (using .../upstart_1.8-0ubuntu1.1_amd64.deb) ...
Unpacking replacement upstart ...
Preparing to replace python3-problem-report 2.9.2-0ubuntu8.1 (using .../python3-problem-report_2.9.2-0ubuntu8.2_all.deb) ...
Unpacking replacement python3-problem-report ...
Preparing to replace python3-apport 2.9.2-0ubuntu8.1 (using .../python3-apport_2.9.2-0ubuntu8.2_all.deb) ...
Unpacking replacement python3-apport ...
Preparing to replace apport 2.9.2-0ubuntu8.1 (using .../apport_2.9.2-0ubuntu8.2_all.deb) ...
apport stop/waiting
Unpacking replacement apport ...
Preparing to replace python-boto 2.3.0-1 (using .../python-boto_2.3.0-1ubuntu0.13.04.1_all.deb) ...
Unpacking replacement python-boto ...
Processing triggers for ureadahead ...
Processing triggers for man-db ...
Processing triggers for shared-mime-info ...
Processing triggers for hicolor-icon-theme ...
Setting up upstart (1.8-0ubuntu1.1) ...
dpkg: error: unknown option --compare-version

Type dpkg --help for help about installing and deinstalling packages [*];
Use `dselect' or `aptitude' for user-friendly package management;
Type dpkg -Dhelp for a list of dpkg debug flag values;
Type dpkg --force-help for a list of forcing options;
Type dpkg-deb --help for help about manipulating *.deb files;

Options marked [*] produce a lot of output - pipe it through `less' or `more' !
Setting up python3-problem-report (2.9.2-0ubuntu8.2) ...
Setting up python3-apport (2.9.2-0ubuntu8.2) ...
Setting up apport (2.9.2-0ubuntu8.2) ...
Installing new version of config file /etc/init/apport.conf ...
apport start/running
Setting up python-boto (2.3.0-1ubuntu0.13.04.1) ...
Processing triggers for ureadahead ...
$

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: upstart 1.8-0ubuntu1.1
ProcVersionSignature: Ubuntu 3.8.0-25.37-generic 3.8.13
Uname: Linux 3.8.0-25-generic x86_64
ApportVersion: 2.9.2-0ubuntu8.2
Architecture: amd64
Date: Fri Jun 28 23:31:19 2013
MarkForUpload: True
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdline: BOOT_IMAGE=/vmlinuz-3.8.0-25-generic root=/dev/mapper/rootfs--ssd--hybrid-os ro text
SourcePackage: upstart
UpgradeStatus: Upgraded to raring on 2013-01-26 (153 days ago)
UpstartBugCategory: System

Nick Semenkovich (semenko) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in upstart (Ubuntu):
status: New → Confirmed
Changed in upstart (Ubuntu Raring):
status: New → Triaged
importance: Undecided → High
assignee: nobody → Dmitrijs Ledkovs (xnox)
Changed in upstart (Ubuntu Saucy):
importance: Undecided → High
assignee: nobody → Dmitrijs Ledkovs (xnox)
description: updated
Changed in upstart (Ubuntu Raring):
status: Triaged → In Progress
Changed in upstart (Ubuntu Saucy):
status: Confirmed → Fix Committed

Hello Nick, or anyone else affected,

Accepted upstart into raring-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/upstart/1.8-0ubuntu1.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

description: updated
Changed in upstart (Ubuntu Raring):
status: In Progress → Fix Committed
tags: added: verification-needed
Nick Semenkovich (semenko) wrote :

Works great -- thanks!

semenko@exon:~$ apt-cache policy upstart
upstart:
  Installed: 1.8-0ubuntu1.2

tags: added: verification-done
removed: verification-needed
Steve Langasek (vorlon) on 2013-07-02
Changed in upstart (Ubuntu Raring):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package upstart - 1.9-0ubuntu1

---------------
upstart (1.9-0ubuntu1) saucy; urgency=low

  [ Dmitrijs Ledkovs ]
  * Use dh_auto_build to run the testsuite, as dh_auto_test stopped
    finding autotools test suite.
  * Correct typo in upstart postinst (LP: #1195955)

  [ James Hunt ]
  * New upstream release.
  * init/tests/test_conf.c: Remove duplicate define.

  [ Stéphane Graber ]
  * Cherry-pick r1498 from upstream upstart to fix incorrect respawn handling
    for jobs that have shell characters in their expanded command line.
    (LP: 1181789)

  [ Marc Deslauriers ]
  * Added some distro-specific changes:
    - init/apparmor.c: do not load apparmor if running in a container or a
      live cd.
    - init/job_process.c: don't fail if the security profile failed to load
      to emulate current behaviour on Ubuntu.
 -- Dmitrijs Ledkovs <email address hidden> Tue, 02 Jul 2013 20:14:51 +0100

Changed in upstart (Ubuntu Saucy):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers