desktop-exec crashed with signal 5 in main()

Bug #1238068 reported by Michał Sawicz on 2013-10-10
36
This bug affects 6 people
Affects Status Importance Assigned to Milestone
upstart-app-launch (Ubuntu)
Medium
Ted Gould

Bug Description

Crash during webbrowser ap tests.

ProblemType: Crash
DistroRelease: Ubuntu 13.10
Package: upstart-app-launch 0.1+13.10.20131008.1-0ubuntu1
Uname: Linux 3.4.0-3-mako armv7l
ApportVersion: 2.12.5-0ubuntu1
Architecture: armhf
Date: Thu Oct 10 14:25:53 2013
ExecutablePath: /usr/lib/arm-linux-gnueabihf/upstart-app-launch/desktop-exec
ExecutableTimestamp: 1381227405
InstallationDate: Installed on 2013-10-10 (0 days ago)
InstallationMedia: Ubuntu Saucy Salamander (development branch) - armhf (20131010.1)
MarkForUpload: True
ProcCmdline: /usr/lib/arm-linux-gnueabihf/upstart-app-launch/desktop-exec
ProcCwd: /home/phablet
Signal: 5
SourcePackage: upstart-app-launch
StacktraceTop: main (argc=1, argv=<optimized out>) at /build/buildd/upstart-app-launch-0.1+13.10.20131008.1/desktop-exec.c:47
Title: desktop-exec crashed with signal 5 in main()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm autopilot cdrom dialout dip nopasswdlogin plugdev sudo tty video

Related branches

Michał Sawicz (saviq) wrote :
information type: Private → Public

StacktraceTop: main () at /build/buildd/upstart-app-launch-0.1+13.10.20131008.1/desktop-exec.c:47

Changed in upstart-app-launch (Ubuntu):
importance: Undecided → Medium
tags: removed: need-armhf-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in upstart-app-launch (Ubuntu):
status: New → Confirmed
Ted Gould (ted) on 2014-04-16
Changed in upstart-app-launch (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Ted Gould (ted)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package upstart-app-launch - 0.3+14.10.20140521-0ubuntu1

---------------
upstart-app-launch (0.3+14.10.20140521-0ubuntu1) utopic; urgency=low

  [ Ted Gould ]
  * Drop Surface Flinger support
  * Debug message for valid, though rare, conditions. (LP: #1301173)
  * More elegant handling of bad application id errors (LP: #1238068)
  * Set LD_LIBRARY_PATH to include the application directory
 -- Ubuntu daily release <email address hidden> Wed, 21 May 2014 17:41:20 +0000

Changed in upstart-app-launch (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers