Laptop screen dims at login screen

Bug #968532 reported by edu jose on 2012-03-29
36
This bug affects 7 people
Affects Status Importance Assigned to Milestone
upower (Ubuntu)
Undecided
Unassigned

Bug Description

When I start the laptop brightness is ok, but arriving at the login screen brightness goes down to zero. Brightness keys work, and using Fn + bright up one time brings the screen back to light, showing normally the lightdm login screen. When brightness is zero the login screen can be seen using the lamp in my table, so it's there but with no backlight from the laptop.

This happens using a fresh install of Ubuntu 12.04 Precise Pangolin Beta 1 (amd64), updated as of today.

Laptop is an HP pavillion dm4-2120ss, using an intel core i3 2330M CPU (Sandy Bridge). It has integrated graphics only (intel HD 3000 I think).

Maybe this is related to bug #255039, though there an NVidia graphics is used in the laptop (an HP too).

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: acpi-support 0.140
ProcVersionSignature: Ubuntu 3.2.0-20.33-generic 3.2.12
Uname: Linux 3.2.0-20-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 1.95-0ubuntu1
Architecture: amd64
Date: Thu Mar 29 20:49:31 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120301)
SourcePackage: acpi-support
UpgradeStatus: No upgrade log present (probably fresh install)

edu jose (pepinmore) wrote :
Steve Langasek (vorlon) on 2012-03-29
affects: acpi-support (Ubuntu) → upower (Ubuntu)
edu jose (pepinmore) wrote :

I found this workaround (from bug #35223, comment #51):

"[...] If I put

echo 2 > /sys/class/backlight/acpi_video0/brightness

in /etc/rc.local (before exit 0) it seems to work."

Indeed it works; I just changed 2 to 1, as 1 gives a low but acceptable brightness level on this laptop.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in upower (Ubuntu):
status: New → Confirmed
Philip Guyton (phil-lxnet) wrote :

Just Experience this same bug on an

HP Pavilion g6 Notebook

using Sandybridge Mobile (GT1) chipset.
Integrated graphics controller rev 09

The suggested echo line also worked for me though 3 was a normal brightness level.

Ubuntu 12.04 installed from 19th April iso nightly and all updates applied as of writing.

Philip Guyton (phil-lxnet) wrote :

Just adding that this HP Pavilion g6 has a Pentium B940 @ 2 GHz
so looks like integrated HD3000 graphics as well.

Kendall Gifford (zettabyte) wrote :

I've got the same problem on my HP Pavilion dm4 w/the integrated Intel HD3000 graphics as well.

Daniel Cordeiro (dcordeiro) wrote :

This bug also affects the latest Ubuntu 12.10 (Quantal Quetzal). :(

tags: added: quantal
Heitor Moreira (heitormsilva) wrote :

I confirm this bug on Kubuntu 13.10 amd 64 (fresh installation) in:
Product Name: HP Pavilion dv4 Notebook PC

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers