Ubuntu

upowerd crashed with SIGSEGV in dbus_connection_send()

Reported by Ubuntu4life on 2010-08-06
402
This bug affects 81 people
Affects Status Importance Assigned to Milestone
upower (Ubuntu)
Critical
Martin Pitt
Maverick
Critical
Martin Pitt

Bug Description

Binary package hint: upower

Ubuntu Netbook Edition
X64
Daily-live august 6th
I Don't know what I was doing.
If any more information is needed please just ask.

ProblemType: Crash
DistroRelease: Ubuntu 10.10
Package: upower 0.9.5-1
ProcVersionSignature: Ubuntu 2.6.35-14.19-generic 2.6.35
Uname: Linux 2.6.35-14-generic i686
Architecture: i386
Date: Fri Aug 6 01:08:10 2010
ExecutablePath: /usr/lib/upower/upowerd
InstallationMedia: Ubuntu-Netbook 10.10 "Maverick Meerkat" - Alpha i386 (20100803.1)
ProcCmdline: /usr/lib/upower/upowerd
ProcEnviron:

SegvAnalysis:
 Segfault happened at: 0xb337f8 <dbus_connection_send+40>: mov 0x4(%esi),%eax
 PC (0x00b337f8) ok
 source "0x4(%esi)" (0x00000014) not located in a known VMA region (needed readable region)!
 destination "%eax" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: upower
StacktraceTop:
 dbus_connection_send () from /lib/libdbus-1.so.3
 dbus_g_method_return () from /usr/lib/libdbus-glib-1.so.2
 ?? ()
 g_cclosure_marshal_VOID__POINTER ()
 ?? () from /usr/lib/libdbus-glib-1.so.2
Title: upowerd crashed with SIGSEGV in dbus_connection_send()
UserGroups:

Related branches

visibility: private → public
yamo (stephane-gregoire) wrote :

Today I've had also this bug.

Hansen (moteprime) wrote :

Booted live session on netbook, Asus eee 1005p the bug was there after startup of "Try Ubuntu".

Hansen (moteprime) wrote :

Sorry forgot to add: Maverick daily image, alpha 3, dated 24. august.

Anthony Hook (anthonyhook) wrote :

I was greeted with this bug report shortly after logging in on a fresh bootup.

x86 Netbook Edition

tags: added: armel
Ricardo Salveti (rsalveti) wrote :

Also happens on Beagleboard, using Omap 3 image from 20100830.

I'm not using a live edition. I just rebooted and got the crash message. I wasn't doing anything differently.

Blaster (holst-niels) wrote :

x86 normal edition. Happened right after boot.

Giulio Collura (gcollura) wrote :

x86 desktop edition using 10.10 live image.

Ubuntu4life (jeroenmerks) wrote :

It seems to effect a lot of people, what do I need to do to get some attention? I'm not a coder myself.
What can I do to speed up or help with the fix? Am I doing anything wrong?

This seems to happen whenever I go into sleep or hibernation. When I come out, I get this error and I have issues with connecting to a wireless network. Some serious problems somewhere with sleep/hibernation.

Blaster (holst-niels) wrote :

I can confirm #11 for a Samsung netbook N150, a Toshiba Satellite Pro L300, a Dell Latitude D600 and a Lenovo ThinkPad T410i.

Yes, Ubuntu apparently just stopped supporting hibernation starting with 10.04. Not that that's a real problem, we all kind of run old stationaries. Get real!

Power Management problems - both hibernate and suspense - has been neglected for close to a year. It worked pretty damn good in 9.10.

Best of luck beating launchpad bug #1 without a fix for this.

Arthur (adolphsn) wrote :

Happens a startup, Intel D510 chip, also will not hold the panels after changing resolution.

Just happened randomly for me; I haven't used suspend/hibernate, etc at all today. I had just closed the shotwell photo manager, and used ctrl+alt+left to get to an application on another workspace when mutter crashed (and then restarted) and I was left with a bug report for this package.

madbiologist (me-again) wrote :

I keep getting this with Ubuntu 10.10 "Maverick Meerkat" beta desktop edition Live CD. Today I booted my system and then didn't touch it for several hours. When I returned this crash notification was in my top panel. I see the same thing after every bootup, even if I am using the system.

Uname: Linux 2.6.35-19-generic i686
upower 0.9.5-1

Changed in upower (Ubuntu Maverick):
importance: Undecided → High
importance: High → Critical
importance: Critical → High
Changed in upower (Ubuntu Maverick):
importance: High → Critical
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
Martin Pitt (pitti) on 2010-09-15
Changed in upower (Ubuntu Maverick):
status: New → Confirmed
assignee: Canonical Desktop Team (canonical-desktop-team) → Martin Pitt (pitti)

Thank you for taking the time to report this crash and helping to make Ubuntu better. This particular crash has already been reported and is a duplicate of bug #613594, so is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Please continue to report any other bugs you may find.

Martin Pitt (pitti) wrote :

Please ignore the previous comment from the Apport retracers.

tags: removed: need-i386-retrace
Martin Pitt (pitti) on 2010-09-24
Changed in upower (Ubuntu Maverick):
status: Confirmed → In Progress
Martin Pitt (pitti) wrote :

The crash happens in dbus-glib, but all the dups crash within up_daemon_{suspend,hibernate}_allowed(). There is no firm proof for it, but it is very likely that this is due to a double D-BUS result return. This was recently fixed in

   http://cgit.freedesktop.org/upower/commit/?id=3967e062ef5a58c4f3f283f34d591c6e8a5d8788

While I'm at it, I'll also import two other fixes which were done recently:

  http://cgit.freedesktop.org/upower/commit/?id=d815c491eb105c49a7dbcb29c355ca9aaa8d92c4
  http://cgit.freedesktop.org/upower/commit/?id=4a53c56a913b002d4f7e23b3379ccb134ed454db

Martin Pitt (pitti) wrote :

Fix committed to Debian bzr and uploaded to sid and maverick. Needs a release team member to review/approve now.

Changed in upower (Ubuntu Maverick):
status: In Progress → Fix Committed
Bryan Aho (virtualbry) wrote :

I'd be glad to test this on my PC if there is a prerelease ISO that includes this change.

Ubuntu4life (jeroenmerks) wrote :

Well, thank you very much for fixing this bug (for so far) Martin Pitt !
Me and undoubtly many other Ubuntu/Debian users appreciate what you have done.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package upower - 0.9.5-3

---------------
upower (0.9.5-3) unstable; urgency=low

  * Add 00git_fix_double_dbus_return.patch,
    00git_fix_missing_polkit_dbus_return.patch,
    00git_fix_missing_qos_dbus_return.patch: Fix missing or duplicate D-BUS
    return values, which cause crashes. Patches cherrypicked from upstream git
    head. (LP: #614119)
 -- Martin Pitt <email address hidden> Fri, 24 Sep 2010 18:04:17 +0200

Changed in upower (Ubuntu Maverick):
status: Fix Committed → Fix Released
Bryan Aho (virtualbry) wrote :

I tested this using the x86 Desktop iso build from 25/09/2010, and the problem seems to be fixed in that build. Thanks!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers