Laptop suspends itself while on AC power

Bug #1238663 reported by Julien Olivier on 2013-10-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
upower (Ubuntu)
Critical
Unassigned

Bug Description

When I set my laptop to not supend when on AC power, it still suspend automatically after about an hour. It did work correctly in raring but not anymore in saucy.

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: gnome-settings-daemon 3.8.5-0ubuntu7
ProcVersionSignature: Ubuntu 3.11.0-12.19-generic 3.11.3
Uname: Linux 3.11.0-12-generic i686
ApportVersion: 2.12.5-0ubuntu1
Architecture: i386
Date: Fri Oct 11 15:20:43 2013
InstallationDate: Installed on 2010-09-15 (1121 days ago)
InstallationMedia: Ubuntu 10.04.1 LTS "Lucid Lynx" - Release i386 (20100816.1)
MarkForUpload: True
SourcePackage: gnome-settings-daemon
UpgradeStatus: Upgraded to saucy on 2011-04-01 (924 days ago)

Julien Olivier (julo) wrote :
Julien Olivier (julo) wrote :

This might be a duplicate of #1055874, but I'm not quite sure...

Sebastien Bacher (seb128) wrote :

Thank you for your bug report. The log files suggest you are running gnome-shell, is that true? If so, do you get the issue under Unity as well?

Changed in gnome-settings-daemon (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Julien Olivier (julo) wrote :

Yes, I use Ubuntu GNOME, not stock Ubuntu. I don't even have Unity installed but I'll try it if needed as soon as I can.

Sebastien Bacher (seb128) wrote :

well, not sure it's needed, but I can't confirm the issue here. It could be useful to run "gnome-settings-daemon --replace --debug" and let it idle/go to suspend and attach the log to the bug

Julien Olivier (julo) wrote :

Oddly enough, I am now unable to reproduce this bug... Sorry for the noise, you can close it and I'll re-open it if it bites me again.

Sebastien Bacher (seb128) wrote :

Closing it then, thanks

Changed in gnome-settings-daemon (Ubuntu):
status: Incomplete → Invalid
Julien Olivier (julo) wrote :

It happened again, and I attached the requested log.

Changed in gnome-settings-daemon (Ubuntu):
status: Invalid → New
Iain Lane (laney) wrote :

It's a bug in UPower not updating the properties right, meaning that g-s-d didn't know when you were on battery or power and getting confused because of this.

affects: gnome-settings-daemon (Ubuntu) → upower (Ubuntu)
Changed in upower (Ubuntu):
importance: Low → Critical
status: New → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package upower - 0.9.22-1ubuntu1

---------------
upower (0.9.22-1ubuntu1) saucy; urgency=low

  * Cherry-pick two fixes from upstream:
    - up-client: Really don't overwrite retval with prop values. Properties
      and property notification via libupower-glib got broken in 0.9.22.
      Incorrect values were being returned, meaning anything relying on these
      might do the wrong thing, such as in LP: #1238663
    - lib: Fix crasher calling _about_to_sleep_sync(). Crash fix.
 -- Iain Lane <email address hidden> Mon, 14 Oct 2013 11:41:36 +0100

Changed in upower (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers