Ubuntu

notifier 'Failure to download extra data' every kubuntu 12.04 restart

Reported by jmunin on 2012-04-24
126
This bug affects 28 people
Affects Status Importance Assigned to Milestone
update-notifier (Ubuntu)
Undecided
Unassigned

Bug Description

cat /var/lib/update-notifier/user.d/data-downloads-failed

Name: Failure to download extra data filesName-ar.UTF-8: فشل تنزيل ملفات البيانات الإضافيةName-ast.UTF-8: Fallu al descargar ficheros de datos estraName-bn.UTF-8: অতিরিক্ত ডাটা ফাইল ডাউনলোড করতে ব্যর্থ হয়েছেName-bs.UTF-8: Neuspjelo učitavanje dodatnih datoteka s podacimaName-ca.UTF-8: Ha fallat la baixada dels fitxers de dades addicionalsName-da.UTF-8: Kunne ikke hente ekstra datafilerName-de.UTF-8: Herunterladen von zusätzlichen Datendateien schlug fehlName-el.UTF-8: Αποτυχία λήψης επιπλέον αρχείων δεδομένωνName-en_AU.UTF-8: Failure to download extra data filesName-en_GB.UTF-8: Failure to download extra data filesName-eo.UTF-8: Fiasko dum elŝutado de pliaj datumdosierojName-es.UTF-8: Fallo al descargar archivos de datos extraName-fi.UTF-8: Ylimääräisten tiedostojen lataus epäonnistuiName-fr.UTF-8: Échec du téléchargement des données supplémentairesName-gd.UTF-8: Dh'fhàillig luchdadh a-nuas faidhlichean dàta a bharrachdName-gl.UTF-8: Fallo na descarga de ficheiros extra de datosName-he.UTF-8: הורדת קובצי נתוני נוספים נכשלהName-hr.UTF-8: Greška pri preuzimanju dodatnih podatkovnih datotekaName-hu.UTF-8: Nem sikerült letölteni az extra adatfájlokatName-id.UTF-8: Gagal mengunduh berkas data ekstraName-it.UTF-8: Scaricamento file dati extra non riuscitoName-ja.UTF-8: 追加データのダウンロードに失敗Name-km.UTF-8: បានបរាជ័យក្នុងការទាញយកឯកសារទិន្នន័យបន្ថែមName-lt.UTF-8: Nepavyko atsiųsti papildomų duomenų failųName-lv.UTF-8: Neizdevās lejupielādēt papildus datu failusName-ms.UTF-8: Gagal memuat turun fail data tambahanName-nl.UTF-8: Downloaden van extra gegevensbestanden is misluktName-oc.UTF-8: Fracàs del telecargament de las donadas suplementàriasName-pt_BR.UTF-8: Falha ao baixar arquivos de dados adicionaisName-ro.UTF-8: Eșec la descărcarea fișierelor cu date suplimentareName-ru.UTF-8: Ошибка загрузки дополнительных файлов данныхName-sk.UTF-8: Zlyhalo stiahnutie ďalších dátových súborovName-sl.UTF-8: Napaka med prejemom dodatnih podatkovnih datotekName-sq.UTF-8: Dështoi shkarkimi i skedarëve të të dhënave ekstraName-sv.UTF-8: Misslyckades med att hämta extra datafilerName-tr.UTF-8: Fazladan veri dosyalarını indirme başarısızName-ug.UTF-8: قوشۇمچە سانلىق-مەلۇمات ھۆججەتلىرىنى چۈشۈرۈش مەغلۇپ بولدىName-uk.UTF-8: Не вдалось завантажити додаткові файли данихName-vi.UTF-8: Lỗi khi tải các tập tin dữ liệu bổ sung xuốngName-zh_CN.UTF-8: 下载额外数据文件失败Name-zh_TW.UTF-8: 下載額外資料檔案失敗
Priority: High
Terminal: True
Command: gksudo /usr/lib/update-notifier/package-data-downloader
Description:
 The following packages requested additional data downloads after package
 installation, but the data could not be downloaded or could not be
 processed.
 .
 .
   flashplugin-installer
 .
 .
 The download will be attempted again later, or you can try the download
 again now. Running this command requires an active Internet connection.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: update-notifier (not installed)
ProcVersionSignature: Ubuntu 3.2.0-23.36-generic 3.2.14
Uname: Linux 3.2.0-23-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.0.1-0ubuntu5
Architecture: amd64
Date: Tue Apr 24 18:57:12 2012
InstallationMedia: Kubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120328)
ProcEnviron:
 LANGUAGE=
 TERM=xterm
 LANG=es_ES.UTF-8
 SHELL=/bin/bash
SourcePackage: update-notifier
UpgradeStatus: No upgrade log present (probably fresh install)

jmunin (jmunin) wrote :
Luca Borrione (luca.borrione) wrote :

I had a similar issue on lubuntu 12.04 while trying to install "ttf-mscorefonts-installer": it hangs for a while after
"ttf-mscorefonts-installer: downloading http://downloads.sourceforge.net/corefonts/andale32.exe"
and then it ended giving the same error reported here, with the only difference that in mine it put "ttf-mscorefonts-installer" in place of "flashplugin-installer".

I successfully solved the issue by installing "libgtk2-perl".

Luca Borrione (luca.borrione) wrote :

I forgot to mention to reinstall the package after that by typing

sudo apt-get install --reinstall flashplugin-installer

It's obvious in my head, but maybe not so for readers.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in update-notifier (Ubuntu):
status: New → Confirmed
Eugene (eugene-vanderwatt) wrote :

I am also affected by this bug. Ubuntu also prompts internal error and powers-off at times....

bryncoles (brunomatti) wrote :

lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.04 LTS
Release: 12.04
Codename: precise

I am getting this error too, on an old HP Compaq nx9010. Going to try the 'libgtk2-perl' suggestion above now, and see what happens!

bryncoles (brunomatti) wrote :

oops, forgot to mention, the problem package is the MTT corefonts (or whatever that is called)

Francesco D'Anisi (ciccios) wrote :

i have the same bug.

this is the image of the bug.

Bernie Bernstein (bernie9998) wrote :

I tried the suggested fix above, installing libgtk2-perl and then reinstalling flashplugin-installer. However, I still receive this error message on occasion.

Max Polk (maxpolk) wrote :

Possible duplicate of 994584 (and maybe 290062 duplicate of 556293)

Robalo Claude (claude-robalo) wrote :

Hello,

same error with Kubuntu 12.04 LTS : failure ....

Impossible to click on "continue this action ?"

Have a nice day,

Claude

Brad Forschinger (bnjf) wrote :

In my case the proxy wasn't being used. Running

sudo -E /usr/lib/update-notifier/package-data-downloader

from a command prompt fixed it.

jifg (jifges) wrote :

It seems that flashplugin-installer tries to download a file that is not available in the repository:

$ sudo /usr/lib/update-notifier/package-data-downloader
flashplugin-installer: downloading http://archive.canonical.com/pool/partner/a/adobe-flashplugin/adobe-flashplugin_11.2.202.233.orig.tar.gz

$ wget http://archive.canonical.com/pool/partner/a/adobe-flashplugin/adobe-flashplugin_11.2.202.233.orig.tar.gz
--2012-06-06 09:18:42-- http://archive.canonical.com/pool/partner/a/adobe-flashplugin/adobe-flashplugin_11.2.202.233.orig.tar.gz
Resolving archive.canonical.com (archive.canonical.com)... 91.189.92.150, 91.189.92.191
Connecting to archive.canonical.com (archive.canonical.com)|91.189.92.150|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2012-06-06 09:18:42 ERROR 404: Not Found.

nikman (nikita-manovich) wrote :

I can confirm that "sudo -E /usr/lib/update-notifier/package-data-downloader" from command line fixes the problem. My machine is behind a proxy server.

JW (arch0njw) wrote :

sudo -E /usr/lib/update-notifier/package-data-downloader
does not work for me.

I am behind a proxy.

Kubunut 12.04 64-bit.

asgard2 (kamp000x) wrote :

I have the same bug, but it is only in my 12.04 virtual maschine with unity.
http://www.xup.in/dl,11564137/Bildschirmfoto_vom_2012-08-19_11:06:42.png/

I updated with apt-get upgrade, but the window already appears.

It is not just a problem with kubuntu.

JW (arch0njw) wrote :

I think I may have gotten "sudo -E /usr/lib/update-notifier/package-data-downloader" to work. I had to export the following variables as below:

$ export http_proxy='http://server.domain.ext:port/'
$ export https_proxy='http://server.domain.ext:port/'
$ export ftp_proxy='http://server.domain.ext:port/'

I then saw this happy little message:
flashplugin-installer: downloading http://archive.canonical.com/pool/partner/a/adobe-flashplugin/adobe-flashplugin_11.2.202.251.orig.tar.gz
Installing from local file /tmp/tmpiuX3Vk.gz
Flash Plugin installed.

Hopefully this helps someone else -- and perhaps the devs so they can make sure these variables pass through to package-data-downloader.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers