update-notifier setup hangs during installation of Precise with ubiquity

Bug #984373 reported by Max Brustkern on 2012-04-17
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
update-notifier (Ubuntu)
High
Unassigned
Precise
High
Unassigned

Bug Description

I'm installing the precise beta onto a lenovo thinkcentre m91p. I've done 2 installs from the same CD that ran to completion, one of them earlier today on the same disk. This time, the installer got up to "Installing system" then reported an invalid framebuffer.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: ubiquity 2.10.4
ProcVersionSignature: Ubuntu 3.2.0-20.33-generic 3.2.12
Uname: Linux 3.2.0-20-generic x86_64
ApportVersion: 1.95-0ubuntu1
Architecture: amd64
CasperVersion: 1.312
Date: Tue Apr 17 16:55:28 2012
InstallCmdLine: file=/cdrom/preseed/ubuntu.seed boot=casper only-ubiquity initrd=/casper/initrd.lz quiet splash --
LiveMediaBuild: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120328)
ProcEnviron:
 TERM=linux
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Max Brustkern (nuclearbob) wrote :
Max Brustkern (nuclearbob) wrote :

To clarify "stops," the machine is still responsive and not frozen. I can switch to other consoles and look at logs, and the installer responds to mouse and keyboard commands, and shows the log, it just doesn't seem to proceed any further. It does not freeze or crash.

Jean-Baptiste Lallement (jibel) wrote :

Thanks for your report.

The installer so;etimes hangs without any feedback when update-notifier downloads package data.
I got the same on VM but after some time it timed out and installation continued.

Changed in ubiquity (Ubuntu):
importance: Undecided → High
status: New → Confirmed
Changed in ubiquity (Ubuntu Precise):
assignee: nobody → Canonical Foundations Team (canonical-foundations)
affects: ubiquity (Ubuntu Precise) → update-notifier (Ubuntu Precise)
summary: - Install stops during "Installing System"
+ update-notifier setup hangs during installation of Precise
summary: - update-notifier setup hangs during installation of Precise
+ update-notifier setup hangs during installation of Precise with ubiquity
tags: added: rls-mgr-p-tracking
Steve Langasek (vorlon) wrote :

Do you have some idea why this is hanging in your case? Is there a firewall that prevents the supplemental data files from being downloaded, leading to an indefinite hang?

I'm sure we need to make this more robust, but it would help to be sure first that we're reproducing the right issue.

Jean-Baptiste Lallement (jibel) wrote :

I have no confirmation but it seems to be caused by a host at archive.canonical.com being slow to respond.

I have no firewall blocking data files from being downloaded and use a proxy that doesn't cache tar.gz files.
From the logs of the proxy, response time from archive.canonical.com was 241s, then 49s on next try (file being downloaded was adobe-flashplugin_11.2.202.233.orig.tar.gz)

I ran 100 iterations of the following command today with and without proxy:
rm /var/lib/update-notifier/package-data-downloads/flashplugin-installer; apt-get install --reinstall update-notifier-common

None of them failed and I couldn't reproduce the hang. Average response times are below 5s for scandium.canonical.com and between 7s and 10s for sadalbari.canonical.com.

Here is an excerpt of my proxy's logs for yesterdays tries:
TimeStamp ResponseTime (ms) Peer
2012-04-17 11:14:07 240914 91.189.92.191
2012-04-17 11:19:42 49232 91.189.92.191
2012-04-17 11:34:11 4364 91.189.88.33
2012-04-17 11:39:13 4591 91.189.88.33
2012-04-17 11:49:27 4501 91.189.88.33
2012-04-17 12:07:56 8955 91.189.92.191
2012-04-17 13:02:37 10554 91.189.92.191

My guess is that remote host was slow to respond/unresponsive which froze the downloader.

Steve Langasek (vorlon) wrote :

The downloader is written using a well-exercised python library; it's unlikely to have bugs that cause hangs due to slow servers. Obviously if the server is *slow*, it will take a long time to download the data, and there'll be no feedback in the GUI while this is happening, but that's nothing new.

When the hang happens, are you able to pull up the terminal showing the package progress? Is it possible you just didn't wait long enough for the download to finish from the really slow server?

Steve Langasek (vorlon) on 2012-04-19
Changed in update-notifier (Ubuntu Precise):
status: Confirmed → Incomplete
assignee: Canonical Foundations Team (canonical-foundations) → Steve Langasek (vorlon)
Max Brustkern (nuclearbob) wrote :

It is possible I didn't wait long enough. I only gave it about 30 minutes. 2 other installs on the same hardware with the same CD on the same day finished normally, so I don't have a good way to recreate it at this point. The machine was still responsive, and I could view logs in the console, but nothing was updated for about 30 minutes until I gave up.

Steve Langasek (vorlon) wrote :

Ok. 30 minutes is certainly longer than the tcp timeout, so if this were simply an /unresponsive/ server you should have seen an error well before then. I suspect it was instead just a really bad connection to the server. But if you can recreate this, I'd be happy to do some further debugging in realtime on IRC.

Max Brustkern (nuclearbob) wrote :

All my other installs so far on that machine have worked as expected. Should I keep trying with the old CD, or try a newer one?

On Fri, Apr 20, 2012 at 09:30:44PM -0000, Max Brustkern wrote:
> All my other installs so far on that machine have worked as expected.
> Should I keep trying with the old CD, or try a newer one?

There've been no relevant changes... I think you should probably just use
the newest.

Hi,

I've got the exact same issue, the upgrade hung off while downloading ms-core-fonts from sourceforge. After 2 hours waiting for the process to continue, I decided to kill the process downloading the package.

So I just ran "sudo htop" then F5 to see the tree of process, I started from the main process responsible for the upgrade to precise and searched for the one reponsible for the download. I killed this one, then the process skips the ms-core-font download part then continues and finishes the updrage to precise.

Hope this can help.

Cheers!

Steve Langasek (vorlon) on 2012-05-02
Changed in update-notifier (Ubuntu Precise):
assignee: Steve Langasek (vorlon) → nobody
Changed in update-notifier (Ubuntu):
assignee: Steve Langasek (vorlon) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers