package downloader doesn't follow redirects

Bug #977812 reported by marcobra (Marco Braida) on 2012-04-10
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
update-notifier (Ubuntu)
High
Colin Watson
Precise
High
Colin Watson

Bug Description

Description: Ubuntu precise (development branch)
Release: 12.04
ubuntu@ubuntu-sin:/var/log/apt$ apt-cache policy ttf-mscorefonts-installer
ttf-mscorefonts-installer:
  Installato: 3.4ubuntu3
  Candidato: 3.4ubuntu3
  Tabella versione:
 *** 3.4ubuntu3 0
        500 http://archive.ubuntu.com/ubuntu/ precise/multiverse i386 Packages
        100 /var/lib/dpkg/status

Here the /var/log/apt/term.log part with error i get... seems a temporary error: i report, it may help developers

http://downloads.sourceforge.net/corefonts/andale32.exe^M
Traceback (most recent call last):^M
  File "/usr/lib/update-notifier/package-data-downloader", line 233, in process_download_requests^M
    dest_file = urllib.urlretrieve(files[i])[0]^M
  File "/usr/lib/python2.7/urllib.py", line 93, in urlretrieve^M
    return _urlopener.retrieve(url, filename, reporthook, data)^M
  File "/usr/lib/python2.7/urllib.py", line 239, in retrieve^M
    fp = self.open(url, data)^M
  File "/usr/lib/python2.7/urllib.py", line 207, in open^M
    return getattr(self, name)(url)^M
  File "/usr/lib/python2.7/urllib.py", line 358, in open_http^M
    return self.http_error(url, fp, errcode, errmsg, headers)^M
  File "/usr/lib/python2.7/urllib.py", line 375, in http_error^M
    return self.http_error_default(url, fp, errcode, errmsg, headers)^M
  File "/usr/lib/python2.7/urllib.py", line 380, in http_error_default^M
    raise IOError, ('http error', errcode, errmsg, headers)^M
IOError: ('http error', 307, 'Temporary Redirect', <httplib.HTTPMessage instance at 0xb73b18cc>)^M
Setting up update-notifier (0.119ubuntu5) ...^M

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: ttf-mscorefonts-installer 3.4ubuntu3
ProcVersionSignature: Ubuntu 3.2.0-22.35-generic-pae 3.2.14
Uname: Linux 3.2.0-22-generic-pae i686
ApportVersion: 2.0-0ubuntu4
Architecture: i386
Date: Tue Apr 10 09:37:40 2012
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=it:en
 TERM=xterm
 PATH=(custom, user)
 LANG=it_IT.UTF-8
 SHELL=/bin/bash
SourcePackage: msttcorefonts
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

affects: msttcorefonts (Ubuntu) → update-notifier (Ubuntu)
Jean-Baptiste Lallement (jibel) wrote :

reproduced on precise when the downloader hits this URL
http://downloads.sourceforge.net/corefonts/andale32.exe

summary: - error downloading/installing andale32.exe font
+ package downloader doesn't follow redirects
Changed in update-notifier (Ubuntu):
importance: Undecided → High
tags: added: regression-release
Changed in update-notifier (Ubuntu Precise):
assignee: nobody → Canonical Foundations Team (canonical-foundations)
milestone: none → ubuntu-12.04
assignee: Canonical Foundations Team (canonical-foundations) → nobody
status: New → Triaged
assignee: nobody → Canonical Foundations Team (canonical-foundations)
tags: added: rls-p-tracking
Colin Watson (cjwatson) wrote :

This is specific to the case where there's a proxy.

Changed in update-notifier (Ubuntu Precise):
assignee: Canonical Foundations Team (canonical-foundations) → Colin Watson (cjwatson)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-notifier - 0.119ubuntu6

---------------
update-notifier (0.119ubuntu6) precise; urgency=low

  * data/package-data-downloader: Set urllib._urlopener to an instance of
    urllib.FancyURLopener rather than urllib.URLopener, since the former
    handles redirects (LP: #977812).
 -- Colin Watson <email address hidden> Tue, 10 Apr 2012 12:15:08 +0100

Changed in update-notifier (Ubuntu Precise):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers