After upgrading to 12.04, flash doesn't seem to be installed to Firefox even though the package is.

Bug #977178 reported by Lazy on 2012-04-09
154
This bug affects 31 people
Affects Status Importance Assigned to Milestone
update-notifier (Ubuntu)
High
Steve Langasek

Bug Description

Well, the summary says it all. After upgrading to 12.04 the flash is not working anymore in Firefox.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: flashplugin-installer 11.2.202.228ubuntu3
ProcVersionSignature: Ubuntu 3.2.0-22.35-generic 3.2.14
Uname: Linux 3.2.0-22-generic x86_64
ApportVersion: 2.0-0ubuntu4
Architecture: amd64
Date: Mon Apr 9 14:39:11 2012
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: flashplugin-nonfree
UpgradeStatus: Upgraded to precise on 2012-04-09 (0 days ago)

Related branches

Lazy (ubuntu-bugs-oittaa) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in flashplugin-nonfree (Ubuntu):
status: New → Confirmed
Lazy (ubuntu-bugs-oittaa) wrote :

Workaround for this is to run the following command:

sudo apt-get --reinstall install flashplugin-installer

But this should be fixed properly, because otherwise there will be tons of pissed off users whose youtube videos won't work after upgrading.

Steve Langasek (vorlon) on 2012-04-09
Changed in flashplugin-nonfree (Ubuntu):
importance: Undecided → High
Steve Langasek (vorlon) on 2012-04-09
Changed in flashplugin-nonfree (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Steve Langasek (vorlon)
Steve Langasek (vorlon) wrote :

This was fixed in update-notifier 0.119ubuntu5. Changelog:

update-notifier (0.119ubuntu5) precise; urgency=low

  * Make sure /usr/lib/update-notifier/package-data-downloader is called on
    package configuration as well, since a trigger is not guaranteed to
    happen if the triggering package is configured first. LP: #977178.

affects: flashplugin-nonfree (Ubuntu) → update-notifier (Ubuntu)
Changed in update-notifier (Ubuntu):
status: In Progress → Fix Released
Markus Berndt (markus-berndt) wrote :

The proposed fix in #3 does not work for me. Am behind a proxy which I have manually configured systemwide, such that the relevant proxy environment variables show up in /etc/environment. However, while the package flashplugin-installer installs fine, it fails to download the file

http://archive.canonical.com/pool/partner/a/adobe-flashplugin/adobe-flashplugin_11.2.202.228.orig.tar.gz

I suspect that the process that is supposed to download this file does not have the complete environment that should include /etc/environment.

Steve Langasek (vorlon) wrote :

Markus, the job that downloads the files is run in the same context as the rest of the package manager; so if packages are being downloaded using the proxy configured in /etc/environment (as opposed to, say, the apt proxy setting which is automatically managed by the same option in the desktop config dialog), it should work.

How are you invoking the package manager? A workaround is almost certainly possible for your case, but it will depend on you're doing the package install - and there may be some bugs here as well.

Markus Berndt (markus-berndt) wrote :

I am installing from the terminal with

sudo apt-get install flashplugin-installer

it asks for my password, installs the package, and almost immediately the a window pops up titled "Information available" that states

<quote>
Failure to download extra data files

The following packages requested additional data downloads after package installation, but the data could not be downloaded or could not be processed.

flashplugin-installer

The download will be attempted again later, or you can try the download again now. Running this command requires an active Internet connection.
</quote>

When I click on the button "Run this action now" I am asked to enter my password, then a terminal window pops up for an instant and then disappears. It looks like there's an error message displayed in that terminal window but it disappears too quickly for me to read it. That's it, the file with the plugin is not downloaded.

One thing I now noticed is that when I get a root shell with 'sudo bash', wget does not work with my proxy, while it works fine from my user account. Maybe that is actually the problem?

On Fri, Apr 13, 2012 at 09:34:05PM -0000, Markus Berndt wrote:
> One thing I now noticed is that when I get a root shell with 'sudo
> bash', wget does not work with my proxy, while it works fine from my
> user account. Maybe that is actually the problem?

Yes, that's the problem in this context.

You can specify in /etc/sudoers that you want your proxy variable to be
preserved by adding this line:

Defaults env_keep="http_proxy"

Note that this allows any user with sudo access to MITM root's network
connections, so is not enabled by default.

We should really just make sudo pull in /etc/environment though, I think.

Markus Berndt (markus-berndt) wrote :

Awesome, adding that line to /etc/sudoers did it!

Thanks a bunch!

AndresClari (andresclari) wrote :

On a clean install this seems to be an issue.

I downloaded the latest beta, upraded all packages and I still get the "Couln't load plugin" error in chrome.

Did you manually attempt to install the plugin? - sudo apt-get install flashplugin-installer (not sure if flashplugin-downloader
 is needed)

By chrome did you mean the browser? Google Chrome (not Chromium) has flash built into the sandbox so no additional plugins are needed.

zub (zub-linux) wrote :

I have http_proxy environment variable and I have proxy configured in /etc/apt/apt.conf.d. This is what I believe to be the correct setup - no MITM via sudo, and update-manager, apt, aptitude, jockey just work.

Where does the dialog originate from? update-notifier? But is it also the source of the text? I'd have guessed it's flashplugin-installer-related script trying to download something, and not using apt's proxy, and not seeing http_proxy.

Could you not just make the flashplugin-installer script (or whatever is it that is trying to do the download) pull in /etc/profile? That sounds sane to me, I don't see it being a hole for the http_proxy hijack as sudo would be. Sounds safer to me than just passing http_proxy through sudo. Also note that sudo -i does pull /etc/profile in.

But I don't know what do the GUI tools provided in Ubuntu to set http proxy do. Whatever the solution, it should work for a user who just sets http_proxy by GUI. (And this I assume does not set apt proxy, or does it? Oh...)

Steve Langasek (vorlon) wrote :

On Fri, May 04, 2012 at 07:25:01AM -0000, zub wrote:
> I have http_proxy environment variable and I have proxy configured in
> /etc/apt/apt.conf.d. This is what I believe to be the correct setup - no
> MITM via sudo, and update-manager, apt, aptitude, jockey just work.

See bug #982684.

> Where does the dialog originate from? update-notifier? But is it also
> the source of the text? I'd have guessed it's flashplugin-installer-
> related script trying to download something, and not using apt's proxy,
> and not seeing http_proxy.

The dialog is from update-notifier.

> Could you not just make the flashplugin-installer script (or whatever is
> it that is trying to do the download) pull in /etc/profile? That sounds
> sane to me, I don't see it being a hole for the http_proxy hijack as
> sudo would be. Sounds safer to me than just passing http_proxy through
> sudo. Also note that sudo -i does pull /etc/profile in.

It wouldn't be a hole, but I don't know that manually pulling in
/etc/profile is correct. Anyway, we are never execing a shell here; parsing
/etc/profile in python would be messy, to say the least.

I think the main issue still affecting people is bug #982684, which I'm
working on.

zub (zub-linux) wrote :

Agreed, resolving bug #982684 resolves this and probably a host of other issues.

Lazy (ubuntu-bugs-oittaa) wrote :

I don't have any proxy configurations. Just a simple firewall between the computer and the internet.

Lazy (ubuntu-bugs-oittaa) wrote :

You can probably ignore my last comment. I didn't notice that this was probably fixed in my case with "update-notifier (0.119ubuntu5)".

Marcin Wojtczuk (fastviper) wrote :

Erm.. can you please explain in a few words how it is possible for such a major bug not to be fixed?
I just upgraded from 10.04 LTS to 12.04 LTS and lost flash in Firefox. I did simmilar thing with my home machine (10.04 LTS -> 11.04) and also lost flash, but hoped it was some kind of my mistake.

Seeing this bug made me realise, Ubuntu is no longer a work environment for me.
You see, I work in website creating company and now I'm left with only one choice - install Windows on my machine.
I cannot do my work as a tester without flash. I need it to do my job.
And this problem affects thousands of machines, not 28 people. Thousands!

Marcin Wojtczuk (fastviper) wrote :

We have managed to get back Flash in Firefox 22 to work on Ubuntu 12.04.
Steps:
reinstall flashplugin-installer
reinstall FIREFOX (sic!)
move ~/.mozilla to backup directory
Start firefox.

All steps required - which suggests that the problem is not distribution-only.
There is some kind of problem with firefox settings (and It's not libflashplayer.so in ~/.mozilla/plugins, trust me)

Marcin Wojtczuk (fastviper) wrote :

Sadly te above "fix" is not true. We tested flash on youtube and got HTML5 video :(

What really fixed the problem was forcing older librtmp version to install:

sudo apt-get install librtmp0=2.4~20110711.gitc28f1bab-1

I had newer from XBMC custom repository and installing distribution, older version fixed both gnash and Adobe Flash.
So it really *was* local problem, althrough probably common.

James Lewis (james-fsck) wrote :

At least one of the issues mentioned above appears still to affect me in 14.04.1. I completed a fresh install, and then set up a system wide proxy using the system settings dialog, I was then able to update and install new packages via apt, and the software centre, but I keep getting the popup attempting to download flash and failing.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers