update notifier crashes on startup

Bug #95727 reported by salman on 2007-03-25
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
update-notifier (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: update-notifier

Memory status: size: 30203904 vsize: 0 resident: 30203904 share: 0 rss: 12197888 rss_rlim: 0
CPU usage: start_time: 1174704851 rtime: 0 utime: 41 stime: 0 cutime:39 cstime: 0 timeout: 2 it_real_value: 0 frequency: 262

Backtrace was generated from '/usr/bin/update-notifier'

(no debugging symbols found)
Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1225259344 (LWP 4778)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
0xffffe410 in __kernel_vsyscall ()
#0 0xffffe410 in __kernel_vsyscall ()
#1 0xb740e323 in __waitpid_nocancel ()
   from /lib/tls/i686/cmov/libpthread.so.0
#2 0xb7f221b6 in gnome_gtk_module_info_get () from /usr/lib/libgnomeui-2.so.0
#3 <signal handler called>
#4 0xb733c375 in memcpy () from /lib/tls/i686/cmov/libc.so.6
#5 0xb74235ca in g_array_append_vals () from /usr/lib/libglib-2.0.so.0
#6 0xb7b32c80 in notify_notification_set_icon_from_pixbuf ()
   from /usr/lib/libnotify.so.1
#7 0x080514a0 in ?? ()
#8 0x081a6d50 in ?? ()
#9 0x00000000 in ?? ()

Thread 1 (Thread -1225259344 (LWP 4778)):
#0 0xffffe410 in __kernel_vsyscall ()
No symbol table info available.
#1 0xb740e323 in __waitpid_nocancel ()
   from /lib/tls/i686/cmov/libpthread.so.0
No symbol table info available.
#2 0xb7f221b6 in gnome_gtk_module_info_get () from /usr/lib/libgnomeui-2.so.0
No symbol table info available.
#3 <signal handler called>
No symbol table info available.
#4 0xb733c375 in memcpy () from /lib/tls/i686/cmov/libc.so.6
No symbol table info available.
#5 0xb74235ca in g_array_append_vals () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#6 0xb7b32c80 in notify_notification_set_icon_from_pixbuf ()
   from /usr/lib/libnotify.so.1
No symbol table info available.
#7 0x080514a0 in ?? ()
No symbol table info available.
#8 0x081a6d50 in ?? ()
No symbol table info available.
#9 0x00000000 in ?? ()
No symbol table info available.
#0 0xffffe410 in __kernel_vsyscall ()

Michael Vogt (mvo) wrote :

Thanks for your bugreport.

Do you have a crashfile for this bug in /var/crash that you can attach to this report? What version of ubuntu do you use?

thanks,
 Michael

Changed in update-notifier:
status: Unconfirmed → Needs Info
Michael Vogt (mvo) wrote :

Sorry, but I'm afraid I have to close the bug as I need a crash file or a backtrace with debug symbols. Please reopen if you experience this problem again and append the crash file.

Thanks,
 Michael

Changed in update-notifier:
status: Needs Info → Rejected
Ezra Morris (ezramorris) on 2011-09-20
Changed in update-notifier (Ubuntu):
status: Invalid → Confirmed
status: Confirmed → New
Ezra Morris (ezramorris) wrote :

I also see this. Every time update-notifier starts (either automatically or manually), it crashes and a Problem Report dialog appears. The process does not actually terminate, but a backtrace as described at https://wiki.ubuntu.com/Backtrace is attached. Ctrl-C was pressed when the Problem Report dialog appeared.

There doesn't seem to be anything relevant in /var/crash:
$ ls -l /var/crash
total 2076
-rw------- 1 ezra ezra 2075397 2011-09-20 10:14 _usr_bin_nautilus.1000.crash
-rw------- 1 root root 25392 2011-09-20 09:46 _usr_share_apport_apport-gtk.0.crash
-rw------- 1 root root 16865 2011-09-20 02:21 _usr_share_software-center_update-software-center.0.crash

If any further information is required, I'll endeavor to get it.

Ezra Morris (ezramorris) wrote :

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu oneiric (development branch)
Release: 11.10
Codename: oneiric
$ apt-cache policy update-notifier
update-notifier:
  Installed: 0.117ubuntu1
  Candidate: 0.117ubuntu1
  Version table:
 *** 0.117ubuntu1 0
        500 http://gb.archive.ubuntu.com/ubuntu/ oneiric/main i386 Packages
        100 /var/lib/dpkg/status

Clint Byrum (clint-fewbar) wrote :

Marking Low priority, since this bug has existed for a long time and only two reporters exist. Also marking Confirmed since two people have experienced it.

Changed in update-notifier (Ubuntu):
status: New → Confirmed
importance: Undecided → Low

I have a crash on update-notifier shortly after login every time on Ubuntu GNOME 17.10 Wayland.
I don't know if this is same problem but I attach my crash file.

corrado@corrado-HP-aGnome:~$ echo $XDG_SESSION_TYPE
wayland
corrado@corrado-HP-aGnome:~$ uname -a
Linux corrado-HP-aGnome 4.10.0-20-generic #22-Ubuntu SMP Thu Apr 20 09:22:42 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
corrado@corrado-HP-aGnome:~$ inxi -Fx
System: Host: corrado-HP-aGnome Kernel: 4.10.0-20-generic x86_64 (64 bit gcc: 6.3.0)
           Desktop: Gnome 3.24.1 (Gtk 3.22.12-1ubuntu1) Distro: Ubuntu Artful Aardvark (development branch)
Machine: Device: laptop System: Hewlett-Packard product: HP 250 G3 Notebook PC v: 0991100000000000000600087
           Mobo: Hewlett-Packard model: 2211 v: 86.49 UEFI: Insyde v: F.36 date: 12/18/2014
Battery BAT1: charge: 10.9 Wh 47.7% condition: 22.8/22.9 Wh (99%) model: 13-42 OA03031 status: Discharging
CPU: Dual core Intel Core i5-4210U (-HT-MCP-) cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 9577
           clock speeds: max: 2700 MHz 1: 823 MHz 2: 831 MHz 3: 1006 MHz 4: 800 MHz
Graphics: Card: Intel Haswell-ULT Integrated Graphics Controller bus-ID: 00:02.0
           Display Server: X.Org 1.19.3 driver: N/A Resolution: 1366x768@59.80hz
           GLX Renderer: Mesa DRI Intel Haswell Mobile GLX Version: 3.0 Mesa 17.0.5 Direct Rendering: Yes
Audio: Card-1 Intel 8 Series HD Audio Controller driver: snd_hda_intel bus-ID: 00:1b.0
           Card-2 Intel Haswell-ULT HD Audio Controller driver: snd_hda_intel bus-ID: 00:03.0
           Sound: Advanced Linux Sound Architecture v: k4.10.0-20-generic
Network: Card-1: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller
           driver: r8169 v: 2.3LK-NAPI port: 3000 bus-ID: 08:00.0
           IF: enp8s0 state: up speed: 100 Mbps duplex: full mac: 5c:b9:01:06:ba:ce
           Card-2: Ralink RT3290 Wireless 802.11n 1T/1R PCIe driver: rt2800pci v: 2.3.0 bus-ID: 09:00.0
           IF: wlo1 state: down mac: 86:bd:7b:64:00:0a
Drives: HDD Total Size: 500.1GB (2.2% used)
           ID-1: /dev/sda model: ST500LT012 size: 500.1GB
Partition: ID-1: / size: 32G used: 6.3G (21%) fs: ext4 dev: /dev/sda7
           ID-2: swap-1 size: 4.29GB used: 0.00GB (0%) fs: swap dev: /dev/sda2
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 42.0C mobo: 42.0C
           Fan Speeds (in rpm): cpu: N/A
Info: Processes: 242 Uptime: 9 min Memory: 1210.8/3881.4MB Init: systemd runlevel: 5 Gcc sys: 6.3.0
           Client: Shell (bash 4.4.51) inxi: 2.3.8
corrado@corrado-HP-aGnome:~$

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers