Ubuntu

backend_helper.py crashed with RuntimeError in add_signal_receiver(): To make asynchronous calls, receive signals or export objects, D-Bus connections must be attached to a main loop by passing mainloop=... to the constructor or calling dbus.set_default_main_loop(...)

Reported by Aubrey on 2012-03-04
240
This bug affects 33 people
Affects Status Importance Assigned to Milestone
update-notifier (Ubuntu)
High
Brian Murray
Precise
High
Michael Terry

Bug Description

[Impact]
This is one of the top-reported bugs on error.ubuntu.com. It seems to occur when you've inserted an Ubuntu CD and started the package manager.

[Test Case]
sudo apt-get remove synaptic
/usr/lib/update-notifier/backend_helper.py add_cdrom test

[Regression Potential]
I think very low. The only affected code path is right before this crashes unconditionally anyway. So even if this screws something up, it can't make it worse. We import a module from python-dbus, but we already were using python-dbus, so dependencies and module use aren't changing.

Aubrey (aubreym) wrote :
tags: removed: need-duplicate-check
Aubrey (aubreym) on 2012-03-04
visibility: private → public
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in update-notifier (Ubuntu):
status: New → Confirmed
Adrián (jaksi) wrote :

Inserting an Ubuntu Live CD and started package manager!

Illu (illu) wrote :

Inserted ubuntu-studio CD and started package manager.

Changed in update-notifier (Ubuntu):
assignee: nobody → Emilio Sanguanini (e-sanguanini)
status: Confirmed → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in update-notifier (Ubuntu):
status: New → Confirmed
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/946718

tags: added: iso-testing
Fabio Marconi (fabiomarconi) wrote :

@Emilio Sanguanini, if you aren't a developer, please remove your name from Assigned tag.
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Changed in update-notifier (Ubuntu):
assignee: Emilio Sanguanini (e-sanguanini) → nobody
importance: Undecided → High
Brian Murray (brian-murray) wrote :

The version of update-notifier that this crash occured with is rather old. Is anybody still receiving this crash?

Changed in update-notifier (Ubuntu):
status: Confirmed → Incomplete
Tommy Fergusson (t-w-fergusson) wrote :

Yes. 1st boot after installing

Ciderax (ciderax) wrote :

Inserting an Ubuntu Live CD and started package manager asked to do a driver update or something

Sebastien Bacher (seb128) wrote :

Hey Michael, that bug is one of the frequent issue we get on errors.ubuntu.com, is there any chance you could have a look to it?

Changed in update-notifier (Ubuntu):
status: Incomplete → Confirmed
Changed in update-notifier (Ubuntu Precise):
importance: Undecided → High
milestone: none → ubuntu-12.04.1
assignee: nobody → Michael Terry (mterry)

*I checked and the Bugs you have listed say something different from what I
see on My computer mines says broken pike unable to write*

On Thu, Jul 5, 2012 at 9:39 AM, Sebastien Bacher <email address hidden> wrote:

> Hey Michael, that bug is one of the frequent issue we get on
> errors.ubuntu.com, is there any chance you could have a look to it?
>
> ** Changed in: update-notifier (Ubuntu)
> Status: Incomplete => Confirmed
>
> ** Also affects: update-notifier (Ubuntu Precise)
> Importance: Undecided
> Status: New
>
> ** Changed in: update-notifier (Ubuntu Precise)
> Importance: Undecided => High
>
> ** Changed in: update-notifier (Ubuntu Precise)
> Milestone: None => ubuntu-12.04.1
>
> ** Changed in: update-notifier (Ubuntu Precise)
> Assignee: (unassigned) => Michael Terry (mterry)
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (938197).
> https://bugs.launchpad.net/bugs/946718
>
> Title:
> backend_helper.py crashed with RuntimeError in add_signal_receiver():
> To make asynchronous calls, receive signals or export objects, D-Bus
> connections must be attached to a main loop by passing mainloop=... to
> the constructor or calling dbus.set_default_main_loop(...)
>
> Status in “update-notifier” package in Ubuntu:
> Confirmed
> Status in “update-notifier” source package in Precise:
> New
>
> Bug description:
> Crashing when attempting to update applications.
>
> ProblemType: Crash
> DistroRelease: Ubuntu 12.04
> Package: update-notifier-common 0.118.1ubuntu1
> ProcVersionSignature: Ubuntu 3.2.0-17.27-generic 3.2.6
> Uname: Linux 3.2.0-17-generic x86_64
> ApportVersion: 1.94-0ubuntu1
> Architecture: amd64
> CasperVersion: 1.305
> Date: Sun Mar 4 23:23:52 2012
> ExecutablePath: /usr/lib/update-notifier/backend_helper.py
> InterpreterPath: /usr/bin/python2.7
> LiveMediaBuild: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64
> (20120304)
> PackageArchitecture: all
> ProcCmdline: /usr/bin/python /usr/lib/update-notifier/backend_helper.py
> add_cdrom /media/Ubuntu\ 11.10\ i386
> ProcEnviron:
> PATH=(custom, no user)
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> PythonArgs: ['/usr/lib/update-notifier/backend_helper.py', 'add_cdrom',
> '/media/Ubuntu 11.10 i386']
> SourcePackage: update-notifier
> Title: backend_helper.py crashed with RuntimeError in
> add_signal_receiver(): To make asynchronous calls, receive signals or
> export objects, D-Bus connections must be attached to a main loop by
> passing mainloop=... to the constructor or calling
> dbus.set_default_main_loop(...)
> UpgradeStatus: No upgrade log present (probably fresh install)
> UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/update-notifier/+bug/946718/+subscriptions
>

Changed in update-notifier (Ubuntu Precise):
status: New → Triaged
Changed in update-notifier (Ubuntu):
status: Confirmed → Triaged
Luigi Tanese (luigitanese) wrote :

Bug found when the session is live - Live Session in Ubuntu DVD i386 - for Precise 12.04.1 - Version: 20120817.1

Changed in update-notifier (Ubuntu Precise):
milestone: ubuntu-12.04.1 → ubuntu-12.04.2

I am no Longer using Kinux I am using windows once again thanks. Grady
Kindred

On Sat, Aug 25, 2012 at 10:04 PM, Stéphane Graber <email address hidden>wrote:

> ** Changed in: update-notifier (Ubuntu Precise)
> Milestone: ubuntu-12.04.1 => ubuntu-12.04.2
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (938197).
> https://bugs.launchpad.net/bugs/946718
>
> Title:
> backend_helper.py crashed with RuntimeError in add_signal_receiver():
> To make asynchronous calls, receive signals or export objects, D-Bus
> connections must be attached to a main loop by passing mainloop=... to
> the constructor or calling dbus.set_default_main_loop(...)
>
> Status in “update-notifier” package in Ubuntu:
> Triaged
> Status in “update-notifier” source package in Precise:
> Triaged
>
> Bug description:
> Crashing when attempting to update applications.
>
> ProblemType: Crash
> DistroRelease: Ubuntu 12.04
> Package: update-notifier-common 0.118.1ubuntu1
> ProcVersionSignature: Ubuntu 3.2.0-17.27-generic 3.2.6
> Uname: Linux 3.2.0-17-generic x86_64
> ApportVersion: 1.94-0ubuntu1
> Architecture: amd64
> CasperVersion: 1.305
> Date: Sun Mar 4 23:23:52 2012
> ExecutablePath: /usr/lib/update-notifier/backend_helper.py
> InterpreterPath: /usr/bin/python2.7
> LiveMediaBuild: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64
> (20120304)
> PackageArchitecture: all
> ProcCmdline: /usr/bin/python /usr/lib/update-notifier/backend_helper.py
> add_cdrom /media/Ubuntu\ 11.10\ i386
> ProcEnviron:
> PATH=(custom, no user)
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> PythonArgs: ['/usr/lib/update-notifier/backend_helper.py', 'add_cdrom',
> '/media/Ubuntu 11.10 i386']
> SourcePackage: update-notifier
> Title: backend_helper.py crashed with RuntimeError in
> add_signal_receiver(): To make asynchronous calls, receive signals or
> export objects, D-Bus connections must be attached to a main loop by
> passing mainloop=... to the constructor or calling
> dbus.set_default_main_loop(...)
> UpgradeStatus: No upgrade log present (probably fresh install)
> UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/update-notifier/+bug/946718/+subscriptions
>

Michael Terry (mterry) on 2012-09-06
Changed in update-notifier (Ubuntu):
assignee: nobody → Michael Terry (mterry)
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-notifier - 0.122

---------------
update-notifier (0.122) quantal; urgency=low

  * Tell python-dbus to use glib's mainloop so it doesn't throw an exception
    (LP: #946718).
 -- Michael Terry <email address hidden> Fri, 07 Sep 2012 09:11:53 -0400

Changed in update-notifier (Ubuntu):
status: In Progress → Fix Released
Michael Terry (mterry) wrote :

I've uploaded a fix to precise-proposed and adjusted the description for SRU requirements.

description: updated
Changed in update-notifier (Ubuntu Precise):
status: Triaged → In Progress

Hello Aubrey, or anyone else affected,

Accepted update-notifier into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/update-notifier/0.119ubuntu8.6 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in update-notifier (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Brian Murray (brian-murray) wrote :

I tested update-notifier version 0.119ubunt8.5 and received a crash report when following the test case. When I used update-notifier from precise-proposed, version 0.119ubuntu8.6, I did not receive a crash report and software center launched.

tags: added: patch-refused
tags: added: verification-done
removed: patch-refused verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-notifier - 0.119ubuntu8.6

---------------
update-notifier (0.119ubuntu8.6) precise-proposed; urgency=low

  * Tell python-dbus to use glib's mainloop so it doesn't throw an exception
    (LP: #946718).
 -- Michael Terry <email address hidden> Fri, 07 Sep 2012 09:34:15 -0400

Changed in update-notifier (Ubuntu Precise):
status: Fix Committed → Fix Released
Changed in update-notifier (Ubuntu):
assignee: Michael Terry (mterry) → martin dejesus jr (mdjesus918)
Changed in update-notifier (Ubuntu):
assignee: martin dejesus jr (mdjesus918) → jayantha silva (samadhiizumee)
Changed in update-notifier (Ubuntu):
assignee: jayantha silva (samadhiizumee) → Brian Murray (brian-murray)
To post a comment you must log in.