Add Recommends on aptdaemon

Bug #600745 reported by Michael Terry
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
update-notifier (Ubuntu)
Fix Released
Low
Unassigned

Bug Description

Binary package hint: update-notifier

Update notifier takes advantage of aptdaemon (e.g. aptdaemon_pending_transactions()) but does not directly pull it in itself. In Lucid, I only have aptdaemon from software-center (and indirectly from rhythmbox-ubuntuone-music-store).

I would imagine using Recommends over Depends just because update-notifier is functional without it.

Tags: oem-services

Related branches

Revision history for this message
David Sugar (dyfet-deactivatedaccount) wrote :

In Maverick, I get from rdepends:

aptdaemon
Reverse Depends:
  sessioninstaller
  software-center
  python-aptdaemon
  language-selector

And lucid is
Reverse Depends:
  software-center
  software-center
  python-aptdaemon

Hence, even in Maverick do you get aptdaemon from update-notifier by itself, though you do get it as a result of a default install (via software-center). It also appears update-notifier[-common] can certainly get installed on Ubuntu "server" images by default, but in that case nothing that leads to aptdaemon would be present since software-center is of course not installed, but this circumstances would be desirable there. Since aptdaemon is about user access to package management, and one may not want that functionality if they really have chosen to remove software-center but keep update-notifier alone, I am not sure it should be a recommends, but I do think it could at minimum can clearly be a suggests.

Revision history for this message
Charlie Kravetz (charlie-tca) wrote :

Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here. Thanks for taking the time to make Ubuntu better!

Changed in update-notifier (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Michael Vogt (mvo)
Changed in update-notifier (Ubuntu):
status: Triaged → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-notifier - 0.110.1ubuntu1

---------------
update-notifier (0.110.1ubuntu1) natty; urgency=low

  [ Michael Vogt ]
  * data/update-motd-fsck-at-reboot:
    - fix small issues in the script that I introduced in the
      merge
  * add recommends to aptdaemon (thanks to Michael Terry)
    LP: #600745

  [ Kees Cook ]
  * data/update-motd-cpu-checker, data/Makefile.am, debain/control,
    debian/20-cpu-checker, debian/update-notifier-common.{install,postinst}:
    drop cpu-checker since kernel will unmask BIOS filtering of NX now.
 -- Kees Cook <email address hidden> Wed, 17 Nov 2010 11:35:00 -0800

Changed in update-notifier (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.