[LUCID] update-notifier no longer shows update icon even with auto_launch=false

Bug #549799 reported by Noel J. Bergman on 2010-03-27
52
This bug affects 8 people
Affects Status Importance Assigned to Milestone
update-notifier (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: update-notifier

As of recent updates, update-notifier no longer shows the icon even after executing:

  gconftool -s --type bool /apps/update-notifier/auto_launch false

It was bad enough when the highly controversial and widely criticized (Bug 332945) change was made to remove the notification icon by default, but now it is not showing up at all, even when the user explicitly wants it.

ProblemType: Bug
Architecture: amd64
Date: Sat Mar 27 15:26:32 2010
DistroRelease: Ubuntu 10.04
InstallationMedia: Error: [Errno 13] Permission denied: '/var/log/installer/media-info'
NonfreeKernelModules: nvidia
Package: update-notifier 0.99
ProcEnviron:
 LANG=C
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-17.26-generic 2.6.32.10+drm33.1
SourcePackage: update-notifier
Uname: Linux 2.6.32-17-generic x86_64

Noel J. Bergman (noeljb) wrote :
Fabián Rodríguez (magicfab) wrote :

Noel, can you elaborate on this ? If auto_launch is false, it seems OK it would display, no ?

Thank you.

Changed in update-notifier (Ubuntu):
status: New → Incomplete
Martin Erik Werner (arand) wrote :

Expected behaviour when key auto_launch is false is that the notification icon is shown.
In current lucid it doesn't, however it does show up with the "a package manager is working status" in relevant cases.
Confirmed

Changed in update-notifier (Ubuntu):
status: Incomplete → Confirmed
Martin Erik Werner (arand) wrote :

It seems to work as it should in the beta, but not in current.

I can confirm this bug in Beta1 with all updates applied.
Ubuntu 10.04 beta1 AMD64
When, for example, "apt-get update" is running the icon appears in the pannel (grayed out). But when the command finish the icon dissapears, even if there is updates to apply; and never appears automatically.

I have the gconf entry /apps/update-notifier/auto_launch as false

update-notifier:
  Installed: 0.99
  Candidate: 0.99
  Version table:
 *** 0.99 0
        500 http://us.archive.ubuntu.com/ubuntu/ lucid/main Packages
        100 /var/lib/dpkg/status
     0.98 0
        500 cdrom://Ubuntu 10.04 _Lucid Lynx_ - Beta amd64 (20100317.1)/ lucid/main Packages

Noel J. Bergman (noeljb) wrote :

The correct behavior came back yesterday afternoon after a number of updates, but I'm not spotting which one fixed it for me. What does everyone else see?

Bart Rose (jbrose3) wrote :

Fixed for me too.

Noel J. Bergman (noeljb) wrote :

How do we mark this as Fix Released, if we don't know which package fixed it?

Martin Erik Werner (arand) wrote :

Since we don't know what fixed it, policy is to set it as invalid.

If you still see this bug, feel free to re-open.

Changed in update-notifier (Ubuntu):
status: Confirmed → Invalid
Felix Dreissig (f30) on 2010-03-31
Changed in update-notifier (Ubuntu):
status: Invalid → Fix Released
status: Fix Released → Invalid
ingo (ingo-steiner) wrote :

as of now I never received any notification from update-manager.

Lucid-amd64, even with auto_launch false=false nothing. I am sure there are security-updates pending which are not yet installed

Changed in update-notifier (Ubuntu):
status: Invalid → Confirmed
ski (skibrianski) wrote :

I have the same problem as Ingo. My machine was running 8.04LTS, and I did a dist-upgrade to 10.04 in the past month.

ski (skibrianski) wrote :

One difference from Ingo - I'm on x86. Same problem otherwise. Setting autolaunch to be false doesn't change a thing, and I haven't seen either a pop up or an icon in more than a week.

ski (skibrianski) wrote :

The strange bit is I have other machines that I upgraded directly from 9.10 (not 8.04) that don't have the problem. I can't tell if it's all of those machines or not though, or if that's related at all.

Maarten Bezemer (veger) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. We are sorry that we do not always have the capacity to look at all reported bugs in a timely manner. There have been many changes in Ubuntu since that time you reported the bug and your problem may have been fixed with some of the updates. It would help us a lot if you could test it on a currently supported Ubuntu version. When you test it and it is still an issue, kindly upload the updated logs by running apport-collect 549799 and any other logs that are relevant for this particular issue.

Changed in update-notifier (Ubuntu):
status: Confirmed → Incomplete
Felix Dreissig (f30) wrote :

With the introduction of Unity in 11.04, the behaviour of update notification has again changed fundamentally: The notification area icon was entirely dismissed and the Update Manager now shows up in the Unity launcher on new updates (with its window in the background).
I'm not sure about other desktop environments like GNOME 3 or Xfce, but for the "official" Ubuntu desktop this bug no longer seems to be an issue.

Launchpad Janitor (janitor) wrote :

[Expired for update-notifier (Ubuntu) because there has been no activity for 60 days.]

Changed in update-notifier (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers