apt_check.py crashed with SIGSEGV in pkgCacheGenerator::MergeList()

Bug #510788 reported by Tim Bond on 2010-01-21
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
update-notifier (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: update-notifier

$ apt-cache policy update-notifier
update-notifier:
  Installed: 0.92
  Candidate: 0.92
  Version table:
 *** 0.92 0
        500 http://gb.archive.ubuntu.com lucid/main Packages
        100 /var/lib/dpkg/status

Crashed whilst wajig dist-upgrade was running; unsure whether it spawned from this or ran independantly but I'd suspect the latter.

ProblemType: Crash
Architecture: i386
Date: Thu Jan 21 17:51:10 2010
DistroRelease: Ubuntu 10.04
ExecutablePath: /usr/lib/update-notifier/apt_check.py
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20100113)
InterpreterPath: /usr/bin/python2.6
Package: update-notifier-common 0.92
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/lib/update-notifier/apt-check
ProcEnviron:
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-11.15-generic
SegvAnalysis:
 Segfault happened at: 0x24feb3 <_ZN17pkgCacheGenerator9MergeListERNS_10ListParserEPN8pkgCache11VerIteratorE+1379>: mov (%edx),%edx
 PC (0x0024feb3) ok
 source "(%edx)" (0xb7b59e48) not located in a known VMA region (needed readable region)!
 destination "%edx" ok
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: update-notifier
StacktraceTop:
 pkgCacheGenerator::MergeList(pkgCacheGenerator::ListParser&, pkgCache::VerIterator*) () from /usr/lib/libapt-pkg-libc6.10-6.so.4.8
 debStatusIndex::Merge(pkgCacheGenerator&, OpProgress&) const
 ?? () from /usr/lib/libapt-pkg-libc6.10-6.so.4.8
 pkgMakeStatusCache(pkgSourceList&, OpProgress&, MMap**, bool) () from /usr/lib/libapt-pkg-libc6.10-6.so.4.8
 pkgCacheFile::BuildCaches(OpProgress&, bool) ()
Tags: lucid
Title: apt_check.py crashed with SIGSEGV in pkgCacheGenerator::MergeList()
Uname: Linux 2.6.32-11-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Thank you for taking the time to report this crash and helping to make Ubuntu better. This particular crash has already been reported and is a duplicate of bug #340479, so is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Please continue to report any other bugs you may find.

visibility: private → public
tags: removed: need-i386-retrace
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers