update notifier icon does not show up after upgrade from breezy

Bug #47533 reported by kenc on 2006-05-30
12
Affects Status Importance Assigned to Milestone
update-notifier (Ubuntu)
Medium
Unassigned

Bug Description

I just simply followed the instructions to upgrade to dapper. I never actually see the update notifier icon (even though it actually exists in my session, and IS running in the background).

I have another machine at work which is just a straight up Dapper install from the liveCD which HAS this icon whenever there's an update.

Both machine has the exact same Software Properties (auto download, and auto check daily).

Taliesin (matthewk) wrote :

https://launchpad.net/distros/ubuntu/+source/update-notifier/+bug/29295

Following the instructions from this bug report to do a change to some permisions has fixed this issue for me, I had the same issue when upgrading from breezy -> dapper.

Some developers seem fit to think I have made a permission change originally myself, when I know I havent :)

pop (stephane-popinet) wrote :

Hi,

Just to confirm I have exactly the same problem after an upgrade from breezy to dapper. Newly created users (after the upgrade) do not have this problem.

Also the permissions of my sources.list are correct i.e.:

% ls -l -h /etc/apt/sources.list
-rw-r--r-- 1 root root 1.9K 2006-06-04 18:00 /etc/apt/sources.list

So the "fix" above does not work for me...

cheers

Stephane

Michael Vogt (mvo) wrote :

Thanks for your bugreport.

Could you please tell me what the output of:
$ /usr/lib/update-notifier/apt-check
is?

Thanks,
 Michael

Changed in update-notifier:
status: Unconfirmed → Needs Info

Michael Vogt wrote:
> Thanks for your bugreport.
>
> Could you please tell me what the output of:
> $ /usr/lib/update-notifier/apt-check
> is?

Hi Michael,

Here is what I get:

steph@pukeko:~$ /usr/lib/update-notifier/apt-check
Reading package lists... Done
Building dependency tree... Done
0steph@pukeko:~$

which I imagine means that everything is ok. Which is not surprising
given that apt-get, synaptic etc... work fine on my system.

Since posting the bug report, I have fixed the problem using the "brute
force" technique of deleting my account, recreating it and copying my
files (but not the gnome and other desktop config files etc...) Needless
to say I wouldn't like to have to do this after each distribution upgrade...

My guess is that for some reason, the config for the gnome notification
area (wherever that is) got changed somehow and by default then never
allowed notifications from the update-notifier to appear. Does this make
sense?

cheers

Stephane

Topper (t-harley) wrote :

I have the same problem after upgrade from dapper beta to dapper release : The update notifier doesn't show up anymore. The update notifier daemon is running and I can still hear the hard disk activity that usually precedes the update-notifier pop-up, but it doen't show.
If I manually launch the update manager and check for updates, there are usually some updates available that I was not notified of.

PS : My permissions for sources.list are 644 root root

Michael Vogt (mvo) wrote :

Thanks for this additonal information about this bug.

If you still have this problem, could you please check if your panel still has a notification-area? What does:
$ gconftool -R /apps/update-notifier
output?

Thanks,
 Michael

Hi Michael,

> If you still have this problem, could you please check if your panel still has a notification-area? What does:
> $ gconftool -R /apps/update-notifier
> output?

I have upgraded my system to Feisty and don't have this problem anymore.

cheers

Stephane

Michael Vogt (mvo) wrote :

Is there anyone who can still reproduce it? If so, please reopen. I would like to close it on the grounds that I have not recived reports about this for feisty (or gutsy) anymore.

Changed in update-notifier:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions