Icon double-clicks and slow launches should be bufferred

Bug #43774 reported by Mike Owens on 2006-05-09
8
Affects Status Importance Assigned to Milestone
update-notifier (Ubuntu)
Wishlist
Michael Vogt

Bug Description

This is similar to, but not the same as #28455

Because there can be a significant (1-3s) delay in launching the package manager after clicking the update-notifier icon, the icon should ignore subsequent clicks for a short period after launching. In this limbo period, users may click the icon again, mistakenly thinking it was mis-clicked. Other users accidentally or habitually double-click icons. Both of these situations result in a second update-manager instance with a big error message.

The soon-to-be-attached patch will refuse to execute update-manager more than once every 3 seconds. This doesn't solve the underlying issue of update-notifier being pretty much unaware of update-manager. In the future, we can mark the icon as "working" on first launch, or locate and activate an existing update-manager instance.

However, this patch is hopefully small and safe enough to improve the user experience in dapper.

I'm not familiar with the proper procedure to patch a package, but this is a diff -U against what I got with an 'apt-get source update-notifier'

Simon Law (sfllaw) wrote :

From a usability point-of-view, this is sort of a kludge.

One should make it super-fast to show that update-notifier is being
started. As well, it only makes sense to have one instance of
update-notifier running.

Changed in update-notifier:
status: Unconfirmed → Confirmed
Mike Owens (sphivo) wrote :

The proper solution (which I described in the original report, and you described right back at me) requires much more invasive changes to update-manager. I'm actually interested in working on this, but now I'm merely hoping to see less troubles like "I clicked the icon, but it said it's already running" in time for dapper, which is fast approaching.

I apologize if I did not make it clear that this was intended as a small and easily-tested workaround until update-notifier and update-manager become properly integrated, presumably sometime between dapper and edgy. Perhaps this report should've been categorized in launchpad more appropriately as release-specific.

Michael Vogt (mvo) wrote :

Thanks for the bugreport and the patch.

I applied it and hope we can come up with something better for dapper+1.

Cheers,
 Michael

Changed in update-notifier:
assignee: nobody → mvo
status: Confirmed → Fix Committed
Michael Vogt (mvo) on 2006-10-02
Changed in update-notifier:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers