update manager reports wrong number of updates in notification area (intrepid and hardy-proposed)

Bug #251494 reported by Carl Simpson on 2008-07-24
8
Affects Status Importance Assigned to Milestone
update-notifier (Ubuntu)
Undecided
Michael Vogt
Hardy
Medium
Michael Vogt

Bug Description

Binary package hint: update-manager

Using Ubuntu 8.04.1 and update-manager 1:0.87.29, the update manager displays a different number of updates in its title text ("You can install ## updates") than the text from hovering over the notification area icon.

When counted, the "You can install ## updates" title is correct, and the notification icon is wrong.

This is utter speculation, but since there are "10" updates available in this case, and the notification icon claims "1 update available", maybe it is dropping that "0", or just taking the first number.

TEST CASE:
 * use the verification instructions for #239673 (they were updated to include a test for this regression as well)- this upload fixes a regression in that change

Michael Vogt (mvo) wrote :

Thanks for your bugreport.

Could you please run:
/usr/lib/update-notifier/apt-check
and
/usr/lib/update-notifier/apt-check -p

in a terminal and attach the output to this bugreport?

Changed in update-manager:
assignee: nobody → mvo
status: New → Incomplete
Michael Vogt (mvo) wrote :

Do you run hardy-proposed?

Michael Vogt (mvo) wrote :

Could you please try the following patch:

=== modified file 'data/apt-check'
--- data/apt-check 2008-06-30 15:43:20 +0000
+++ data/apt-check 2008-07-28 12:27:26 +0000
@@ -109,7 +109,6 @@
             upgrades = upgrades + 1
             if isSecurityUpgrade(cand_ver):
                 security_updates += 1
- break
             # now check for security updates that are masked by a
             # canidate version from another repo (-proposed or -updates)
             for ver in pkg.VersionList:

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-notifier - 0.71.1

---------------
update-notifier (0.71.1) intrepid; urgency=low

  * src/update.c:
    - make the "repository-outdated" nag message more clear
      and mention that unavailable repositores may cause the
      problem (LP: #243876)
  * data/apt-check:
    - fix incorrect display of number of updates (LP: #251494)

 -- Michael Vogt <email address hidden> Mon, 28 Jul 2008 14:32:47 +0200

Changed in update-notifier:
status: Incomplete → Fix Released
Michael Vogt (mvo) wrote :

Uploaded to hardy-proposed, this bug is a regression caused by the fix for bug #239673

Changed in update-notifier:
assignee: nobody → mvo
importance: Undecided → Medium
status: New → In Progress
Michael Vogt (mvo) on 2008-07-28
description: updated
description: updated
Martin Pitt (pitti) wrote :

Accepted into -proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in update-notifier:
status: In Progress → Fix Committed

I am already running proposed, and have just obtained the update- thank you for the direction nonetheless. However, this bug was patched very quickly; I did not at any point receive conformation regarding what exactly the bug is. When would I expect to see the bug? If I know this, I will be able to confirm whether or not the bug is gone.

Thank you both for addressing this issue quickly.

Michael Vogt (mvo) wrote :

@Carl: Thanks for your reply. If you compare the tooltip message (N updates available) in the notification area and that matches the number of updates in the header in update-manager (when you run the update application) then the bug is fixed :)

Matt Neilson (ichthyoboy) wrote :

Confirmed as fixed.

Uphaar Agrawalla (uphaar) wrote :

Here's the second confirmation that the bug is fixed.

Martin Pitt (pitti) wrote :

Copied to hardy-updates.

Changed in update-notifier:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers