'Livepatch-Notif' is always a zombie process after a system restart

Bug #1809505 reported by chris pollock on 2018-12-21
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
update-notifier (Ubuntu)
Medium
Andrea Azzarone

Bug Description

* Impact
update-notifier let livepatch-notification zombie processes

* Test case
wait for a livepatch update/notification, after the notification is dismissed there should be no zombie process

* Regression potential
Check that the livepatch notifications are correctly displayed still

---------------------------------

This is Ubuntu 18.04.1 with update-notifier version
apt-cache policy update-notifier
update-notifier:
  Installed: 3.192.1.4
  Candidate: 3.192.1.4

As shown here - https://imageshack.com/i/pl753Ekfp AFAICT I don't have
livepatch enabled. Running:

chris@localhost:/var/log$ ps axo stat,ppid,pid,comm | grep -w defunct
Z+ 3283 3290 livepatch-notif <defunct>

3283 chris 20 0 585404 23776 17608 S 0.0 0.2 0:00.09
update-
notifier

3290 chris 20 0 0 0 0 Z 0.0 0.0 0:00.00
livepatch-notif

It's no big deal to remove the zombie by killing update-notifier
however I don't know if that's the right thing to do or not and why is
livepatch-notif always a zombie process after a restart?

Related branches

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1809505/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
chris pollock (cpollock) wrote :

Forgot to add source package when converting from question to bug.

affects: ubuntu → update-notifier (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in update-notifier (Ubuntu):
status: New → Confirmed
Steve Langasek (vorlon) on 2018-12-24
Changed in update-notifier (Ubuntu):
assignee: nobody → Andrea Azzarone (azzar1)
chris pollock (cpollock) wrote :

Question, since I have to kill the update-notifier process to get rid of the Zombie Livepatch-Notif process does this mean that updates are not being automatically checked for and that I need to run 'apt update' manually periodically?

Andrea Azzarone (azzar1) on 2019-01-07
Changed in update-notifier (Ubuntu):
status: Confirmed → In Progress
Andrea Azzarone (azzar1) on 2019-01-07
Changed in update-notifier (Ubuntu):
importance: Undecided → Medium
Sebastien Bacher (seb128) wrote :

> does this mean that updates are not being automatically checked for and that I need to run 'apt update' manually periodically?

No, it doesn't impact the work update-notifier is doing

Changed in update-notifier (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-notifier - 3.192.11

---------------
update-notifier (3.192.11) disco; urgency=medium

  * src/update-notifier.c: Don't use G_SPAWN_DO_NOT_REAP_CHILD in order
    to avoid zombie processes. (LP: #1809505)

 -- Andrea Azzarone <email address hidden> Mon, 07 Jan 2019 12:49:07 +0000

Changed in update-notifier (Ubuntu):
status: Fix Committed → Fix Released
Sebastien Bacher (seb128) wrote :

I've uploaded a SRU to bionic for the fix, cosmic doesn't have livepatch so the SRU is not useful there

description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers