17.10 to 18.04 upgrade: 'upgrade now' has no effect

Bug #1768748 reported by Jean-Baptiste Lallement on 2018-05-03
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
update-notifier (Ubuntu)
Critical
Brian Murray
Artful
Critical
Brian Murray
Bionic
Critical
Brian Murray

Bug Description

Test Case:
1. Install 17.10 and all the updates available
2. Reboot
3. Wait until the upgrade notification to 18.04 shows up
4. Press on 'Upgrade now'

To force the upgrade dialog to appear a second time you will need to use dconf-editor to reset com.ubuntu.update-notifier.release-check-time to 0 and then reboot.

Expected behaviour
The upgrade process starts

Actual result
The update notifier dialog is closed and nothing happens. This is reproducible with the the Wayland and X sessions.

It works fine if update-notifier is executed manually with:
$ update-notifier --force-release-check

The following messages are logged in the journal:
mai 03 09:04:23 ubuntu gnome-software[1600]: running get-distro-updates with refine-flags=require-setup-action with timeout=60 on plugin=appstream took 26ms
mai 03 09:04:26 ubuntu PackageKit[1073]: get-updates transaction /3_acacceea from uid 1000 finished with success after 2634ms
mai 03 09:04:26 ubuntu gnome-software[1600]: running refresh with timeout=60 with cache age=86400 on plugin=steam took 2743ms
mai 03 09:04:26 ubuntu gnome-software[1600]: running get-updates with refine-flags=require-update-details,require-update-severity with timeout=60 on plugin=systemd-updates took 1ms
mai 03 09:04:26 ubuntu update-notifier.desktop[1799]: localuser:root being added to access control list
mai 03 09:04:26 ubuntu update-notifier.desktop[1799]: Refusing to render service to dead parents.

ProblemType: BugDistroRelease: Ubuntu 17.10
Package: update-notifier 3.186.1
ProcVersionSignature: Ubuntu 4.13.0-39.44-generic 4.13.16
Uname: Linux 4.13.0-39-generic x86_64
ApportVersion: 2.20.7-0ubuntu3.8
Architecture: amd64
Date: Thu May 3 09:06:03 2018
EcryptfsInUse: Yes
InstallationDate: Installed on 2018-05-02 (0 days ago)
InstallationMedia: Ubuntu 17.10 "Artful Aardvark" - Release amd64 (20180105.1)SourcePackage: update-notifier
UpgradeStatus: No upgrade log present (probably fresh install)

Jean-Baptiste Lallement (jibel) wrote :
description: updated
description: updated
Steve Langasek (vorlon) on 2018-05-03
Changed in update-notifier (Ubuntu):
importance: Undecided → Critical
description: updated
tags: added: id-5aeabab0a9ce139522922cea
dino99 (9d9) wrote :

Met that problem twice too on different laptops

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in update-notifier (Ubuntu):
status: New → Confirmed
Brian Murray (brian-murray) wrote :

update-notifier just ends calling "/usr/lib/ubuntu-release-upgrader/check-new-release-gtk" and that is where the "upgrade now" dialog comes from so its weird to me that it works with "--force-release-check".

Changed in update-notifier (Ubuntu):
assignee: nobody → Brian Murray (brian-murray)
Changed in update-notifier (Ubuntu Bionic):
assignee: nobody → Brian Murray (brian-murray)
Changed in update-notifier (Ubuntu Artful):
assignee: nobody → Brian Murray (brian-murray)
Changed in update-notifier (Ubuntu Bionic):
status: New → In Progress
Changed in update-notifier (Ubuntu Artful):
status: New → In Progress
importance: Undecided → Critical
Changed in update-notifier (Ubuntu Bionic):
importance: Undecided → Critical

Hello Jean-Baptiste, or anyone else affected,

Accepted update-notifier into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/update-notifier/3.192.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in update-notifier (Ubuntu Bionic):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-bionic
Łukasz Zemczak (sil2100) wrote :

Hello Jean-Baptiste, or anyone else affected,

Accepted update-notifier into artful-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/update-notifier/3.186.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-artful to verification-done-artful. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-artful. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in update-notifier (Ubuntu Artful):
status: In Progress → Fix Committed
tags: added: verification-needed-artful
Brian Murray (brian-murray) wrote :

I installed update-notifier version 3.186.2 from artful-proposed and verified that after clicking "Upgrade Now" I was prompted to enter my password, then I saw the Release Notes for Ubuntu 18.04 and after clicking that upgrade button the upgrade did proceed.

description: updated
tags: added: verification-done-artful
removed: verification-needed-artful
Brian Murray (brian-murray) wrote :

I was able to verify this in bionic with update-notifier version 3.192.1 from -proposed by modifying /etc/update-manager/meta-release to point at server with cosmic in a meta-release-development file and modifying check-new-release-gtk to have devel-release as a default of true. This all was necessary because cosmic doesn't have an animal yet so the meta-release file has not been updated and a new ubuntu-release-upgrader has not been uploaded to cosmic.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-notifier - 3.192.1

---------------
update-notifier (3.192.1) bionic; urgency=medium

  * Use a wrapper script of /bin/sh when calling check-new-release-gtk to
    workaround its requirement that the ppid not be 1. (LP: #1768748)

 -- Brian Murray <email address hidden> Fri, 04 May 2018 15:42:00 -0700

Changed in update-notifier (Ubuntu Bionic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-notifier - 3.186.2

---------------
update-notifier (3.186.2) artful; urgency=medium

  * Use a wrapper script of /bin/sh when calling check-new-release-gtk to
    workaround its requirement that the ppid not be 1. (LP: #1768748)

 -- Brian Murray <email address hidden> Fri, 04 May 2018 16:51:28 -0700

Changed in update-notifier (Ubuntu Artful):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for update-notifier has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-notifier - 3.192.1

---------------
update-notifier (3.192.1) bionic; urgency=medium

  * Use a wrapper script of /bin/sh when calling check-new-release-gtk to
    workaround its requirement that the ppid not be 1. (LP: #1768748)

 -- Brian Murray <email address hidden> Fri, 04 May 2018 15:42:00 -0700

Changed in update-notifier (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers