Livepatch motd enhancement to show people how livepatch can help protect systems.

Bug #1710976 reported by David Britton on 2017-08-15
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
ubuntu-advantage-tools (Ubuntu)
Wishlist
Andreas Hasenack
update-notifier (Ubuntu)
Undecided
Unassigned

Bug Description

This is a request to add an enhancement in our motd.d to inform users of the following:

1) that livepatch is available for their platform/kernel if they don't have it set up and installed right now.

2) When a system is protected by livepatch, and the system is currently patched (i.e., canonical-livepatch has active patches applied).

3) when a system is protected by livepatch and no livepatches exist yet for the kernel version, a single line message of 'This system is protected by canonical-livepatch." or similar.

summary: - Livepatch motd enahancement to show people how livepatch can help
- protect systems.
+ Livepatch motd enhancement to show people how livepatch can help protect
+ systems.
Changed in linux (Ubuntu):
assignee: nobody → Steve Langasek (vorlon)

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1710976

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Steve Langasek (vorlon) on 2017-08-15
Changed in linux (Ubuntu):
status: Incomplete → Triaged
Changed in update-notifier (Ubuntu):
assignee: Steve Langasek (vorlon) → Andreas Hasenack (ahasenack)
Changed in linux (Ubuntu):
assignee: Steve Langasek (vorlon) → Andreas Hasenack (ahasenack)
Steve Langasek (vorlon) wrote :

I believe no code changes are needed to the linux package.

Changed in linux (Ubuntu):
status: Triaged → Invalid
Changed in update-notifier (Ubuntu):
status: New → Triaged
Changed in update-notifier (Ubuntu):
status: Triaged → In Progress
Changed in linux (Ubuntu):
assignee: Andreas Hasenack (ahasenack) → nobody
David Britton (davidpbritton) wrote :

moved to ubuntu-advantage-tools where the work was decided to be done.

Changed in ubuntu-advantage-tools (Ubuntu):
assignee: nobody → Andreas Hasenack (ahasenack)
status: New → In Progress
Changed in update-notifier (Ubuntu):
status: In Progress → Invalid
Changed in ubuntu-advantage-tools (Ubuntu):
importance: Undecided → Medium
importance: Medium → Wishlist
Changed in update-notifier (Ubuntu):
importance: Medium → Undecided
assignee: Andreas Hasenack (ahasenack) → nobody
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-advantage-tools - 14

---------------
ubuntu-advantage-tools (14) bionic; urgency=medium

  * New upstream release:
    - repositories are only added after credentials are verified
      (LP: #1730361)
    - Livepatch MOTD script (LP: #1710976)
    - better "status" command output formatting (LP: #1719034)
    - sources.list.d files no longer contain credentials. The "auth.conf"
      facility is used instead. (LP: #1700611)
    - enabled Livepatch support for Bionic 18.04 LTS

 -- Andreas Hasenack <email address hidden> Tue, 06 Feb 2018 09:58:03 -0200

Changed in ubuntu-advantage-tools (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers