update-notifier segfaults under wayland (trying to use xorg clipboard to see if it's already started)

Bug #1697381 reported by Marko Stanković on 2017-06-12
44
This bug affects 8 people
Affects Status Importance Assigned to Milestone
update-notifier (Ubuntu)
High
Unassigned
Artful
High
Unassigned

Bug Description

I've just logged in the Unity session and was greeted by the "application crashed" message. Aptitude was open in byobu.

ProblemType: Crash
DistroRelease: Ubuntu 17.10
Package: update-notifier 3.179
ProcVersionSignature: Ubuntu 4.10.0-22.24-generic 4.10.15
Uname: Linux 4.10.0-22-generic x86_64
ApportVersion: 2.20.5-0ubuntu4
Architecture: amd64
CurrentDesktop: GNOME
Date: Wed Jun 7 00:48:51 2017
Disassembly: => 0x0: Cannot access memory at address 0x0
ExecutablePath: /usr/bin/update-notifier
ExecutableTimestamp: 1489528707
InstallationDate: Installed on 2015-05-21 (753 days ago)
InstallationMedia: Ubuntu 15.10 "Wily Werewolf" - Alpha amd64 (20150517)
ProcCmdline: update-notifier
ProcCwd: /home/sm4rk0
SegvAnalysis:
 Segfault happened at: 0x0: Cannot access memory at address 0x0
 PC (0x00000000) not located in a known VMA region (needed executable region)!
SegvReason: executing NULL VMA
Signal: 11
SourcePackage: update-notifier
StacktraceTop:
 ()
 g_hash_table_lookup () at /lib/x86_64-linux-gnu/libglib-2.0.so.0
 () at /usr/lib/x86_64-linux-gnu/libgdk-3.so.0
 ()
 __libc_csu_init ()
Title: update-notifier crashed with SIGSEGV
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip disk docker fuse lpadmin lxd plugdev pulse pulse-access pulse-rt sambashare sudo vboxusers

Related branches

Marko Stanković (sm4rk0) wrote :

StacktraceTop:
 ?? ()
 g_hash_table_lookup_node (hash_return=<synthetic pointer>, key=0x47, hash_table=0x5570a4e017c0) at ../../../../glib/ghash.c:375
 g_hash_table_lookup (hash_table=0x5570a4e017c0, key=0x47) at ../../../../glib/ghash.c:1149
 _gdk_x11_xwindow_get_shape (xdisplay=<optimized out>, window=<optimized out>, scale=-1528831936, shape_type=<optimized out>) at ././gdk/x11/gdkwindow-x11.c:4602
 ?? ()

Changed in update-notifier (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
information type: Private → Public
summary: - update-notifier crashed with SIGSEGV
+ update-notifier crashed with SIGSEGV in g_hash_table_lookup_node

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in update-notifier (Ubuntu):
status: New → Confirmed
Changed in update-notifier (Ubuntu):
importance: Medium → High
tags: added: wayland
tags: removed: wayland-session
Casey (casey-jao) wrote :

The crash seems to be caused by the X-specific up_get_clipboard() function used to check if update-notifier is already running. What if one were to replace that by a different hack, such as the one attached?

The attachment "Proposed hack" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
summary: - update-notifier crashed with SIGSEGV in g_hash_table_lookup_node
+ update-notifier segfaults under wayland (trying to use xorg clipboard to
+ see if it's already started)
tags: added: rls-aa-incoming
tags: removed: rls-aa-incoming
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-notifier - 3.186

---------------
update-notifier (3.186) artful; urgency=medium

  * src/crash.c: don't prompt about system reports under wayland, pkexec
    doesn't work there
  * src/clipboard.c, src/update-notifier.c, src/Makefile.am:
    - don't use the xorg clipboard to do single instance, that doesn't work
      under wayland, replace it with a file lock (lp: #1697381)

 -- Sebastien Bacher <email address hidden> Thu, 07 Sep 2017 00:30:10 +0200

Changed in update-notifier (Ubuntu Artful):
status: Confirmed → Fix Released
Thomas (thomasmanchadi-k) wrote :

Whenever I start Ubuntu,there appears to be "system error" notification.

Marko Stanković (sm4rk0) wrote :

@thomasmanchadi-k, this bug report is about a specific bug. If you cancel that notification, it will show up again next time you log in, until you authenticate.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers