[Ubuntu 16.04] update-notifier motd doesn't update with apt full-upgrade

Bug #1558270 reported by bugproxy on 2016-03-16
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ubuntu on IBM z Systems
Medium
Unassigned
update-notifier (Ubuntu)
Undecided
Dimitri John Ledkov

Bug Description

== Comment: #0 - Thorsten Winkler - 2016-03-16 06:59:10 ==
Logging in into Ubuntu shows the MOTD (message of the day) which again shows how many packages still could be updated.
---------
For example:
Welcome to Ubuntu Xenial Xerus (development branch) (GNU/Linux 4.4.0-11-generic s390x)

 * Documentation: https://help.ubuntu.com/

7 packages can be updated.
0 updates are security updates.
---------
After "apt-get update" and "apt-get upgrade", then rebooting the system, this message still appears although now no package is available to update. That is sometimes confusing a little bit.

Here the config of /etc/pam.d/login:
     session optional pam_motd.so motd=/run/motd.dynamic
     session optional pam_motd.so noupdate

I tried to comment the second line but nothing happened.
And I also tried to delete "/run/motd.dynamic", hoping that this file will be created again with updated information. But it does not.

== Comment: #1 - Thorsten Diehl - 2016-03-16 09:19:57 ==
After apt-get upgrade, apt-get dist-upgrade or aptitude the status of the number of updateable packages should be recalculated.

== Comment: #3 - Maxim Shchetynin - 2016-03-16 13:11:56 ==
These messages are generated by some Python script belonging to the package update-notifier-common.
To get rid of these annoying messages just remove the package update-notifier-common, though it is designed to be used on desktop systems and is therefore not necessary on server systems like System z.

Related branches

bugproxy (bugproxy) on 2016-03-16
tags: added: architecture-s39064 bugnameltc-139140 severity-low targetmilestone-inin---
Changed in ubuntu:
assignee: nobody → Skipper Bug Screeners (skipper-screen-team)
Kevin W. Rudd (kevinr) on 2016-03-16
affects: ubuntu → update-notifier (Ubuntu)
dann frazier (dannf) on 2016-03-16
Changed in update-notifier (Ubuntu):
assignee: Skipper Bug Screeners (skipper-screen-team) → Dimitri John Ledkov (xnox)
Dimitri John Ledkov (xnox) wrote :

This message is not cleared at the end of "apt fullinstall" but they are cleared when update notifier runs again. It is a cosmetic issue.

It is wrong to assume that update-notifier is not needed on the server, it implements reboot notifications, upgrade notifications, security notifications as well as propagates the data into landscape.canonical.com (or self-hosted instance) for remote monitoring and upgrades.

Dimitri John Ledkov (xnox) wrote :

@bdmurray @mvo

Is it sossible to somehow clear the update-notifier message at the end of the apt full-upgrade run? and/or get the motd check (without hitting the network) that there is nothing to upgrade?

summary: - [Ubuntu 16.04] No automatic/regular update of motd
+ [Ubuntu 16.04] update-notifier motd doesn't update with apt full-upgrade
Brian Murray (brian-murray) wrote :

I wonder if this is due to the change in update-notifier version 3.165 which makes "NEED_UPDATE_CHECK=no".

https://launchpadlibrarian.net/235427143/update-notifier_3.164_3.165.diff.gz

Steve Langasek (vorlon) wrote :

I think this is possibly fixed with the upload of update-notifier 3.167 and is a duplicate of bug #1563854.

dann frazier (dannf) wrote :

This appears to be a duplicate of LP: #1563854, so I'm going to mark it as such. If there is a different issue here, please unmark as a dup and add a comment explaining the difference.

------- Comment From <email address hidden> 2016-04-11 05:19 EDT-------
I can not confirm that this is fixed with version 3.167:
I tested this an system with update-notifier-common only and with both update-notifier and -common.
Same behaviour. motd status is not updated after apt-get upgrade, apt-get dist-upgrade, apt-get full-upgrade nor aptitude.

I would expect that /var/lib/update-notifier/updates-available is updated after every run of apt-get upgrade, apt-get dist-upgrade, apt-get full-upgrade or aptitude.

bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2016-04-11 11:01 EDT-------
Cleared LP duplicate flag as LP: #1563854 is not an IBM mirrored bug, and there are additional comments coming in via the existing mirror.

Changed in update-notifier (Ubuntu):
status: New → Fix Committed
Changed in ubuntu-z-systems:
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-notifier - 3.168

---------------
update-notifier (3.168) xenial; urgency=medium

  * Also update motd, at the end of Dpkg-Post run, properly counting how
    many things are left to update, rather than assuming that all updates
    were applied, as was done in previous release series. LP: #1558270

 -- Dimitri John Ledkov <email address hidden> Mon, 11 Apr 2016 16:28:54 +0100

Changed in update-notifier (Ubuntu):
status: Fix Committed → Fix Released
bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2016-04-12 11:54 EDT-------
Fixed with update-notifier 3.168. (Just having update-notifier-common 3.168 is not sufficient). Closed.

tags: added: targetmilestone-inin1604
removed: targetmilestone-inin---
Changed in ubuntu-z-systems:
status: In Progress → Fix Released
importance: Undecided → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers