cannot install new version of update-notifier: gconf schema problem

Bug #150680 reported by LGB [Gábor Lénárt] on 2007-10-08
116
Affects Status Importance Assigned to Milestone
update-notifier (Ubuntu)
High
Unassigned

Bug Description

Just tried to upgrade my AMD64 gutsy system but at upgrading package update-notifier, I got:

Setting up update-notifier (0.60) ...
/usr/share/gconf/schemas/update-notifier.schemas:12: parser error : Opening and ending tag mismatch: default line 7 and schema
    </schema>
             ^
/usr/share/gconf/schemas/update-notifier.schemas:14: parser error : expected '>'
  </schemalist>
          ^
/usr/share/gconf/schemas/update-notifier.schemas:15: parser error : Opening and ending tag mismatch: schemalist line 2 and gconfschemafile
</gconfschemafile>
                  ^
/usr/share/gconf/schemas/update-notifier.schemas:16: parser error : Premature end of data in tag gconfschemafile line 1

^
dpkg: error processing update-notifier (--configure):
 subprocess post-installation script returned error exit status 1
Errors were encountered while processing:
 update-notifier
E: Sub-process /usr/bin/dpkg returned an error code (1)

Content of usr/share/gconf/schemas/update-notifier.schemas:

<gconfschemafile>
  <schemalist>
    <schema>
      <key>/schemas/apps/update-notifier/show_apport_crashes</key>
      <applyto>/apps/update-notifier/show_apport_crashes</applyto>
      <type>bool</type>
      <default>false/default>
      <locale name="C">
        <short>Display apport crash reports automatically</short>
        <long>If this is disabled, the user will not be notified about pending apport crash reports.</long>
      </locale>
    </schema>

  </schemalist>
</gconfschemafile>

LGB [Gábor Lénárt] (lgb) wrote :

Ok, I think line:

<default>false/default>

should be:

<default>false</default>

Fixing file /usr/share/gconf/schemas/update-notifier.schemas and running dpkg --configure update-notifier does the trick.

Laurent GUERBY (laurent-guerby) wrote :

Same initial problem for me, LGB fix did work.

Changed in update-notifier:
importance: Undecided → High
status: New → Triaged
Pedro Villavicencio (pedro) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This particular bug has already been reported. Feel free to continue to report any other bugs you may find.

Changed in update-notifier:
status: Triaged → Invalid
Pedro Villavicencio (pedro) wrote :

I was going to mark this as dup of 150666 but that one was marked as dup in the meantime, re opening.

Changed in update-notifier:
status: Invalid → Triaged
libertyernie (libertyernie) wrote :

Manually editing the file /usr/share/gconf/schemas/update-notifier.schemas fixes the package for me.

John Vivirito (gnomefreak) wrote :

This bug has been confirmed

Changed in update-notifier:
status: Triaged → Confirmed
Chris Thomas (chris-mi-thomas) wrote :

This also affects the i386 release.

mewt (mewt-reaper) wrote :

editing file fixes it great..thanks :D

Brian Murray (brian-murray) wrote :

Changing the status back to Triaged as there is sufficient information in this bug report for a developer to fix the bug. See https://wiki.ubuntu.com/Bugs/Status for more information.

Changed in update-notifier:
status: Confirmed → Triaged
Martin Pitt (pitti) wrote :

This has been fixed in the newest release.

Changed in update-notifier:
status: Triaged → Fix Released
Howard (vibs) wrote :

just ran the update manger to install the newest upgrades for gusty. I have encounted this error, maybe the mirror just hadnt updated yet. LGB's fix worked.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers