apt_check.py crashed with SIGSEGV in strlen()

Bug #1497104 reported by Walter Garcia-Fontes on 2015-09-18
32
This bug affects 6 people
Affects Status Importance Assigned to Milestone
update-notifier (Ubuntu)
Medium
Unassigned

Bug Description

Got this crash report when waking up my system after suspension

ProblemType: Crash
DistroRelease: Ubuntu 15.10
Package: update-notifier-common 3.162
ProcVersionSignature: Ubuntu 4.2.0-7.7-generic 4.2.0
Uname: Linux 4.2.0-7-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.18.1-0ubuntu1
Architecture: amd64
CurrentDesktop: Unity
Date: Fri Sep 18 05:42:22 2015
ExecutablePath: /usr/lib/update-notifier/apt_check.py
InstallationDate: Installed on 2013-11-28 (658 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Release amd64 (20131016.1)
InterpreterPath: /usr/bin/python3.4
PackageArchitecture: all
ProcCmdline: /usr/bin/python3 /usr/lib/update-notifier/apt-check
SegvAnalysis:
 Segfault happened at: 0x7efcee3307fa <strlen+298>: movdqa (%rax),%xmm8
 PC (0x7efcee3307fa) ok
 source "(%rax)" (0x01f24000) not located in a known VMA region (needed readable region)!
 destination "%xmm8" ok
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: update-notifier
StacktraceTop:
 strlen () at ../sysdeps/x86_64/strlen.S:214
 debTranslationsIndex::IndexURI[abi:cxx11](char const*) const () from /usr/lib/x86_64-linux-gnu/libapt-pkg.so.4.16
 debTranslationsIndex::Exists() const () from /usr/lib/x86_64-linux-gnu/libapt-pkg.so.4.16
 ?? () from /usr/lib/x86_64-linux-gnu/libapt-pkg.so.4.16
 pkgCacheGenerator::MakeStatusCache(pkgSourceList&, OpProgress*, MMap**, bool) () from /usr/lib/x86_64-linux-gnu/libapt-pkg.so.4.16
Title: apt_check.py crashed with SIGSEGV in strlen()
UpgradeStatus: Upgraded to wily on 2015-09-01 (16 days ago)
UserGroups: adm cdrom dip kismet lp lpadmin plugdev sambashare saned scanner sudo vboxusers video

StacktraceTop:
 strlen () at ../sysdeps/x86_64/strlen.S:214
 debTranslationsIndex::IndexURI[abi:cxx11](char const*) const () from /tmp/apport_sandbox_2KfypQ/usr/lib/x86_64-linux-gnu/libapt-pkg.so.4.16
 debTranslationsIndex::Exists() const () from /tmp/apport_sandbox_2KfypQ/usr/lib/x86_64-linux-gnu/libapt-pkg.so.4.16
 ?? () from /tmp/apport_sandbox_2KfypQ/usr/lib/x86_64-linux-gnu/libapt-pkg.so.4.16
 pkgCacheGenerator::MakeStatusCache(pkgSourceList&, OpProgress*, MMap**, bool) () from /tmp/apport_sandbox_2KfypQ/usr/lib/x86_64-linux-gnu/libapt-pkg.so.4.16

Changed in update-notifier (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace

I got this crash again this morning after installing updates

information type: Private → Public
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in update-notifier (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers