Poor descriptions for some applications in Startup Programs window

Bug #146918 reported by Ergosys on 2007-09-29
64
This bug affects 9 people
Affects Status Importance Assigned to Milestone
NetworkManager
Fix Released
Medium
One Hundred Papercuts
Medium
Unassigned
gnome-volume-manager
Won't Fix
Wishlist
libcanberra
Fix Released
Medium
bluez-gnome (Ubuntu)
Low
Unassigned
evolution (Ubuntu)
Low
Ubuntu Desktop Bugs
gnome-control-center (Ubuntu)
Low
Ubuntu Desktop Bugs
gnome-panel (Ubuntu)
Low
Unassigned
gnome-power-manager (Ubuntu)
Low
Unassigned
gnome-session (Ubuntu)
Low
Ubuntu Desktop Bugs
gnome-settings-daemon (Ubuntu)
Low
Ubuntu Desktop Bugs
gnome-volume-manager (Ubuntu)
Low
Unassigned
jockey (Ubuntu)
Undecided
Martin Pitt
libcanberra (Ubuntu)
Undecided
Unassigned
network-manager-applet (Ubuntu)
Low
Ubuntu Desktop Bugs
pulseaudio (Ubuntu)
Undecided
Unassigned
seahorse (Ubuntu)
Low
Unassigned
system-config-printer (Ubuntu)
Low
Tim Waugh
tracker (Ubuntu)
Low
Ubuntu Desktop Bugs
update-notifier (Ubuntu)
Low
Unassigned

Bug Description

Most of the descriptions of the startup programs in the default setup are poor:

User Folders update: "No description"

Visual: "Autostart the preferred AT"
  What the heck is an AT? What does "autostart" mean? Is that like "start" or something different?

Volume Manager: "Volume manager for removable drives and media"
  Doesn't describe what it does except "manage", which is vague. The term "Volume" is ambiguous, so this should not be used in the description.

Print Queue Applet: "System tray icon for managing print jobs"
   "managing" is vague. What the heck is a "system tray"? Searching in help doesn't find it. And it is hopefully more than an icon.

Tracker: "Tracker search and indexing service"
   Bonus points for adding information, but "Tracker" is redundant and "service" is unnecessarily technical.

Other descriptions repeat their name without adding much or any information, except maybe "daemon" or "applet":
Network Manager, Power Manager, Bluetooth Manager, Evolution Alarm Notifier and Update Notifier are like this.

In general, it would be an improvement if the descriptions described what each program does in non-technical (if possible) terms using an active voice. For example, Tracker could be: "Indexes your files so that they can be searched".

Sebastien Bacher (seb128) wrote :

Thank you for your bug. That's not a gnome-session issue, the titles and descriptions come from the autostart desktop shipped with the applications, I've opened tasks for the mentionned ones, maybe you have suggestions on the changes to do there?

Changed in gnome-session:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Invalid

Здравствуйте, Sebastien.

Вы писали 3 октября 2007 г., 13:48:32:

Sebastien Bacher> Thank you for your bug. That's not a gnome-session issue, the titles and
Sebastien Bacher> descriptions come from the autostart desktop shipped with the
Sebastien Bacher> applications, I've opened tasks for the mentionned ones, maybe you have
Sebastien Bacher> suggestions on the changes to do there?

Sebastien Bacher> ** Changed in: gnome-session (Ubuntu)
Sebastien Bacher> Importance: Undecided => Low
Sebastien Bacher> Assignee: (unassigned) => Ubuntu Desktop Bugs (desktop-bugs)
Sebastien Bacher> Status: New => Invalid

ЗАЕБАЛИ!!!!!!!!!!!!!!!!!!!!!!!!!!

--
С уважением,
 Eduard mailto:<email address hidden>

The upstream package of system-config-printer contains translations into more or less 30 languages. Changing the translatable description now, shortly before Gutsy release is a bad idea, as translations will not catch up and leave the user with an untranslated entry. So better to fix this after release of Gutsy.

Changed in system-config-printer:
assignee: nobody → twaugh
importance: Undecided → Low
status: New → Confirmed
era (era) wrote :

The "Visual" thing in particular is extremely opaque. I was about to file a bug about that, but let me instead just chime in here.

Searching for "visual" in yelp suggested that "AT" might stand for "assistive technologies" (but did not unambiguously resolve the issue for me); still, it's not clear what "visual" and "preferred AT" refer to.

Googling for a bit brought up http://thread.gmane.org/gmane.comp.gnome.accessibility.devel/2599 which I think explains it well enough for someone to try to figure out how to clarify this.

I still don't understand why this needs to be in the Session manager. Shouldn't hooks for assistive technologies be integrated to Gnome itself?

era (era) wrote :

Launchpad bug #121525 (confirmed, priority low) is about the Visual problem specifically. I think it's more grave than the rest of this report, so maybe the corresponding part of this bug could be marked as "invalid" (I'm sure Sebastien Bacher is eager to bite ... sorry, couldn't resist).

Changed in evolution:
importance: Undecided → Low
Changed in gnome-control-center:
importance: Undecided → Low
Changed in gnome-power-manager:
importance: Undecided → Low
Changed in gnome-volume-manager:
importance: Undecided → Low
Changed in network-manager-applet:
importance: Undecided → Low
Changed in tracker:
importance: Undecided → Low
Changed in update-notifier:
importance: Undecided → Low
Changed in evolution:
assignee: nobody → desktop-bugs
status: New → Confirmed
Changed in gnome-control-center:
assignee: nobody → desktop-bugs
status: New → Confirmed
Changed in gnome-power-manager:
assignee: nobody → ted-gould
status: New → Confirmed
Changed in gnome-volume-manager:
assignee: nobody → desktop-bugs
status: New → Confirmed
Changed in network-manager-applet:
assignee: nobody → desktop-bugs
status: New → Confirmed
Changed in tracker:
assignee: nobody → desktop-bugs
status: New → Confirmed
Changed in update-notifier:
assignee: nobody → mvo
status: New → Confirmed
Martin Pitt (pitti) on 2008-02-06
Changed in gnome-volume-manager:
assignee: desktop-bugs → pitti
status: Confirmed → In Progress
Sebastien Bacher (seb128) wrote :

 Thank you for your bug report. This bug has been reported to the developers of the software. You can track it and make comments here: http://bugzilla.gnome.org/show_bug.cgi?id=515197

Changed in gnome-control-center:
status: Confirmed → Triaged
Sebastien Bacher (seb128) wrote :

The bug has been fixed upstream now

Changed in gnome-control-center:
status: Triaged → Fix Committed
Sebastien Bacher (seb128) wrote :

Now would be a good time to change system-config-printer?

Changed in gnome-volume-manager:
status: Unknown → Confirmed
Launchpad Janitor (janitor) wrote :
Download full text (3.6 KiB)

This bug was fixed in the package gnome-control-center - 1:2.21.92-0ubuntu1

---------------
gnome-control-center (1:2.21.92-0ubuntu1) hardy; urgency=low

  * New upstream versions:
    about-me:
    - Fix widget tab order (lp: #41748)
    - Don't distribute the .desktop.in file
    - Port to gio
    appearance:
    - always apply the current GConf settings to the initially selected
      wallpaper so that we don't modify the settings if GConf state and
      the definition in backgrounds.xml are not identical
    - don't try to set shading and options in GConf when we're dealing with a
      read-only source
    common:
    - Handle broken pipe if thumbnailer crashes
    - Fix a small leak in the file transfer dialog
    - Use new Metacity function to render rounded metacity borders correctly
      (lp: #131189)
    default-applications:
    - use '...' syntax instead of $(...) for better portability
    display:
    - Escape strange hostnames that we want to use as GConf keys
      (see bug #517259 for a similar issue in gnome-settings-daemon)
    general:
    - Increase required metacity version to 2.21.21
    - Revert removal of FONTILUS and THEMUS
      substitution that occurred in r8452.
    Fixes distcheck.
    - remove obsolete checks
    - add gio-2.0 to general capplet flags for now; this part needs
      cleaning up in the next cycle
    - Add check for LIBSOUNDS.
    appearance:
    - Add a comment for translators
    - Make sure we're done with the dialog before we destroy it (lp: #189003)
    - Remove useless (with GIO-based Nautilus) 'Go to fonts folder' button
    at-properties:
    - Move capplet to main menu
    default applications:
    - Support --new-tab/--new-window for Iceweasel
    - Improve name and description for the visual AT autostarter (lp: #146918)
    - Add support for Terminator console (lp: #184635)
    - Add support for Konsole (lp: #162021)
    keybindings:
    - Move Launch Calculator to Desktop group
      and sort all launch_app keybing together
    keyboard:
    - Don't mark padding strings as translatable
    libbackground:
    - Use LIBBACKGROUND_{CFLAGS,...} instead of CAPPLET_... so we can use
      libbackground in gnome-settings-daemon too
    - Don't pass a GError to the gconf_client*() calls
      since we don't use it anyway
    libwindow-settings:
    - Expose missing metacity double-click actions
    mouse:
    - Set up the proper scale widgets to GtkSizeGroup in both tabs
    - Fix HIG compliance for spacing, borders, padding, alignment
      and sentence label
    sound:
    - Use the libsounds.la now that libsounds uses libtool
    shell:
    - Add missing full stops in the long description
    - Specify libtool versioning info
    network:
    - Don't mark padding strings as translatable
    themus:
    - Don't leak the ATK relation set
    typing break:
    - Add a comment for translators
    general:
    - Remove some cruft from the configure script and give libbackground
      its own settings
    updated translation
  * debian/control.in:
    - updated libmetacity requirement
  * debian/patches/95_desktop-effects-integration.patch:
    - don't translate gtk-preferences label (lp: #15...

Read more...

Changed in gnome-control-center:
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

So the translations generally move to an "action"-based description ("Do something with foo") instead of a purpose-based description ("Foo manager")?

What do you guys suggest for the printer applet? "System tray icon for managing print jobs" → "Control printer jobs"?

Changed in gnome-volume-manager:
status: In Progress → Confirmed
Changed in jockey:
status: New → Confirmed

Hello,

Please find a small patch which change slightly the _name field and add a _comment field to jockey.
I hope I understand the purpose of jockey;

Regards,

Printer applet:
I would avoid "applet" because it is not very descriptive; let say "A tool to view and control the jobs sent to printers"

Martin Pitt (pitti) wrote :

Baptiste, thanks for raising that. Two things:

 * Is the Name field really supposed to have the application name inside? If not, I prefer the current string ("Check for new hardware drivers") in order to not break translations. If so, we need to find a new string, since jockey is intended to not just look for proprietary drivers (it'll get support for printer drivers soon, too, as well as for driver backports).

 * What about this Comment: "Notify about new hardware drivers which are applicable to your system"?

Changed in jockey:
status: Confirmed → Incomplete

For Jockey:

As we are on string freeze, _Name field won't be changed for now; but _Comment will be; we agreed on "Notify about new hardware drivers applicable to your system"; I'm thinking perhaps "Notify about new hardware drivers applicable for the system" would be good too.

Changed in jockey:
assignee: nobody → pitti
status: Incomplete → Confirmed

pitti said "In Progress" :)

Changed in jockey:
status: Confirmed → In Progress

<Hobbsee> crevette: that's correct english usage
<Hobbsee> crevette: although s/applicable/available/ would be better
<Hobbsee> crevette: er, s/applicable to/available for/

so "Notify about new hardware drivers available for the system"

Martin Pitt (pitti) on 2008-04-06
Changed in jockey:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package jockey - 0.3.3-0ubuntu6

---------------
jockey (0.3.3-0ubuntu6) hardy; urgency=low

  * Cherrypick a few bug fixes from trunk:
    - nvidia.py: Fix extra screen options to get quoted properly.
      (LP: #211368)
    - autostart .desktop files: Add Comment field. (LP: #146918)
    - POTFILES.in: Add missing desktop files.

 -- Martin Pitt <email address hidden> Sun, 06 Apr 2008 11:24:00 -0600

Changed in jockey:
status: Fix Committed → Fix Released
era (era) wrote :

There's a bunch of weird things in Startup Programs in Session Preferences in Intrepid. Should I post them here, or create a new bug? This bug report is rather unwieldy as it is, so perhaps it would be better to create a new one for Intrepid.

Gabor Kelemen (kelemeng) wrote :

For nm-applet, this was fixed in this upstream bug: http://bugzilla.gnome.org/show_bug.cgi?id=559636

era (era) wrote :

This may seem like a feeble accomplishment, but I managed to find out what AT-SPI means, and so might be able to figure out what "AT-SPI Registry Wrapper" means.

According to http://accessibility.kde.org/developer/atk.php#coreclasses AT-SPI is "Assistive Technology Service Provider Interface" and there are also descriptions of the architecture etc.

Funny that an accessibility / usability component would make the mistake of having a name which is completely undecipherable to the uninitiated, and no description (as of 8.10).

/usr/lib/gnome-session/helpers/at-spi-registryd-wrapper and the corresponding /usr/share/gnome/autostart/at-spi-registryd-wrapper.desktop are in the gnome-session package, so marking as "New" for gnome-session (or should I Be Bold and mark as "Confirmed"?)

My proposed fix would be to add the English description "Framework for applications to interact with assistive technologies". I would be tempted to say "Gnome applications" or even "GTK+ applications" but ironically, the usability folks tend to shoot down anything which involves a technical acronym (but then the name field is barely anything but a technical acronym).

Changed in gnome-session:
status: Invalid → New
era (era) wrote :

> There's a bunch of weird things in Startup Programs in Session Preferences
> in Intrepid. Should I post them here, or create a new bug? This bug report is
> rather unwieldy as it is, so perhaps it would be better to create a new one
> for Intrepid.

I never got a reply, so at least I'm enumerating here what I think is wrong.

(Format is Name[en] - Description[en] - my comments.)

"AT SPI Registry Wrapper" - "No description" - noted above

"Bluetooth Manager" - "Bluetooth Manager applet" - package bluez-gnome, adding "New"
The description is completely redundant after you remove "applet" which as noted elsewhere in this bug report is not recommended. Please describe what it does for the user. Suggest "Enable wireless connections to Bluetooth devices such as mobile phones" or some such. (Too long, admittedly, but then maybe the UI should be changed to accommodate longer descriptions.)

"Evolution Alarm Notifier" - "Evolution Alarm Notifier" - noted above

"GNOME Keyring Daemon Wrapper" - "No description" - package gnome-session, should have a description. "Allow applications to access the keyring" perhaps?

"GNOME Login Sound" - "No description" - I guess we can live with this :-)
Or should it say "Boing bling thud ksssssh"?

"GNOME Settings Daemon" - "No description" - package gnome-settings-daemon, "adding "New". "Manage your GNOME session's settings" maybe?

"GNOME Settings Daemon Helper" - "No description" - now this I think has a more fundamental problem. Are there situations where you would want to run the helper but not the daemon itself, or vice versa? Should that be expressed as a preference in the daemon's settings somewhere instead then? IMHO this is exposing an implementation boundary which should not be exposed to the user.

"GNOME Splash Screen" - "No description" - gnome-session. As with the sound above I guess, not really crucial to describe.

"Network Manager" - "Network Manager applet" - as per Gabor Kelemen's comment above, already fixed upstream

"PulseAudio Session Manager" - "Load module-x11-xsmp into PulseAudio" - package pulseaudio-module-x11, adding "New". Wayyy too technical description.

"Window Manager" - "No description" - package gnome-session. I can't help but think this is also a detail which normal users would never want control over.

Changed in network-manager:
status: Unknown → Fix Released
Gabor Kelemen (kelemeng) wrote :

Pulseaudio improved a lot recently:
http://pulseaudio.org/browser/src/daemon/pulseaudio.desktop
I think it's safe to close this part.
Too bad that this string is still not translatable, but that's another story ;)

Changed in pulseaudio:
status: New → Invalid
Martin Pitt (pitti) wrote :

We stopped using gnome-volume-manager in 8.10.

Changed in gnome-volume-manager:
assignee: pitti → nobody
status: Confirmed → Won't Fix
Changed in gnome-settings-daemon:
importance: Undecided → Low

This is fixed for network-manager-applet in version 0.7

Changed in network-manager-applet:
status: Confirmed → Fix Released
era (era) on 2009-02-19
Changed in pulseaudio:
status: Invalid → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package evolution - 2.25.92-0ubuntu2

---------------
evolution (2.25.92-0ubuntu2) jaunty; urgency=low

  * debian/evolution-alarm-notify.desktop.in,
    debian/patches/64_translate_autostart_strings.patch:
    - update the description and translate the autostart desktop strings,
      thank to Matthew Paul Thomas and Attila Hammer (lp: #146918, #331825)
  [ Ying-Chun Liu (PaulLiu) ]
  * Replace debian/patches/70_1024x600_contact-editor.glade.patch by
    debian/patches/70_1024x600_contact-editor.c.patch: don't add scrolled
    window when the resolution height is greater than 600
  * Replace 77_1024x600_mail-config.glade.patch by
    77_1024x600_mail-config.c.patch: don't add scrolled window when the
    resolution height is greater than 600 (LP: #337264)
  * Install widgets/e-timezone-dialog/e-timezone-dialog-1024x600.glade

 -- Sebastien Bacher <email address hidden> Wed, 04 Mar 2009 15:04:00 +0100

Changed in evolution:
status: Confirmed → Fix Released
Amit Kucheria (amitk) wrote :

The "AT SPI Registry Wrapper" has no description in gnome-session-properties in Jaunty. It is hard to tell whether I can safely turn this off or not.

at-spi-registryd-wrapper only gets run if you have the gconf key /desktop/gnome/interface/accessibility set to true.

Amit Kucheria (amitk) wrote :

On Sun, Apr 19, 2009 at 11:25:21PM -0000, Luke Yelavich wrote:
> at-spi-registryd-wrapper only gets run if you have the gconf key
> /desktop/gnome/interface/accessibility set to true.

That isn't reason to not have a description

It's still broken in Jaunty. I'm guessing it will be fixed in Karmic though.

Changed in pulseaudio (Ubuntu):
status: Fix Released → Fix Committed
summary: - poor descriptions for some startup programs
+ Poor descriptions for some applications in Startup Programs window
era (era) wrote :

Here's the current contents as of a fresh install of Jaunty. I'm leaving in the truncation I see on a 800x600 display, although that is really a separate bug (LP#278964 would have been topical, but was closed when the resize problem was fixed).

"AT SPI Registry Wrapper" - No description
"Bluetooth Manager" - "Bluetooth Manager applet"
"Check for new hardware driv..." - "Notify about new hardware driver..."
"Evolution Alarm Notifier" - "Ensures that alarms set in Evoluti..."
"GNOME Keyring Daemon" - No description
"GNOME Login Sound" - No description
"GNOME Settings Daemon" - No description
"GNOME Settings Daemon Hel..." - No description
"GNOME Splash Screen" - No description
"Indicator applet" - No description
"Network Manager" - "Control your network connections"
"Power Manager" - "Power management daemon"
"Print Queue Applet" - "System tray icon for managing pri..."
"PulseAudio Session Manage..." - "Load module-x11-xsmp into Pulse..."
"Remote Desktop" - "GNOME Remote Desktop Server"
"Seahorse Daemon" - No description
"Tracker" - "Tracker search and indexing service"
"Tracker Applet" - "Control and monitor the Tracker s...."
"Update Notifier" - "Update notification daemon"
"User folders update" - "Update common folders names to..."
"Visual Assistance" - "Start the preferred visual assistiv ..."

I note the inconsistent capitalization and use of passive / active voice etc. Perhaps we should seek a consensus on how these should be unified.

era (era) wrote :

I'm only noting those which are not already noted and/or fixed.

> "Check for new hardware driv..." - "Notify about new hardware driver..."

Perhaps the Jockey team would like to consider a shorter name field if the window size is not going to be changed.

> "GNOME Keyring Daemon" - No description

They took out the "Wrapper" but didn't fix the rest? Also I guess Daemon isn't very newbie-friendly, although i don't particularly want to see that changed personally. What's more bothersome is the concept of a keyring. What is it? Is this like PGP keys or SSH keys, or both, or what?

> "Indicator applet" - No description

Really vague. The real meat is /usr/share/gnome-panel/add-indicator-applet.py which is in the gnome-panel package. Adding as "New".

> "Seahorse Daemon" - No description

No idea what this does. Adding package seahorse as "New".

> "User folders update" - "Update common folders names to..."

If you expand the window, the description is actually fairly good. In case somebody still wants to look into this, the package is xdg-user-dirs-gtk (sic)

What a fantastic paper cut!

Changed in hundredpapercuts:
status: New → Confirmed

On Thu, 25 Jun 2009 16:52 +0000, "David Siegel"
<email address hidden> wrote:
> What a fantastic paper cut!

Thanks (-:

/* era */

--
If this were a real .signature, it would suck less. Well, maybe not.

Changed in hundredpapercuts:
milestone: none → round-2

@era:
> I note the inconsistent capitalization and use of passive / active voice etc.
> Perhaps we should seek a consensus on how these should be unified.

Maybe the Gnome HIG for application tooltips should be applied here as well?

Quoting 2.1.2 from http://library.gnome.org/devel/hig-book/stable/desktop-application-menu.html.en:
> Provide a tooltip for each Application menu item you add, following these guidelines:
> * Phrase the tooltip as an imperative verb, for example "design", "write" or "check".
> * Describe the most important tasks users can accomplish with your application.
> * While tooltips should not be verbose, they should be longer and more descriptive than the item's name.
> Examples:
> Character Map Insert special characters into documents
> Memprof Check your applications for memory leaks
> Same Gnome Arrange long chains of similarly-colored balls to eliminate them
> Gnome Batalla Naval Client Find and sink enemy ships in this networked version of Battleship

era (era) wrote :

@Marcel Stimberg: Sounds like a good plan. However, in the end game, it's the upstream maintainers' call whether or not they agree; but we could well submit patches and refer to these principles. (I don't suppose Ubuntu is going to be prepared to deviate from upstream just to fix this.) Perhaps a patch to the GNOME HIG policy should be proposed as well? If this is turned into GNOME policy it ought to be trivial to get patches approved for the individual applications.

era (era) wrote :

http://bugzilla.gnome.org/show_bug.cgi?id=515200#c5 suggests it may be moot to attempt to fix
Gnome Volume Manager's description at this point.

I think that as long as it's included and used in Ubuntu, we should
fix it. It's a completely trivial fix anyway. Immediately perfect
and improve the things you can, work carefully and thoughtfully on the
things you can't.

On Tue, Jun 30, 2009 at 2:10 PM, era<email address hidden> wrote:
> http://bugzilla.gnome.org/show_bug.cgi?id=515200#c5 suggests it may be moot to attempt to fix
> Gnome Volume Manager's description at this point.
>
> --
> Poor descriptions for some applications in Startup Programs window
> https://bugs.launchpad.net/bugs/146918
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Sebastien Bacher (seb128) wrote :

> It's a completely trivial fix anyway. Immediately perfect and improve the things you can

that's not so clear, the software is not installed by default so it would not benefit lot of users but it would break all the translations so would be a disfavor to all the non-english users

Sebastien Bacher (seb128) wrote :

> It's a completely trivial fix anyway. Immediately perfect and improve the things you can

that's not so clear, the software is not installed by default so it would not benefit lot of users but it would break all the translations so would be a disfavor to all the non-english users

Sebastien Bacher (seb128) wrote :

the bug needs suggestions from english speakers about better wording

Martin Albisetti (beuno) wrote :

I'll try to tackle this and suggest tooltips for these applications.

Changed in hundredpapercuts:
assignee: nobody → Martin Albisetti (beuno)
importance: Undecided → Medium
Martin Albisetti (beuno) wrote :

How's this?

"GNOME accessibility" - "System accessibility process"
"Bluetooth manager" - "Manages your bluetooth connections"
"Find new hardware drivers" - "Notifies you about new hardware driver"
"Evolution alarm notifier" - "Allows alarms set in Evolution to work"
"GNOME keyring daemon" - "Manages authentication for your GPG keys"
"GNOME login sound" - "Plays a sounds on startup"
"GNOME settings daemon" - "System process used to manage configurations"
"GNOME settings daemon Helper" - "System process used to manage configurations"
"GNOME splash screen" - "Startup screen graphics"
"Indicator applet" - "Displays information about various core applications"
"Network manager" - "Network management"
"Power manager" - "Power management"
"Print queue applet" - "System icon that displays printer queue"
"Sound session management" - "Manages Pulseaudio sound sessions"
"Remote desktop" - "Allow others to connect remotely to your desktop"
"Seahorse daemon" - "Manages SSH key authentication"
"Tracker" - "Search and indexing service"
"Tracker applet" - "System icon that displays indexing activity"
"Update notifier" - "Notifies you of system updates"
"User folders update" - "Keeps default folder names localized"
"Visual assistance" - "Preferred visual assistive application"

Andruk (andruk) wrote :
Download full text (3.6 KiB)

I think this is better, but I still don't like how some descriptions
describe what the process does while others are simply the same words
in the name rearranged while others describe the process itself.
Also, get rid of the word 'daemon' - it means nothing to people who
view their computer as a tool to get work done (read: a large subset
of our presumed target users) and people who know what a daemon is can
figure it out even if it isn't explicitly indicated.

This is what I came up with in a few minutes at work on a Windows
machine (so I couldn't check a few things, noted above). I'm still
quite a newbie, so please correct me at every opportunity. I am still
unsure about passive voice.

"GNOME accessibility" - "Arrange alternative interaction devices"
"Bluetooth manager" - "Connect and configure bluetooth devices"
"Driver update" - "Configure hardware drivers"
"Evolution alarm notifier" - "Configure advanced alarm clock features"
(is this correct?)
"GNOME keyring" - "Manage authentication for your GPG encryption keys"
"GNOME login sound" - "Configure system sounds"
"GNOME settings" - "Manage computer configurations"
"GNOME settings helper" - "Automatically manage computer
configurations" (is this correct?)
"GNOME splash screen" - "Change startup screen graphics"
"Indicator applet" - "Configure notifications for system"
"Network manager" - "Connect to a computer network"
"Power manager" - "Change power settings"
"Print queue applet" - "Show printer status"
"Sound session management" - "Manage sound system options" (should
this be "manager" rather than "management"?)
"Remote desktop" - "Allow others to connect to your desktop from a network"
"Seahorse keyring manager" - "Configure secure-shell (SSH)
authentication options"
"Tracker" - "Search and index files and folders"
"Tracker applet" - "Show indexing activity"
"Update notifier" - "Notify about application updates"
"User folders update" - "Keep default folder names localized"
"Visual assistance" - "Help for visually impaired users"

Thanks for caring so much about UI.
-- andruk

On Wed, Jul 1, 2009 at 3:01 PM, Martin Albisetti<email address hidden> wrote:
> How's this?
>
> "GNOME accessibility" - "System accessibility process"
> "Bluetooth manager" - "Manages your bluetooth connections"
> "Find new hardware drivers" - "Notifies you about new hardware driver"
> "Evolution alarm notifier" - "Allows alarms set in Evolution to work"
> "GNOME keyring daemon" - "Manages authentication for your GPG keys"
> "GNOME login sound" - "Plays a sounds on startup"
> "GNOME settings daemon" - "System process used to manage configurations"
> "GNOME settings daemon Helper" - "System process used to manage configurations"
> "GNOME splash screen" - "Startup screen graphics"
> "Indicator applet" - "Displays information about various core applications"
> "Network manager" - "Network management"
> "Power manager" - "Power management"
> "Print queue applet" - "System icon that displays printer queue"
> "Sound session management" - "Manages Pulseaudio sound sessions"
> "Remote desktop" - "Allow others to connect remotely to your desktop"
> "Seahorse daemon" - "Manages SSH key authentication"
> "Tracker" - "Search ...

Read more...

Download full text (3.9 KiB)

Andruk wrote:
> I think this is better, but I still don't like how some descriptions
> describe what the process does while others are simply the same words
> in the name rearranged while others describe the process itself.
> Also, get rid of the word 'daemon' - it means nothing to people who
> view their computer as a tool to get work done (read: a large subset
> of our presumed target users) and people who know what a daemon is can
> figure it out even if it isn't explicitly indicated.
>
> This is what I came up with in a few minutes at work on a Windows
> machine (so I couldn't check a few things, noted above). I'm still
> quite a newbie, so please correct me at every opportunity. I am still
> unsure about passive voice.
>
> "GNOME accessibility" - "Arrange alternative interaction devices"
> "Bluetooth manager" - "Connect and configure bluetooth devices"
> "Driver update" - "Configure hardware drivers"
> "Evolution alarm notifier" - "Configure advanced alarm clock features"
> (is this correct?)
> "GNOME keyring" - "Manage authentication for your GPG encryption keys"
> "GNOME login sound" - "Configure system sounds"
> "GNOME settings" - "Manage computer configurations"
> "GNOME settings helper" - "Automatically manage computer
> configurations" (is this correct?)
> "GNOME splash screen" - "Change startup screen graphics"
> "Indicator applet" - "Configure notifications for system"
> "Network manager" - "Connect to a computer network"
> "Power manager" - "Change power settings"
> "Print queue applet" - "Show printer status"
> "Sound session management" - "Manage sound system options" (should
> this be "manager" rather than "management"?)
> "Remote desktop" - "Allow others to connect to your desktop from a network"
> "Seahorse keyring manager" - "Configure secure-shell (SSH)
> authentication options"
> "Tracker" - "Search and index files and folders"
> "Tracker applet" - "Show indexing activity"
> "Update notifier" - "Notify about application updates"
> "User folders update" - "Keep default folder names localized"
> "Visual assistance" - "Help for visually impaired users"
>
> Thanks for caring so much about UI.
> -- andruk
>
> On Wed, Jul 1, 2009 at 3:01 PM, Martin Albisetti<email address hidden> wrote:
>
>> How's this?
>>
>> "GNOME accessibility" - "System accessibility process"
>> "Bluetooth manager" - "Manages your bluetooth connections"
>> "Find new hardware drivers" - "Notifies you about new hardware driver"
>> "Evolution alarm notifier" - "Allows alarms set in Evolution to work"
>> "GNOME keyring daemon" - "Manages authentication for your GPG keys"
>> "GNOME login sound" - "Plays a sounds on startup"
>> "GNOME settings daemon" - "System process used to manage configurations"
>> "GNOME settings daemon Helper" - "System process used to manage configurations"
>> "GNOME splash screen" - "Startup screen graphics"
>> "Indicator applet" - "Displays information about various core applications"
>> "Network manager" - "Network management"
>> "Power manager" - "Power management"
>> "Print queue applet" - "System icon that displays printer queue"
>> "Sound session management" - "Manages Pulseaudio sound sessions"
>> "Remote desktop" - "Allow oth...

Read more...

Hi,

Martin Albisetti:
> "GNOME accessibility" - "System accessibility process"
> "Bluetooth manager" - "Manages your bluetooth connections"
> "Evolution alarm notifier" - "Allows alarms set in Evolution to work"
[etc.] Shouldn't you use the imperative here? I.e. "Manage your ...",
"Allow alarms ...", etc.

> "Find new hardware drivers" - "Notifies you about new hardware driver"
Umm, IMHO the important part is to _install_ drivers for your new
hardware, so that's what it should say.

> "GNOME settings daemon" - "System process used to manage configurations"
s/used to manage/for managing/ ?

> "Network manager" - "Network management"
> "Power manager" - "Power management"

That doesn't convey any additional information. :-/

> "Tracker applet" - "System icon that displays indexing activity"

Why not simply "display indexing activity"?

--
Matthias Urlichs | {M:U} IT Design @ m-u-it.de | <email address hidden>
Disclaimer: The quote was selected randomly. Really. | http://smurf.noris.de
v4sw7$Yhw6+8ln7ma7u7L!wl7DUi2e6t3TMWb8HAGen6g3a4s6Mr1p-3/-6 hackerkey.com
 - -
Benedict's Principle (formerly Murphy's Ninth Corollary):
    Nature always sides with the hidden flaw.

era (era) wrote :

Thanks for pitching in here! Allow me to comment on a few of your suggestions, though.

As a general comment, these are applications which are started when your session is initiated. Many of them are infrastructure, daemon-type programs which do not directly expose a user interface. Therefore I find it slightly problematic to describe them in terms of "what the user can do".

> "GNOME accessibility" - "Arrange alternative interaction devices"

I'd also be hesitant to coin new names for existing components. Users who know what AT-SPI is might be annoyed to find it renamed to something novel. In order to cover this legacy issue, at a minimum I'd like to keep the old name in the description somewhere. How about

"GNOME AT-SPI Accessibility" - "Enable alternative input and output devices"

> "Evolution alarm notifier" - "Configure advanced alarm clock features"
(is this correct?)

I think they fixed this one already; the current one is IMHO clearer and more correct.

> "GNOME keyring" - "Manage authentication for your GPG encryption keys"

I'm at loss to the relationship between Seahorse and the GNOME Keyring. http://en.wikipedia.org/wiki/GNOME_Keyring says Seahorse should replace the old keyring altogether. If that's the case, it will handle both SSH and GPG keys. In any event, this component does "manage" them from the system's perspective, but it's more of a daemon for interconnecting the key store with applications, if I understand any of this at all. Maybe this description is fine; I'm just thinking out loud here.

> "GNOME login sound" - "Configure system sounds"

To the best of my understanding, this one merely plays the sound; you configure it elsewhere.

"GNOME Login Sound" - "Play the login chime"

> "GNOME settings" - "Manage computer configurations"
>"GNOME settings helper" - "Automatically manage computer
configurations" (is this correct?)

I'm sorry, I'm not really comfortable with this. I don't understand this (see my comments above) but in any event, I believe this manages only the core GNOME configuration, i.e. basically what you can manipulate with gconftool. Most of what users want to configure is handled elsewhere.

> "GNOME splash screen" - "Change startup screen graphics"

Again, like with the login sound, this one just executes, doesn't configure.

> "Indicator applet" - "Configure notifications for system"

Do you genuinely understand what this one does? Could you point to some documentation? Is this the new notification thingamajig? Why does it require a separate startup process in order to add something to the panel, anyway?

> "Network manager" - "Connect to a computer network"
> "Power manager" - "Change power settings"

Again, these run a service which enable you to do these things, but do not directly expose a user interface. Maybe I'm too picky; maybe these are fine.

Finally, I vaguely think the Name field should perhaps be in Title Case, like most of the existing entries.

Thanks again for coming up with a good proposal. These are all minor nits for the most part.

Matthew Paul Thomas (mpt) wrote :

era gives a good explanation of why these descriptions should not use imperative case. There is nothing you have to do here; the purpose of the description is merely to explain why the program is running in the first place. So for example, a good description for "GNOME login sound" would be "Plays a sound whenever you log in". And a good description for "Indicator applet" would be "Provides quick access to messages received in Evolution or Pidgin". One guide to whether you're on the right track: the first word of the description should usually be a verb that ends in the letter "s".

Mark Steadman (bugaroosa) wrote :

In general names in menus are either nouns(OpenOffice, Mozilla Firefox, etc.) or verbs in the imperative case (Open, Save, Uninstall foo, Add/Remove Programs, etc.). The question is should the description be a longer name for the action (Open -> Open a Document [longer name for open]) or a description of the action (Open -> Opens a document [description]), since expansions do both? If you decide on a name like "GNOME Login Sound" it makes sense to provide a description in the descriptive case "Plays the login sound." Since it makes sense to have a name/description pair in order to be consistent one should have also a verb/description. The other option would be short name/long name where the long name would make it clear what it does (Mozilla Firefox/Mozilla Firefox Internet Browser).b

Scott Ritchie (scottritchie) wrote :

What does the seahorse daemon actually do here? Is this the program that prompts me and remembers my GPG key for 10 minutes when I enter it into thunderbird enigmail?

If so, I'd suggest something like "Remembers unlocked encryption keys for limited time"

Changed in seahorse (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Vish (vish) wrote :

@Mark Steadman:
Open -> Opens a document is more correct,
Because the "Open" verb needs to be treated as a noun , since we are describing the verb.
But there is *no* Open in the Startup Applications, rather only names of apps/daemons.
Also simply expanding a name> Long name , wouldnt be a description.

@Scott Ritchie: Maybe:
SeaHorse> "Manages encryption keys"

Vish (vish) wrote :

@Mark Steadman:
Open -> Opens a document is more correct,
Because the "Open" verb needs to be treated as a noun , since we are describing the verb.
But there is *no* Open in the Startup Applications, rather only names of apps/daemons.
Also simply expanding a name> Long name , wouldnt be a description.

@Scott Ritchie: Maybe:
SeaHorse> "Manages encryption keys and keyrings"
http://live.gnome.org/Seahorse

Michael Vogt (mvo) on 2009-07-14
Changed in update-notifier (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-notifier - 0.86

---------------
update-notifier (0.86) karmic; urgency=low

  [ Sebastien Bacher ]
  * debian/rules:
    - build using --as-needed to reduce the depends

  [ Dustin Kirkland ]
  * debian/update-notifier-common.dirs: update-notifier-common
    needs /etc/update-motd.d, rather than /etc/update-motd.d/hourly;
    causes this directory to *not* be removed on update-motd package
    removal/upgrade

  [ Michael Vogt ]
  * src/update-notifier.c:
    - if display can not be opened, show a propper error message
      and do not crash (LP: #317745)
  * src/apt_check.py:
    - count security updates correctly even when they are "shadowed"
      by a regular update (LP: #394958)
    - fix typo (thanks to Hew McLachlan)
  * data/update-motd-updates-available, debian/99update-notifier:
    - move updates available from /var/run to /var/lib/update-notifier
      to make it persistent over reboots
  * src/update-notifier.c:
    - make the timeout for no-activity from apt bigger (LP: #274001)
  * data/update-notifier.desktop.in:
    - better description for the auto startup (LP: #146918)
  * src/update-notifier.c:
    - use GAppInfo/GAppLaunchContext to provide startup notification
      support (LP: #46258)

 -- Michael Vogt <email address hidden> Tue, 14 Jul 2009 16:50:46 +0200

Changed in update-notifier (Ubuntu):
status: Fix Committed → Fix Released
era (era) wrote :

I'm not entirely happy with the new description for Update Notifier: "Check for available updates automatically". The wording is somewhat verbose (why would it check for unavailable updates, and how? Why is this "automatically"? I think I kind of know why you put it there, but is it really necessary?) but above all, if you don't know what sorts of updates, how would you find out? Both of the proposals above are IMHO more informative.

Martin Albisetti wrote on 2009-07-02:
> "Update notifier" - "Notifies you of system updates"

Andruk wrote on 2009-07-02:
> "Update notifier" - "Notify about application updates"

"Check for software updates from Ubuntu and other software sources", though a bit long, might approach some sort of synthesis.

Although I criticize the details of his wording, I think Michael Vogt's proposal captures the essence of the discussion so far; describe what functionality will stop working if you uncheck it. After all, that's what this dialog box is meant for. Hence, perhaps Bluetooth Manager could be something like "Discover Bluetooth devices within range" and Network Manager perhaps something along the lines of "Discover and connect to networks" (by implication, Internet connections; perhaps that could somehow be worked into the description still).

Vish (vish) wrote :

Actually , Update notifier is no longer a valid name. Since the updates behavior has been changed since Jaunty.

So renaming the update-notifier daemon > update-manager daemon would be better.
Since its now working just as an update manger daemon, and there is no other specific notifier.

I'v opened a separate bug for this renaming> Bug #399591

If it is renamed then the description would be > "Checks and displays updates on availability"

Changed in gnome-panel (Ubuntu):
importance: Undecided → Low
Changed in hundredpapercuts:
status: Confirmed → In Progress
era (era) wrote :

@Michael Vogt, others: do you agree with my criticism of the update-notifier patch? I'd reopen this bug for update-notifier but I don't want to be (overtly :-) obnoxious.

Created an attachment (id=28668)
Patch to add a Comment property to the .desktop file that explains what GNOMe Login Sound does

This bug has been reported in Launchpad: https://bugs.launchpad.net/ubuntu/+source/gnome-session/+bug/146918

When a user goes to look at the description for the GNOME (libcanberra) login sound, it has no description in the Startup applications window.

To improve usability, a description needs to be added in the libcanberra-login-sound.desktop file

Attached is a patch for the latest GIT that solves this problem.

There is no chance of any breakage etc. it just adds a Comment property to the .desktop file that explains what it does.

It will be very easy to apply the patch and no risks (ie. stability) involved

Andrew (and471) on 2009-08-16
Changed in libcanberra:
status: New → In Progress
Andrew (and471) on 2009-08-16
Changed in libcanberra:
importance: Undecided → Unknown
status: In Progress → Unknown
status: Unknown → In Progress
Changed in libcanberra:
status: In Progress → Confirmed
Andrew (and471) on 2009-08-16
Changed in libcanberra:
status: Confirmed → Fix Released
Changed in libcanberra (Ubuntu):
status: New → In Progress
era (era) wrote :

Reopening for update-notifier as per comment #54 (see also comment #56). Please feel free to change back to Fix Released if you disagree, obviously.

Changed in update-notifier (Ubuntu):
assignee: Michael Vogt (mvo) → nobody
status: Fix Released → New

On Sun, 16 Aug 2009 19:20 +0000, "rugby471" <email address hidden> wrote:
> ** Changed in: libcanberra
> Status: Confirmed => Fix Released

Should't this be "Fix Committed" until it is actually available in an
official release?

/* era */

--
If this were a real .signature, it would suck less. Well, maybe not.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libcanberra - 0.15-0ubuntu3

---------------
libcanberra (0.15-0ubuntu3) karmic; urgency=low

  * debian/patches/0002-add-description-to-autostart-file.patch: Add comment
    to desktop file used for playing the GNOME login sound, taken from
    git master. Thanks to Andrew Higginson <email address hidden> for the
    work. (LP: #146918)

 -- Luke Yelavich <email address hidden> Tue, 18 Aug 2009 15:01:14 +1000

Changed in libcanberra (Ubuntu):
status: In Progress → Fix Released
Matthew Paul Thomas (mpt) wrote :

era, the confusion between Fix Committed and Fix Released in Ubuntu vs. other projects is covered by bug 163694.

Andrew (and471) on 2009-08-26
Changed in gnome-volume-manager:
status: Confirmed → Invalid
Martin Albisetti (beuno) on 2009-08-26
Changed in hundredpapercuts:
assignee: Martin Albisetti (beuno) → nobody
Chris Coulson (chrisccoulson) wrote :

What needs doing here for gnome-settings-daemon then?

Changed in gnome-settings-daemon (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
status: New → Incomplete
era (era) wrote :

@Chris Coulson: somebody who understands what gnome-settings-daemon and its "helper" do should improve the _Comment field (or add if missing) in their .desktop files.

See e.g. comment #21 for a slightly more detailed problem analysis and comment #43 and the following ones for a draft proposal. Some comments of mine in comment #47 might be useful as guidance for the person authoring the descriptions.

To my current understanding, gnome-settings-daemon is the thing which communicates between gconf and individual gconf clients. What role the "helper" plays in this I don't know. To reiterate remarks from comment #21, is it really absolutely necessary for there to be two different components in the Startup Applications dialog? It would seem like an improvement both for usability and functional purposes to have a single entry there; if it needs to start two processes behind the scenes then so be it, but that should probably not be exposed to the user in this fashion (assuming that it does not really make much sense to run the daemon without the helper, or vice versa); but please understand that my mental model of this is probably less than adequate.

Changed in gnome-settings-daemon (Ubuntu):
status: Incomplete → New
Sebastien Bacher (seb128) wrote :

>> "Indicator applet" - "Configure notifications for system"

> Do you genuinely understand what this one does? Could you point to some documentation? Is this the new notification thingamajig? Why does it require a separate startup process in order to add something to the panel, anyway?

the code is a small script run to add the indicator applet to the gnome-panel configuration after upgrades, it's useful only once but there is no easy way to mask it from the list there

era (era) wrote :

On Thu, 10 Sep 2009 11:05 +0000, "Sebastien Bacher" <email address hidden>
wrote:
> the code is a small script run to add the indicator applet to the gnome-
> panel configuration after upgrades, it's useful only once but there is
> no easy way to mask it from the list there

So it is indeed the Growl-ish thing which shows balloons for various
types of system events? There are some rather wild guesses for what to
put in the description in earlier messages in this bug report, but this
is what I thought as well.

Anyway, as per the quoted comment, the startup item doesn't "configure"
this, just adds it to the panel; so the description should be more along
the lines of "enable notification pop-ups", I guess.

era (era) wrote :

... on the other hand, if it is only useful when it first runs, and indications remain active even if you uncheck it in Startup Programs, that I think is a bug in its own right. Did I understand correctly that this is in fact how it works?

Ted Gould (ted) on 2009-09-10
Changed in gnome-power-manager (Ubuntu):
assignee: Ted Gould (ted) → nobody
Vish (vish) wrote :

 "Indicator applet" - "Updates existing panel configurations to add the applet"
Is a better description ,

But i-a item should *not* be present in the startup list , since it does not have anything to do with starting i-a every time the user logs in.

So , Sebastien is currently figuring a way to have it removed from the startup list while preserving the functions it presently does...
Let's hope he has some spare time before Karmic ;)

@era :
see this file for how it works > /usr/share/gnome-panel/add-indicator-applet.py

Changed in hundredpapercuts:
milestone: round-2 → r2
Vish (vish) wrote :

Old "Update Notifier" description was "Update notification daemon"

In Lucid , it is > "Check for available updates automatically"

Which is what the daemon currently does, it just checks.
I believe we can mark this fix released.

Also , is there any progress from others who have been assigned to the respective packages? Bug seems to have stalled for a long time

Changed in update-notifier (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-session - 2.28.0-0ubuntu9

---------------
gnome-session (2.28.0-0ubuntu9) lucid; urgency=low

  * debian/gnome-session.install, debian/gnome-session-bin.install:
    - don't install the gnome-settings-daemon helper which sets a gtk1 variable
      since that gtk version is deprecated for some cycles
  * debian/patches/91_git_change_correct_capplet_update.patch:
    - git update to fix changes not being stored by the session capplet sometime
      (lp: #444993)
  * debian/gnome-session.preinst:
    - clean deprecated autostart conffiles on upgrade (lp: #146918,#457104)
 -- Sebastien Bacher <email address hidden> Tue, 26 Jan 2010 15:59:42 +0100

Changed in gnome-session (Ubuntu):
status: New → Fix Released
Vish (vish) wrote :

This bug is a huge meta-bug.

From what i can check , the apps in the default setup have been updated. Hence marking it as fix released for papercuts task.
Have I missed any?

Changed in hundredpapercuts:
status: In Progress → Fix Released
era (era) wrote :

I downloaded http://cdimage.ubuntu.com/releases/lucid/alpha-3/lucid-desktop-i386.iso and booted it in Virtualbox. (Incidentally, it takes several minutes to boot up!) I inspected the dialog System > Preferences > Startup Applications and found the following issues to be still open:

* Bluetooth Manager is still kind of vacuous
* Certificate and Key Storage has a very technical description
* Disk Notifications is ... unobvious. What does it actually do?
* GNOME Settings Daemon doesn't have a description, still
* Power kind of irks me, although it's not obvious how to improve it
* Print Queue Applet is still kind of riddled with jargon
* Update Notifier should IMHO mention that it checks for system software updates
* User folders update could still benefit from a somehow less obscure description

The following issues are new, and it's not obvious to me that they belong in this bug in particular.

* Certificate and Key Storage is not consistent with the other Gnome Keyring stuff
* Unchecked items are greyed, as if you couldn't enable them (in fact you can)
* Gwibber is unchecked by default
* "if enabled" is kind of superfluous in the description of Personal File Sharing

Below is an ASCII art rendition of the dialog box in Lucid Alpha 3.

* Bluetooth Manager
  Bluetooth Manager applet
* Certificate and Key Storage
  GNOME Keyring: PKCS#11 Component
* Check for new hardware drivers
  Notify about new hardware drivers ava...
* Disk Notifications
  Provides notifications related to disks
* Evolution Alarm Notifier
  Ensures that alarms set in Evolution go...
---more---
* GNOME Login Sound
  Plays a sound whenever you log in
* GNOME Settings Daemon
  No description
? Gwibber
  Microblogging Client for GNOME
* Network Manager
  Control your network connections
* Personal File Sharing
  Launch Personal File Sharing if enabled
---more---
* Power
  Power management daemon
* Print Queue Applet
  System tray icon for managing print jobs
* PulseAudio Sound System
  Start the PulseAudio Sound System
* Remote Desktop
  GNOME Remote Desktop Server
---more---
* Secret Storage Service
  GNOME Keyring: Secret Service
* SSH Key Agent
  GNOME Keyring: SSH Agent
* Update Notifier
  Check for available updates automatic...
* User folders update
  Update common folders names to mat...
* Visual Assistance
  Start the preferred visual assistive tec...

era (era) wrote :

Also, there are still Capitalization Issues. Should the applications be Title Case? Should the descriptions be regular prose? You see all kinds of variants, still.

> (Incidentally, it takes several minutes to boot up!)

Sorry, not really pertinent here, and it was acceptably fast compared to the latest daily build, which was what I tried first, and which caused me to write this comments in the first place.

era (era) wrote :

Reopening for hundredpapercuts; could you please at the very least add a description for the GNOME Settings Daemon, and maybe take out the "if enabled" in Personal File Sharing. Also the Bluetooth Manager could reasonably fit within the scope of this paper cut, if somebody comes up with a good description of what it does. (I like the suggestions in comment #43 and comment #44.)

Changed in hundredpapercuts:
status: Fix Released → In Progress
era (era) wrote :

Tracker seems to be gone from the Startup Applications dialog. Setting the task for tracker to "Invalid".

Changed in tracker (Ubuntu):
status: Confirmed → Invalid
era (era) wrote :

Seahorse seems to be gone from Startup Applications now. Setting the task for seahorse to "Invalid".

Changed in seahorse (Ubuntu):
status: Triaged → Invalid
Sebastien Bacher (seb128) wrote :

Do you have any gnome-settings-daemon description suggestion?

era (era) wrote :

gnome-settings-daemon: like I write in my comments above, my understanding of its role is probably flawed and/or incomplete, but based on the suggestions in comment #43 and comment #44 and my critique of these, I'd propose something like "Manage GNOME system configuration" or maybe "GNOME system configuration back-end". Perhaps these are too technical, still. (And the "manage" verb is a bit of a red flag, but then I guess so is "back-end".)

era (era) wrote :

The suggestion in comment #44 for the Print Queue Applet is also IMHO a vast improvement over the status quo.

Chris Coulson (chrisccoulson) wrote :

We could just add "NoDisplay=true" to the gnome-settings-daemon desktop file, and hide it completely from the capplet :-)

era (era) wrote :

That sounds like a reasonable plan; there could hardly be a situation where a user would want to disable it, and still have a working Gnome desktop?

era (era) wrote :

Confirming based on long discussions here.

Changed in gnome-settings-daemon (Ubuntu):
status: New → Confirmed
Changed in bluez-gnome (Ubuntu):
status: New → Confirmed
Changed in gnome-settings-daemon (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-settings-daemon - 2.29.92-0ubuntu2

---------------
gnome-settings-daemon (2.29.92-0ubuntu2) lucid; urgency=low

  * debian/patches/07_dont_display_autostart.patch:
    - don't show the gnome-settings-daemon autostart in the session capplet,
      the description is confusing and it's a required component (lp: #146918)
  * debian/patches/92_keyboard_settings_update.patch:
    - upstream change to apply xkb settings to newly connected keyboards
      (lp: #427168)
 -- Sebastien Bacher <email address hidden> Wed, 10 Mar 2010 00:15:32 +0100

Changed in gnome-settings-daemon (Ubuntu):
status: Fix Committed → Fix Released

bluez-gnome has been demoted. so no need to fix.

Changed in bluez-gnome (Ubuntu):
importance: Undecided → Low
status: Confirmed → Won't Fix
Vish (vish) wrote :

This has become a huge metabug!

Is there any description that hasnt been updated yet.

Changed in hundredpapercuts:
milestone: lucid-round-2 → maverick-round-4-potpourri
Vish (vish) wrote :

Gnome-settings-daemon got fixed and bluez-gnome got demoted.

Seems like the list has been cleared! Marking bug as fixed. Really confusing bug! ;-)

Changed in hundredpapercuts:
status: In Progress → Fix Released
Changed in libcanberra:
importance: Unknown → Medium
Changed in network-manager:
importance: Unknown → Medium
Changed in gnome-volume-manager:
importance: Unknown → Wishlist
status: Invalid → Confirmed
Changed in libcanberra:
importance: Medium → Unknown
Changed in libcanberra:
importance: Unknown → Medium
Lars Karlitski (larsu) wrote :

system-config-printer's applet will be deprecated in 12.04.

Changed in system-config-printer (Ubuntu):
status: Confirmed → Invalid
Changed in gnome-volume-manager:
status: Confirmed → Won't Fix
Thomas Hotz (thotz) on 2012-12-03
Changed in gnome-panel (Ubuntu):
status: New → Confirmed
Changed in pulseaudio (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.