[FFE] Use systemd-services rather than ubuntu-system-service systemdcompatibility code

Bug #1153567 reported by Sebastien Bacher on 2013-03-11
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-control-center (Ubuntu)
Low
Unassigned
gnome-settings-daemon (Ubuntu)
Low
Unassigned
indicator-datetime (Ubuntu)
Low
Unassigned
policykit-desktop-privileges (Ubuntu)
Low
Unassigned
ubuntu-system-service (Ubuntu)
Low
Unassigned
update-notifier (Ubuntu)
High
Martin Pitt

Bug Description

The topic was discussed at UDS and work recorded in that spec:
https://blueprints.launchpad.net/ubuntu/+spec/desktop-r-ubuntu-system-services

The transition is ready and tested in the desktop team ppa at the moment, it impacts on those sources:

 * systemd
- needs systemd-services MIRed, that's bug #1152187

 * gnome-settings-daemon and gnome-control-center:
- basically drop the revert-git-commits patches we carry at the moment (those patches make g-s-d ships a custom helper code and g-c-c uses that interface)

* indicator-datetime
- use the systemd interface
https://code.launchpad.net/~desrt/indicator-datetime/timedated/+merge/151560

* ubuntu-system-service
- drops the code that was added to emulate some of the systemd interfaces

Changed in gnome-control-center (Ubuntu):
status: New → Triaged
Changed in gnome-settings-daemon (Ubuntu):
status: New → Triaged
Changed in indicator-datetime (Ubuntu):
status: New → Triaged
Changed in ubuntu-system-service (Ubuntu):
status: New → Triaged
Changed in gnome-control-center (Ubuntu):
importance: Undecided → Low
Changed in gnome-settings-daemon (Ubuntu):
importance: Undecided → Low
Changed in indicator-datetime (Ubuntu):
importance: Undecided → Low
Changed in ubuntu-system-service (Ubuntu):
importance: Undecided → Low
Changed in policykit-desktop-privileges (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Scott Kitterman (kitterman) wrote :

Why was this not landed before feature freeze? One attribute of the development schedule this cycle is that we move feature freeze later in the cycle so that people could get work done before hand with the understanding that we would not generally approve things that didn't make it.

Sebastien Bacher (seb128) wrote :

> Why was this not landed before feature freeze?

Trying to summarize the reasons:
- systemd being packaged was a pre-required to start this work, that took most of the cycle (Steve who was working on that is quite busy...)
- we looked at doing the migration then, put things in a ppa for testing and ran into a few issues, it took a week or so to get those sorted
- vUDS happened then, which "distracted" us from looking at landing things
- systemd's MIR has not been approved yet (admitelly it was written late to make the feature freeze)

Short summary: systemd took a while to land in raring and then the recent discussions made hard to focus on landing our work on time...

Sebastien Bacher (seb128) wrote :

it's unrelated, this FFe only requires systemd-services' helpers (hostnamed, timedated)

Scott Kitterman (kitterman) wrote :

Please check with Ubuntu Gnome (jbicha) and as long as they are also OK with this, approved.

desrt (desrt) wrote :

Note also that this depends on the systemd-shim MIR being approved: bug 1153633

Jeremy Bicha (jbicha) wrote :

+1 from Ubuntu GNOME; in fact this makes things easier and better for us instead of shipping an outdated copy of the datetime panel in System Settings.

I haven't actually tried this stack yet; I guess I just need to enable https://launchpad.net/~ubuntu-desktop/+archive/ppa ?

Sebastien Bacher (seb128) wrote :

> I haven't actually tried this stack yet; I guess I just need to enable https://launchpad.net/~ubuntu-desktop/+archive/ppa ?

yes

desrt (desrt) wrote :

You need to ensure that you manually install the PPA versions of all 5 components listed above (since at least one of them is out of date in the PPA at the time of writing). Also need to install systemd-shim (which will eventually make it into at least a recommends of ubuntu-desktop at some point, I assume).

Changed in policykit-desktop-privileges (Ubuntu):
status: Triaged → Fix Committed
Changed in ubuntu-system-service (Ubuntu):
status: Triaged → Fix Committed
Changed in indicator-datetime (Ubuntu):
status: Triaged → Fix Committed
Changed in gnome-settings-daemon (Ubuntu):
status: Triaged → Fix Committed
Changed in gnome-control-center (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package policykit-desktop-privileges - 0.13

---------------
policykit-desktop-privileges (0.13) raring; urgency=low

  * debian/control: breaks on old gnome-settings-daemon version.

  [ Ryan Lortie ]
  * Change the authorisation name for datetime control functions since we are
    no longer carrying the mechanism in gnome-settings-daemon. (lp: #1153567)
 -- Sebastien Bacher <email address hidden> Tue, 26 Mar 2013 21:35:18 +0100

Changed in policykit-desktop-privileges (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-system-service - 0.2.4

---------------
ubuntu-system-service (0.2.4) raring; urgency=low

  * Drop system compatibility, we use systemd-services instead (lp: #1153567)
 -- Sebastien Bacher <email address hidden> Tue, 26 Mar 2013 21:32:36 +0100

Changed in ubuntu-system-service (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-datetime - 12.10.3daily13.03.26-0ubuntu1

---------------
indicator-datetime (12.10.3daily13.03.26-0ubuntu1) raring; urgency=low

  * Use systemd's service backend, ffe lp: #1153567
  * debian/control: depends on systemd-services and systemd-shim
 -- Sebastien Bacher <email address hidden> Tue, 26 Mar 2013 19:53:55 +0100

Changed in indicator-datetime (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-settings-daemon - 3.6.4-0ubuntu8

---------------
gnome-settings-daemon (3.6.4-0ubuntu8) raring; urgency=low

  * debian/control.in:
    - Breaks on g-c-c and indicator-datetime versions using the old interface
    - recommends systemd-service (lp: #1153567)
  * debian/gnome-settings-daemon.install:
    - updated for the patch being dropped
  * debian/gnome-settings-daemon.main:
    - clean org.gnome.SettingsDaemon.DateTimeMechanism.conf conffile
  * debian/patches/revert_git_datetime_dropping.patch:
    - drop the upstream's revert
 -- Sebastien Bacher <email address hidden> Tue, 26 Mar 2013 21:20:26 +0100

Changed in gnome-settings-daemon (Ubuntu):
status: Fix Committed → Fix Released
Changed in gnome-control-center (Ubuntu):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

We did an archive grep for software that uses com.ubuntu.SystemService, and update-notifier was the one remaining user. It uses this to check whether or not to pop up update-notifier (checks whether any apt/dpkg lock is already taken). This is a regression, as we don't ship ubuntu-system-service any more in raring, so targetting for raring.

Changed in update-notifier (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
importance: Undecided → High
milestone: none → ubuntu-13.04
status: New → In Progress
Martin Pitt (pitti) on 2013-04-09
Changed in update-notifier (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-notifier - 0.133

---------------
update-notifier (0.133) raring; urgency=low

  * Add data/package-system-locked: Check if package system is locked. This
    mirrors what com.ubuntu.SystemService.is_package_system_locked() from
    ubuntu-system-service used to do.
  * data/com.ubuntu.update-notifier.policy.in: Allow local users to run
    package-system-locked through pkexec.
  * src/update.c, dpkg_lock_is_taken(): Drop D-BUS call to
    ubuntu-system-service, call package-system-locked instead. Drop
    ubuntu-system-service Suggests:. (LP: #1153567)
 -- Martin Pitt <email address hidden> Tue, 09 Apr 2013 12:19:08 +0200

Changed in update-notifier (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers