"System error detected" window is not in the alt-tab list, can be lost

Bug #1076972 reported by Andreas Hasenack on 2012-11-09
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
update-notifier (Ubuntu)
High
Unassigned

Bug Description

Sometimes a "System error detected" window pops up in Ubuntu, alerting the user about this situation.

If you happen to be working on something else that is maximized, and hit alt-tab for some reason, you might lose the error window. It will get behind the maximized window and the only way to get back to it is to minimize everything until you find it.

In summary, the "system error detected" dialog is not in the list of windows you see when switching using "alt-tab" and I find it quite easy to lose.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: apport-gtk 2.6.1-0ubuntu6
ProcVersionSignature: Ubuntu 3.5.0-18.29-generic 3.5.7
Uname: Linux 3.5.0-18-generic i686
ApportVersion: 2.6.1-0ubuntu6
Architecture: i386
CrashReports:
 644:0:133:0:2012-11-09 09:37:13.622647228 -0200:2012-11-09 09:37:13.622647228 -0200:/var/crash/_usr_lib_udisks_udisks-daemon.0.upload
 640:0:133:5764356:2012-11-09 09:47:04.144415000 -0200:2012-11-09 09:52:15.405212100 -0200:/var/crash/_usr_lib_udisks_udisks-daemon.0.crash
 640:0:133:15534:2012-11-09 09:43:10.221431000 -0200:2012-11-09 09:43:11.221431000 -0200:/var/crash/_usr_bin_twistd.0.crash
 600:122:133:0:2012-11-09 09:41:12.776573633 -0200:2012-11-09 09:37:16.786647318 -0200:/var/crash/_usr_lib_udisks_udisks-daemon.0.uploaded
Date: Fri Nov 9 09:53:51 2012
InstallationDate: Installed on 2012-02-05 (277 days ago)
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha i386 (20120201.2)
MarkForUpload: True
PackageArchitecture: all
SourcePackage: apport
UpgradeStatus: Upgraded to quantal on 2012-10-29 (10 days ago)

Andreas Hasenack (ahasenack) wrote :
Jeremy Bicha (jbicha) wrote :

Here's a screenshot as this hasn't been fixed in Saucy yet.

Not only do they not show in the Alt-Tab switcher, but they don't show in Unity or GNOME Shell's visual list of running apps.

Changed in apport (Ubuntu):
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in apport (Ubuntu):
status: New → Confirmed
Jeremy Bicha (jbicha) on 2013-08-02
affects: apport (Ubuntu) → update-notifier (Ubuntu)
Changed in update-notifier (Ubuntu):
importance: Medium → High
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1076972

tags: added: iso-testing
Brian Murray (brian-murray) wrote :

The crash dialog now appears in the Alt-Tab list and an icon is show in the Launcher so I am setting this to Fix Released.

Changed in update-notifier (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers