package-data-downloader crashed with KeyError in convert(): 'paquetes'

Bug #1064545 reported by Richard Vajdel on 2012-10-09
278
This bug affects 62 people
Affects Status Importance Assigned to Milestone
update-notifier (Ubuntu)
High
Unassigned

Bug Description

Crash while updating.

ProblemType: Crash
DistroRelease: Ubuntu 12.10
Package: update-notifier-common 0.123
ProcVersionSignature: Ubuntu 3.5.0-17.27-generic 3.5.5
Uname: Linux 3.5.0-17-generic i686
ApportVersion: 2.6.1-0ubuntu2
Architecture: i386
Date: Tue Oct 9 19:14:41 2012
ExecutablePath: /usr/lib/update-notifier/package-data-downloader
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha i386 (20120905.2)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/lib/update-notifier/package-data-downloader
ProcEnviron:
 TERM=linux
 PATH=(custom, no user)
 LANG=sk_SK.UTF-8
PythonArgs: ['/usr/lib/update-notifier/package-data-downloader']
SourcePackage: update-notifier
Title: package-data-downloader crashed with KeyError in convert(): 'paquetes'
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

Richard Vajdel (riko442) wrote :
tags: removed: need-duplicate-check
Changed in update-notifier (Ubuntu):
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in update-notifier (Ubuntu):
status: New → Confirmed
C de-Avillez (hggdh2) on 2012-10-09
visibility: private → public
C de-Avillez (hggdh2) on 2012-10-09
tags: added: rls-q-incoming
Changed in update-notifier (Ubuntu):
importance: Medium → High
C de-Avillez (hggdh2) wrote :

This is a Quantal-Quantal dist-upgrade:

Setting up update-notifier-common (0.123) ...
flashplugin-installer: downloading http://archive.canonical.com/pool/partner/a/adobe-flashplugin/adobe-flashplugin_11.2.202.243.orig.tar.gz
Traceback (most recent call last):
  File "/usr/lib/update-notifier/package-data-downloader", line 296, in <module>
    process_download_requests()
  File "/usr/lib/update-notifier/package-data-downloader", line 292, in process_download_requests
    trigger_update_notifier(our_failures)
  File "/usr/lib/update-notifier/package-data-downloader", line 150, in trigger_update_notifier
    {'packages' : ", ".join(packages)}))
  File "/usr/lib/python2.7/string.py", line 172, in substitute
    return self.pattern.sub(convert, self.template)
  File "/usr/lib/python2.7/string.py", line 162, in convert
    val = mapping[named]
KeyError: 'paquetes'
dpkg: error processing update-notifier-common (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of flashplugin-installer:
 flashplugin-installer depends on update-notifier-common (>= 0.119ubuntu2); however:
  Package update-notifier-common is not configured yet.

dpkg: error processing flashplugin-installer (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of update-notifier:
 update-notifier depends on update-notifier-common (= 0.123); however:
  Package update-notifier-common is not configured yet.

dpkg: error processing update-notifier (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
                                                                                                          No apport report written because the error message indicates its a followup error from a previous failure.
                                                                                                                                                                                                                    Errors were encountered while processing:
 update-notifier-common
 flashplugin-installer
 update-notifier
E: Sub-process /usr/bin/dpkg returned an error code (1)
[cerdea-aws]cerdea@xango3:/build/buildd/qa-kernel-sru-tests$

Eric Chaskes (echaskes) wrote :

a dialog popped up titled "update information" (?) showing only the string "(null)"

Mike Pasche (mike-d-pasche) wrote :

Same -> a dialog popped up titled "update information" (?) showing only the string "(null)"

Sebastien Bacher (seb128) wrote :

update-notifier (0.125) quantal; urgency=low

  * There are other buggy translations, revert those as well.
  * Make sure our tests are actually run at build time.
  * Add a new test for broken translations, and fix the test for the notifier
    output which had not been kept in sync with the source.

update-notifier (0.124) quantal; urgency=low

  * Revert buggy translation of a variable name, addressing bug #1003100.

Changed in update-notifier (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers