update-notifier steals focus

Bug #1052201 reported by Michał Sawicz on 2012-09-17
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
update-notifier (Ubuntu)
High
Unassigned

Bug Description

Whenever update-notifier pops up about an update, it steals focus from whatever app is focused.

It's annoying, 'cause it will interrupt your work, even though the window itself opens minimized and the results appears to be that the app lost focus without the notifier actually popping to the front.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: update-notifier 0.122
ProcVersionSignature: Ubuntu 3.5.0-14.19-generic 3.5.3
Uname: Linux 3.5.0-14-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 2.5.2-0ubuntu1
Architecture: amd64
Date: Mon Sep 17 23:25:42 2012
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120724.3)
SourcePackage: update-notifier
UpgradeStatus: No upgrade log present (probably fresh install)

Michał Sawicz (saviq) wrote :
Changed in update-notifier (Ubuntu):
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in update-notifier (Ubuntu):
status: New → Confirmed

as far as I can see it, the update notifier calls the update-manager with the option

--no-focus-on-map

when I run

update-manager --no-focus-on-map

it start minimized and steals the focus from the current application. So this should be fixed in update-manager and not update modifier right? Can anyone confirm this?

vmerlet (vincent-merlet) wrote :

When I run (under graphical environment) :

update-manager --no-focus-on-map

It works :
- start minimized
- when clicking on the icon in taskbar : it shows the main app as expeted

When I run (under tty1) :

DISPLAY=:0 update-manager --no-focus-on-map

It fails :
- start minimized
- but when clicking on the icon in taskbar : it doesn't show up as expected (same behaviour described in this bug report)

Don't know however if it's the good way to reproduce this bug.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers