package xkb-data 2.5-1ubuntu1 failed to install/upgrade: subprocess installed post-installation script was killed by signal (Terminated)

Bug #990138 reported by Pavol Dovicovic on 2012-04-27
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Undecided
Unassigned

Bug Description

I tried to upgrade my Ubuntu 10.04 LTS to 12.04 LTS on my Lenovo W500 4062-J2G notebook, but upgrade process failed few minutes before end, screen was blinking between GUI and text mode, after one hour I decided to turn off the system. After restart system did not boot properly, only if I used recovery mode. Then I tried to run uograde again, but without success. The only thing which worked was activation of graphics card driver. Then reboot and finally I was able to log on. But almost every app. I run has problem with package as you can see in summary. Maybe it is not a bug, but system started bug report process, so I decided to send it anyway.

ProblemType: Package
DistroRelease: Ubuntu 12.04
Package: xkb-data 2.5-1ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-24.37-generic 3.2.14
Uname: Linux 3.2.0-24-generic x86_64
NonfreeKernelModules: fglrx
ApportVersion: 2.0.1-0ubuntu7
Architecture: amd64
Date: Fri Apr 27 22:20:51 2012
Dependencies:

DistUpgraded: 2012-04-27 22:20:25,468 ERROR incorrect translation for ngettext message '%li second' plural: '%li seconds' to 'sekunda' (wrong number of arguments)
DistroCodename: precise
DistroVariant: ubuntu
DuplicateSignature:
 Setting up xkb-data (2.5-1ubuntu1) ...
 g_dbus_connection_real_closed: Remote peer vanished with error: Underlying GIOStream returned 0 bytes on an async read (g-io-error-quark, 0). Exiting.
 dpkg: error processing xkb-data (--configure):
  subprocess installed post-installation script was killed by signal (Terminated)
ErrorMessage: subprocess installed post-installation script was killed by signal (Terminated)
InstallationMedia: Ubuntu 10.04.2 LTS "Lucid Lynx" - Release amd64 (20110211.1)
MachineType: LENOVO 40612JG
PackageArchitecture: all
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-24-generic root=UUID=22bb122c-ac93-4e73-8067-9e28bb716529 ro quiet splash vt.handoff=7
SourcePackage: xkeyboard-config
Title: package xkb-data 2.5-1ubuntu1 failed to install/upgrade: subprocess installed post-installation script was killed by signal (Terminated)
UpgradeStatus: Upgraded to precise on 2012-04-27 (0 days ago)
dmi.bios.date: 12/03/2010
dmi.bios.vendor: LENOVO
dmi.bios.version: 6FET87WW (3.17 )
dmi.board.name: 40612JG
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr6FET87WW(3.17):bd12/03/2010:svnLENOVO:pn40612JG:pvrThinkPadW500:rvnLENOVO:rn40612JG:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 40612JG
dmi.product.version: ThinkPad W500
dmi.sys.vendor: LENOVO
version.compiz: compiz 1:0.9.7.6-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.32-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.2-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.2-0ubuntu3
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu10
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.0-0ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2

tags: removed: need-duplicate-check
Bryce Harrington (bryce) wrote :

I think the xkeyboard-config error is just a side-effect of the upgrade failure. Probably if you complete the upgrade and reconfigure the package, it should work properly then.

affects: xkeyboard-config (Ubuntu) → ubuntu
shankao (shankao) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage . I have classified this bug as a bug in update-manager.

When reporting bugs in the future please use apport by using 'ubuntu-bug' and the name of the package affected. You can learn more about this functionality at https://help.ubuntu.com/community/ReportingBugs.

affects: ubuntu → update-manager (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers