Wrong distro name reported available for upgrade

Bug #990091 reported by SteVe Cook on 2012-04-27
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Undecided
Unassigned

Bug Description

"New *Ubuntu* release '12.04 LTS' is available" offered as an upgrade instead of "New *Lubuntu* release '12.04 LTS' is available".
This does not effect the upgrade procedure but, has caused confusion as to what the result will be, Ubuntu or Lubuntu.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: update-manager 1:0.152.25.9
ProcVersionSignature: Ubuntu 3.0.0-19.33-generic 3.0.27
Uname: Linux 3.0.0-19-generic i686
ApportVersion: 1.23-0ubuntu4
Architecture: i386
Date: Fri Apr 27 21:29:27 2012
InstallationMedia: Lubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
PackageArchitecture: all
SourcePackage: update-manager
UpgradeStatus: No upgrade log present (probably fresh install)

SteVe Cook (yorvyk) wrote :
amjjawad  (amjjawad) wrote :

It has nothing to do with Lubuntu but with ALL the other variants, just like Xubuntu. Why? I think, IMHO, because all share the same core system. Not sure if it is possible to fix but I do hope so because it caused so much confusion.

http://i47.tinypic.com/2dtyiv9.jpg

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in update-manager (Ubuntu):
status: New → Confirmed
Erick Brunzell (lbsolost) wrote :

Is this not the same reason Ubuntu shows up in grub rather than the actual distro name?

kroq-gar78 (kroq-gar78) wrote :

Yes, I'm pretty sure it's the same reason; Lubuntu is just a variant of Ubuntu and uses the same core systems. This is why it says "Ubuntu 12.04" instead of "Lubuntu 12.04".

amjjawad  (amjjawad) wrote :

I don't think this will ever be changed as long as both Lubuntu and Ubuntu share the same 'core' system. Having that said, I am not sure if it is good idea to keep this bug and not mark it as invalid.

dino99 (9d9) wrote :

This version has expired

Changed in update-manager (Ubuntu):
status: Confirmed → Invalid
Adolfo Jayme (fitojb) on 2015-11-24
Changed in update-manager (Ubuntu):
status: Invalid → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers